- Update chinese/fcitx-googlepinyin to 0.1.4

- Update chinese/fcitx-configtool to 0.4.0
- Update chinese/fcitx-cloudpinyin to 0.2.0
- Update chinese/fcitx-sunpinyin to 0.3.3
- Update chinese/fcitx to 4.2.2
- Update textproc/fcitx-keyboard to 0.1.0

PR:		ports/166689
Submitted by:	Zhihao Yuan <lichray@gmail.com> (maintainer)
This commit is contained in:
Michael Scheidell 2012-04-30 22:57:38 +00:00
parent 270ea2ece5
commit 18b73e0fe0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295745
21 changed files with 106 additions and 87 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= fcitx-cloudpinyin
PORTVERSION= 0.2.0
PORTVERSION= 0.2.1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@ -17,7 +17,7 @@ COMMENT= A cloud-based Pinyin module for Fcitx
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
curl:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
USE_XZ= yes
USE_GETTEXT= yes
USE_CMAKE= yes
USE_GNOME= intltool

View File

@ -1,2 +1,2 @@
SHA256 (fcitx/fcitx-cloudpinyin-0.2.0.tar.bz2) = a485b52169fab47ce4658cb1e520f965be85b38676fc4fd215f2447ea6db67d1
SIZE (fcitx/fcitx-cloudpinyin-0.2.0.tar.bz2) = 19275
SHA256 (fcitx/fcitx-cloudpinyin-0.2.1.tar.xz) = 548a08a2a1585c5dc13c5bf6116197203dafc2c475efdf5b6e57bdb900cb2cac
SIZE (fcitx/fcitx-cloudpinyin-0.2.1.tar.xz) = 18388

View File

@ -6,18 +6,18 @@
#
PORTNAME= fcitx-configtool
PORTVERSION= 0.4.0
PORTVERSION= 0.4.2
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= Fcitx IM configure tool
COMMENT= Fcitx IM framework configure tool
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx
USE_BZIP2= yes
USE_XZ= yes
USE_GNOME= intltool gnomehack
USE_GETTEXT= yes
USE_CMAKE= yes

View File

@ -1,2 +1,2 @@
SHA256 (fcitx/fcitx-configtool-0.4.0.tar.bz2) = 580a531838c27a1446d1b8ad33d84e44fa729c1b178deff4b9736d316d754640
SIZE (fcitx/fcitx-configtool-0.4.0.tar.bz2) = 32124
SHA256 (fcitx/fcitx-configtool-0.4.2.tar.xz) = 98e1c14c3737e13a6340eb093f7f5391e4cd973e147aec8c9e49f41b3a1904b7
SIZE (fcitx/fcitx-configtool-0.4.2.tar.xz) = 33724

View File

@ -1,4 +1,4 @@
Fcitx is a simple and fast Chinese XIM server. It comes with a script,
Fcitx is a flexible input method framework. It comes with a script,
fcitx-configtool, which looks for this configure tool and invokes it.
WWW: http://code.google.com/p/fcitx/

View File

@ -6,7 +6,7 @@
#
PORTNAME= fcitx-googlepinyin
PORTVERSION= 0.1.4
PORTVERSION= 0.1.5
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@ -17,7 +17,7 @@ COMMENT= A libgooglepinyin support for Fcitx
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
googlepinyin.0:${PORTSDIR}/chinese/libgooglepinyin
USE_BZIP2= yes
USE_XZ= yes
USE_GETTEXT= yes
USE_CMAKE= yes
USE_GNOME= intltool

View File

@ -1,2 +1,2 @@
SHA256 (fcitx/fcitx-googlepinyin-0.1.4.tar.bz2) = f6152d5ba0cf310f8b46f16b4f89ca7d57563fd3607f2b152595c5994cbe0f63
SIZE (fcitx/fcitx-googlepinyin-0.1.4.tar.bz2) = 20812
SHA256 (fcitx/fcitx-googlepinyin-0.1.5.tar.xz) = f74ac4b40d11002a0dfc49572475a9b9d9671755b9c77bbc7a091d6e0849ab8d
SIZE (fcitx/fcitx-googlepinyin-0.1.5.tar.xz) = 20776

View File

@ -1,11 +1,11 @@
--- src/eim.cpp~ 2012-01-31 09:03:36.000000000 -0600
+++ src/eim.cpp 2012-02-06 02:13:29.145600582 -0600
@@ -466,7 +466,7 @@ void* FcitxGooglePinyinCreate (FcitxInst
if (fp)
fclose(fp);
- bool result = ime_pinyin::im_open_decoder(LIBDIR "/googlepinyin/data/dict_pinyin.dat", userDict);
+ bool result = ime_pinyin::im_open_decoder(DATADIR "/googlepinyin/dict_pinyin.dat", userDict);
if (userDict)
free(userDict);
--- src/eim.cpp.orig 2012-03-08 22:07:27.000000000 -0600
+++ src/eim.cpp 2012-04-06 02:04:15.502210235 -0500
@@ -476,7 +476,7 @@ void* FcitxGooglePinyinCreate (FcitxInst
else
#endif
{
- syspath = strdup(GOOGLEPINYIN_LIBDIR "/googlepinyin/data/dict_pinyin.dat");
+ syspath = strdup(GOOGLEPINYIN_LIBDIR "/../share/googlepinyin/dict_pinyin.dat");
}
bool result = ime_pinyin::im_open_decoder(syspath, userDict);
free(syspath);

View File

@ -1,4 +1,4 @@
fcitx-googlepinyin provides libgooglepinyin, a fork of Google Pinyin IME
on Android, as a back-end to the Fcitx IM server.
on Android, as a back-end to the Fcitx IM framework.
WWW: http://code.google.com/p/fcitx/

View File

@ -6,7 +6,7 @@
#
PORTNAME= fcitx-sunpinyin
PORTVERSION= 0.3.3
PORTVERSION= 0.3.5
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@ -17,7 +17,7 @@ COMMENT= SunPinyin support for Fcitx
LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
sunpinyin.3:${PORTSDIR}/chinese/sunpinyin
USE_BZIP2= yes
USE_XZ= yes
USE_GETTEXT= yes
USE_CMAKE= yes
USE_GNOME= intltool

View File

@ -1,2 +1,2 @@
SHA256 (fcitx/fcitx-sunpinyin-0.3.3.tar.bz2) = e9cb352ca05fd2dc9e366f9c35e2cdd6747a8aafc5ca5ae4fdce002b0ec21dba
SIZE (fcitx/fcitx-sunpinyin-0.3.3.tar.bz2) = 43224
SHA256 (fcitx/fcitx-sunpinyin-0.3.5.tar.xz) = 932b74eafb86f9051400a311c4da09ad4888190015e667eea3c4019934f67b62
SIZE (fcitx/fcitx-sunpinyin-0.3.5.tar.xz) = 40248

View File

@ -1,11 +0,0 @@
--- CMakeLists.txt~ 2011-09-29 01:58:59.000000000 -0500
+++ CMakeLists.txt 2011-11-10 23:22:41.804644040 -0600
@@ -10,7 +10,7 @@ FIND_PACKAGE(Libintl REQUIRED)
FIND_PACKAGE(Gettext REQUIRED)
FIND_PACKAGE(Fcitx 4.1.2 REQUIRED)
-PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.4" )
+PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.3" )
# uninstall target
configure_file(

View File

@ -0,0 +1,11 @@
--- cmake/FindSunpinyin.cmake~ 2012-03-04 21:43:53.000000000 -0600
+++ cmake/FindSunpinyin.cmake 2012-04-06 02:14:47.564463773 -0500
@@ -16,7 +16,7 @@ if(SUNPINYIN_INCLUDE_DIR AND SUNPINYIN_L
endif(SUNPINYIN_INCLUDE_DIR AND SUNPINYIN_LIBRARIES)
find_package(PkgConfig REQUIRED)
-pkg_check_modules(PC_LIBSUNPINYIN "sunpinyin-2.0 >= 2.0.4")
+pkg_check_modules(PC_LIBSUNPINYIN "sunpinyin-2.0 >= 2.0.3")
find_path(SUNPINYIN_MAIN_INCLUDE_DIR
NAMES sunpinyin.h

View File

@ -1,4 +1,4 @@
fcitx-sunpinyin provides SunPinyin, a statistical language model based
input method engine, as a back-end to the Fcitx IM server.
input method engine, as a back-end to the Fcitx IM framework.
WWW: http://code.google.com/p/fcitx/

View File

@ -6,7 +6,7 @@
#
PORTNAME= fcitx
PORTVERSION= 4.2.0
PORTVERSION= 4.2.2
CATEGORIES= chinese x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pinyin.tar.gz table.tar.gz
@ -14,7 +14,7 @@ DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= lichray@gmail.com
COMMENT= A simple and fast GBK Chinese XIM server
COMMENT= A Flexible Input Method Framework
LICENSE= GPLv2
@ -25,7 +25,7 @@ RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
MAN1= createPYMB.1 fcitx-remote.1 fcitx.1 mb2org.1 mb2txt.1 \
readPYBase.1 readPYMB.1 scel2org.1 txt2mb.1
USE_BZIP2= yes
USE_XZ= yes
USE_GNOME= pango intltool gnomehack
USE_GETTEXT= yes
USE_XORG= x11 xext

View File

@ -1,6 +1,6 @@
SHA256 (fcitx/fcitx-4.2.0.tar.bz2) = 1410141f91321ec0c2514b8a9b3ff13ce3af82841036264f5a8b7ad005b139e5
SIZE (fcitx/fcitx-4.2.0.tar.bz2) = 785160
SHA256 (fcitx/pinyin.tar.gz) = bf8c581450f9fac0eab0498927d1d5e5c1cd465ed9937e4d9362ca9d67920fa4
SIZE (fcitx/pinyin.tar.gz) = 1613447
SHA256 (fcitx/fcitx-4.2.2.tar.xz) = 1d18096232a700ddcf059e737b6acb2b292e5a4ae5d4bc2714e4f599e4e6daa6
SIZE (fcitx/fcitx-4.2.2.tar.xz) = 585936
SHA256 (fcitx/pinyin.tar.gz) = 583829b24a758c087c08de4a69480d0bf5946354fe77db360d6d7f467c2bd8e1
SIZE (fcitx/pinyin.tar.gz) = 1608886
SHA256 (fcitx/table.tar.gz) = 6196053c724125e3ae3d8bd6b2f9172d0c83b65b0d410d3cde63b7a8d6ab87b7
SIZE (fcitx/table.tar.gz) = 4144686

View File

@ -1,22 +1,22 @@
--- data/punc.mb.zh_CN~ 2012-02-01 10:41:59.000000000 -0600
+++ data/punc.mb.zh_CN 2012-02-06 01:32:03.879099301 -0600
--- data/punc.mb.zh_CN.orig 2012-02-01 10:41:59.000000000 -0600
+++ data/punc.mb.zh_CN 2012-03-05 09:20:53.636598589 -0600
@@ -1,10 +1,10 @@
. 。
, ,
? ?
-" “ ”
+" 「 」
: :
; ;
-' ‘ ’
+' 『 』
< 《
> 》
\ 、
@@ -17,4 +17,4 @@ _ ——
) )
[ ·
] ï¼» ï¼½
-~ ~
.
,
?
-" “ ”
+" 「 」
:
;
-'
+' 『 』
<
>
\
@@ -17,4 +17,4 @@ _ ——
)
[ ·
]
-~
\ No newline at end of file
+~ ~
+~

View File

@ -1,7 +1,4 @@
Fcitx is a simple and fast GBK Chinese XIM server. It stands for Free
Chinese Input Toy for X, an input method for Unix-like operating systems.
To be more precise, it is a collection of Simplified Chinese input methods
based on XIM (X Input Method), including WuBi, PinYin, and QuWei, and is
distributed under GPL. It is the descendent of gWuBi.
Fcitx (Free Chinese Input Toy for X) is an input method framework,
which aims to provide a flexible IM solution for the desktop environments.
WWW: http://code.google.com/p/fcitx/

View File

@ -100,6 +100,7 @@ share/cmake/fcitx/FcitxMacro.cmake
%%DATADIR%%/configdesc/fcitx-chttrans.desc
%%DATADIR%%/configdesc/fcitx-classic-ui.desc
%%DATADIR%%/configdesc/fcitx-pinyin.desc
%%DATADIR%%/configdesc/fcitx-quickphrase.desc
%%DATADIR%%/configdesc/fcitx-xim.desc
%%DATADIR%%/configdesc/inputmethod.desc
%%DATADIR%%/configdesc/profile.desc
@ -132,6 +133,7 @@ share/cmake/fcitx/FcitxMacro.cmake
%%DATADIR%%/skin/classic/fullwidth_inactive.png
%%DATADIR%%/skin/classic/inactive.png
%%DATADIR%%/skin/classic/input.png
%%DATADIR%%/skin/classic/kbd.png
%%DATADIR%%/skin/classic/logo.png
%%DATADIR%%/skin/classic/menu.png
%%DATADIR%%/skin/classic/next.png
@ -164,6 +166,7 @@ share/cmake/fcitx/FcitxMacro.cmake
%%DATADIR%%/skin/dark/fullwidth_inactive.png
%%DATADIR%%/skin/dark/inactive.png
%%DATADIR%%/skin/dark/input.png
%%DATADIR%%/skin/dark/kbd.png
%%DATADIR%%/skin/dark/keyboard.png
%%DATADIR%%/skin/dark/logo.png
%%DATADIR%%/skin/dark/menu.png
@ -197,6 +200,7 @@ share/cmake/fcitx/FcitxMacro.cmake
%%DATADIR%%/skin/default/fullwidth_inactive.png
%%DATADIR%%/skin/default/inactive.png
%%DATADIR%%/skin/default/input.png
%%DATADIR%%/skin/default/kbd.png
%%DATADIR%%/skin/default/keyboard.png
%%DATADIR%%/skin/default/logo.png
%%DATADIR%%/skin/default/menu.png
@ -231,6 +235,13 @@ share/cmake/fcitx/FcitxMacro.cmake
%%DATADIR%%/table/wbx.mb
%%DATADIR%%/table/zrm.conf
%%DATADIR%%/table/zrm.mb
share/icons/gnome/scalable/status/fcitx-fullwidth-active.svg
share/icons/gnome/scalable/status/fcitx-fullwidth-inactive.svg
share/icons/gnome/scalable/status/fcitx-kbd.svg
share/icons/gnome/scalable/status/fcitx-punc-active.svg
share/icons/gnome/scalable/status/fcitx-punc-inactive.svg
share/icons/gnome/scalable/status/fcitx-vk-active.svg
share/icons/gnome/scalable/status/fcitx-vk-inactive.svg
share/icons/hicolor/128x128/apps/fcitx.png
share/icons/hicolor/16x16/apps/fcitx.png
share/icons/hicolor/16x16/status/fcitx-fullwidth-active.png
@ -240,6 +251,14 @@ share/icons/hicolor/16x16/status/fcitx-punc-active.png
share/icons/hicolor/16x16/status/fcitx-punc-inactive.png
share/icons/hicolor/16x16/status/fcitx-vk-active.png
share/icons/hicolor/16x16/status/fcitx-vk-inactive.png
share/icons/hicolor/22x22/apps/fcitx.png
share/icons/hicolor/22x22/status/fcitx-fullwidth-active.png
share/icons/hicolor/22x22/status/fcitx-fullwidth-inactive.png
share/icons/hicolor/22x22/status/fcitx-kbd.png
share/icons/hicolor/22x22/status/fcitx-punc-active.png
share/icons/hicolor/22x22/status/fcitx-punc-inactive.png
share/icons/hicolor/22x22/status/fcitx-vk-active.png
share/icons/hicolor/22x22/status/fcitx-vk-inactive.png
share/icons/hicolor/24x24/apps/fcitx.png
share/icons/hicolor/24x24/status/fcitx-fullwidth-active.png
share/icons/hicolor/24x24/status/fcitx-fullwidth-inactive.png
@ -269,19 +288,22 @@ share/icons/hicolor/48x48/status/fcitx-vk-inactive.png
share/icons/hicolor/48x48/status/fcitx-wbpy.png
share/icons/hicolor/48x48/status/fcitx-wubi.png
share/icons/hicolor/48x48/status/fcitx-ziranma.png
share/icons/hicolor/scabable/status/fcitx-fullwidth-active.svg
share/icons/hicolor/scabable/status/fcitx-fullwidth-inactive.svg
share/icons/hicolor/scabable/status/fcitx-kbd.svg
share/icons/hicolor/scabable/status/fcitx-punc-active.svg
share/icons/hicolor/scabable/status/fcitx-punc-inactive.svg
share/icons/hicolor/scabable/status/fcitx-vk-active.svg
share/icons/hicolor/scabable/status/fcitx-vk-inactive.svg
share/icons/hicolor/scalable/status/fcitx-fullwidth-active.svg
share/icons/hicolor/scalable/status/fcitx-fullwidth-inactive.svg
share/icons/hicolor/scalable/status/fcitx-kbd.svg
share/icons/hicolor/scalable/status/fcitx-punc-active.svg
share/icons/hicolor/scalable/status/fcitx-punc-inactive.svg
share/icons/hicolor/scalable/status/fcitx-vk-active.svg
share/icons/hicolor/scalable/status/fcitx-vk-inactive.svg
share/locale/zh_CN/LC_MESSAGES/fcitx.mo
share/locale/zh_TW/LC_MESSAGES/fcitx.mo
share/mime/packages/x-fskin.xml
@dirrmtry share/applications
@dirrmtry share/icons/hicolor/scabable/status
@dirrmtry share/icons/hicolor/scabable
@dirrmtry share/icons/gnome/scalable/status
@dirrmtry share/icons/gnome/scalable
@dirrmtry share/icons/gnome
@dirrmtry share/icons/hicolor/scalable/status
@dirrmtry share/icons/hicolor/scalable
@dirrm %%DATADIR%%/table
@dirrm %%DATADIR%%/skin/default
@dirrm %%DATADIR%%/skin/dark

View File

@ -6,7 +6,7 @@
#
PORTNAME= fcitx-keyboard
PORTVERSION= 0.1.0
PORTVERSION= 0.1.2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= fcitx
@ -19,7 +19,7 @@ LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
enchant.1:${PORTSDIR}/textproc/enchant \
icuuc.48:${PORTSDIR}/devel/icu
USE_BZIP2= yes
USE_XZ= yes
USE_GETTEXT= yes
USE_CMAKE= yes
USE_GNOME= intltool libxml2

View File

@ -1,2 +1,2 @@
SHA256 (fcitx/fcitx-keyboard-0.1.0.tar.bz2) = 09813e57cdebe24c6405b0fcef3b72e045b58c527c733dbc45689fcc3cef0c13
SIZE (fcitx/fcitx-keyboard-0.1.0.tar.bz2) = 45518
SHA256 (fcitx/fcitx-keyboard-0.1.2.tar.xz) = de62e60f9a2e23836885f893f8c475b02ce5c6b93fcc8af7ec5b626a1c0b0a95
SIZE (fcitx/fcitx-keyboard-0.1.2.tar.xz) = 42060