New ports: games/voxelands and games/voxelands-server
A voxel sandbox game forked from minetest: http://www.voxelands.com/ PR: 201069 Submitted by: dcmenche@gmail.com (maintainer) Reviewed by: mat Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D8379
This commit is contained in:
parent
d8fee16f8e
commit
18b723cbb8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425080
@ -1019,6 +1019,8 @@
|
||||
SUBDIR += vodovod
|
||||
SUBDIR += volleyball
|
||||
SUBDIR += vor
|
||||
SUBDIR += voxelands
|
||||
SUBDIR += voxelands-server
|
||||
SUBDIR += vultures-eye
|
||||
SUBDIR += wanderer
|
||||
SUBDIR += wargus
|
||||
|
9
games/voxelands-server/Makefile
Normal file
9
games/voxelands-server/Makefile
Normal file
@ -0,0 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PKGNAMESUFFIX= -server
|
||||
OPTIONS_SLAVE= SERVER
|
||||
OPTIONS_EXCLUDE=CLIENT NLS SOUND
|
||||
COMMENT= Server component for Voxelands
|
||||
MASTERDIR= ${.CURDIR}/../voxelands
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
8
games/voxelands-server/pkg-descr
Normal file
8
games/voxelands-server/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
Server component for Voxelands.
|
||||
|
||||
Voxelands is a sandbox construction game based on Minetest, which was
|
||||
inspired by earlier "voxel world" games such as Infiniminer. Gameplay puts
|
||||
players in a fully destructible 3D game world where they can place and dig
|
||||
numerous types of blocks, items and creatures using a variety of tools.
|
||||
|
||||
WWW: http://voxelands.com
|
51
games/voxelands/Makefile
Normal file
51
games/voxelands/Makefile
Normal file
@ -0,0 +1,51 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= voxelands
|
||||
PORTVERSION= 1604.00
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://voxelands.com/downloads/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= dcmenche@gmail.com
|
||||
COMMENT?= Fun-Focused voxel world game
|
||||
|
||||
LICENSE= GPLv3+
|
||||
|
||||
LIB_DEPENDS= libIrrlicht.so:x11-toolkits/irrlicht \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= cmake tar:bzip2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
OPTIONS_DEFINE= NLS SOUND SQLITE3
|
||||
OPTIONS_MULTI= BINARIES
|
||||
OPTIONS_MULTI_BINARIES= CLIENT SERVER
|
||||
|
||||
OPTIONS_DEFAULT= SOUND CLIENT SERVER
|
||||
|
||||
OPTIONS_SLAVE?= CLIENT
|
||||
OPTIONS_EXCLUDE?= SERVER
|
||||
|
||||
SOUND_DESC= Enable menu background music and in-game sound effects
|
||||
SQLITE3_DESC= Use bundled SQLite3 instead of databases/sqlite3
|
||||
|
||||
CLIENT_CMAKE_BOOL= BUILD_CLIENT
|
||||
CLIENT_LIB_DEPENDS= libpng16.so:graphics/png \
|
||||
libjpeg.so:graphics/jpeg
|
||||
CLIENT_USE= xorg=x11,xxf86vm gl=gl
|
||||
CLIENT_USES= jpeg
|
||||
NLS_USES= gettext
|
||||
NLS_CMAKE_BOOL= GETTEXT_FOUND
|
||||
SERVER_CMAKE_BOOL= BUILD_SERVER
|
||||
SQLITE3_CMAKE_ON= -DSQLITE3_INCLUDE_DIR=SQLITE3_INCLUDE_DIR-NOTFOUND \
|
||||
SQLITE3_LIBRARY=SQLITE3_LIBRARY-NOTFOUND
|
||||
SQLITE3_LIB_DEPENDS_OFF=libsqlite3.so:databases/sqlite3
|
||||
SOUND_CMAKE_BOOL= ENABLE_AUDIO
|
||||
SOUND_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
|
||||
libogg.so:audio/libogg \
|
||||
libopenal.so:audio/openal-soft
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/voxelands/distinfo
Normal file
3
games/voxelands/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1477789212
|
||||
SHA256 (voxelands-1604.00-src.tar.bz2) = 411453c3271bd4cf2ff464a0ba006e2b63157d687a4f6331b28336d5038c8e20
|
||||
SIZE (voxelands-1604.00-src.tar.bz2) = 10739562
|
11
games/voxelands/files/patch-CMakeLists.txt
Normal file
11
games/voxelands/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt.orig 2016-10-29 06:01:08 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -80,7 +80,7 @@ elseif(UNIX) # Linux, BSD etc
|
||||
set(SHAREDIR "${CMAKE_INSTALL_PREFIX}/share/${PROJECT_NAME}")
|
||||
set(BINDIR "${CMAKE_INSTALL_PREFIX}/bin")
|
||||
set(DOCDIR "${CMAKE_INSTALL_PREFIX}/share/doc/${PROJECT_NAME}")
|
||||
- set(MANDIR "${CMAKE_INSTALL_PREFIX}/share/man")
|
||||
+ set(MANDIR "${CMAKE_INSTALL_PREFIX}/man")
|
||||
set(EXAMPLE_CONF_DIR ${DOCDIR})
|
||||
set(XDG_APPS_DIR "${CMAKE_INSTALL_PREFIX}/share/applications")
|
||||
set(APPDATADIR "${CMAKE_INSTALL_PREFIX}/share/appdata")
|
6
games/voxelands/pkg-descr
Normal file
6
games/voxelands/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Voxelands is a sandbox construction game based on Minetest, which was
|
||||
inspired by earlier "voxel world" games such as Infiniminer. Gameplay puts
|
||||
players in a fully destructible 3D game world where they can place and dig
|
||||
numerous types of blocks, items and creatures using a variety of tools.
|
||||
|
||||
WWW: http://voxelands.com
|
1317
games/voxelands/pkg-plist
Normal file
1317
games/voxelands/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user