Update to 0.50.35-1

PR:		37753
Submitted by:	maintainer
This commit is contained in:
Patrick Li 2002-05-04 17:27:55 +00:00
parent 857aafeab4
commit 18b6594d6c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=58532
5 changed files with 75 additions and 102 deletions

View File

@ -22,7 +22,7 @@ BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang \
popt.0:${PORTSDIR}/devel/popt
RPMVERSION= 0.50.33
RPMVERSION= 0.50.35
RPMREVISION= 1
WRKSRC= ${WRKDIR}/newt-${RPMVERSION}
@ -65,7 +65,7 @@ post-build:
@cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${FILESDIR}/setup.py build
post-install:
@cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${FILESDIR}/setup.py install
@cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${FILESDIR}/setup.py install --prefix=${PREFIX}
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/peanuts.py ${WRKSRC}/popcorn.py ${EXAMPLESDIR}

View File

@ -1 +1 @@
MD5 (newt-0.50.33-1.src.rpm) = b8801b4aed32741859c061b791529159
MD5 (newt-0.50.35-1.src.rpm) = b436cb502a7ac3681a8d08b30a5a8ee1

View File

@ -1,5 +1,5 @@
--- grid.c.orig Mon Feb 8 16:41:47 1999
+++ grid.c Sat Jul 22 01:14:25 2000
--- grid.c.orig Sun May 5 00:23:33 2002
+++ grid.c Sun May 5 00:23:45 2002
@@ -1,4 +1,3 @@
-#include <alloca.h>
#include <stdlib.h>

View File

@ -1,60 +1,56 @@
--- Makefile.in.orig Tue Jan 23 15:27:38 2001
+++ Makefile.in Sun Mar 17 17:46:32 2002
@@ -1,18 +1,14 @@
--- Makefile.in.orig Tue Mar 19 02:31:59 2002
+++ Makefile.in Sun May 5 01:17:55 2002
@@ -1,23 +1,25 @@
-LIBS = -lslang -lm #-lefence
-SHLIBS = -lslang -lm -lc
+CC ?= cc
+LIBS = -L$(PREFIX)/lib -lslang -lpopt -lncurses -lm
+TCLLIBS = -l${TCLVERSION:S/.//g}
+SHLIBS = $(LIBS)
+LIBS = -lslang -lm -lpopt -lncurses #-lefence
+SHLIBS = -lslang -lm -lc -lpopt -lncurses
-GPM_SUPPORT=@gpm_support@
+CFLAGS = $(PCFLAGS) -Wall -I$(prefix)/include -I$(prefix)/include/${TCLVERSION}
GPM_SUPPORT=@gpm_support@
-CFLAGS = $(RPM_OPT_FLAGS) -Wall -I/usr/include/slang
-ifeq ($(RPM_OPT_FLAGS),)
-CFLAGS += -g # -O2 -I/usr/include/slang
-endif
+VERSION ?= 0
+SONAME = ${VERSION}
+CFLAGS += -I${LOCALBASE}/include -I${PREFIX}/include
+LDFLAGS += -L${LOCALBASE}/lib -L${PREFIX}/lib
-VERSION = @VERSION@
-CVSTAG = r$(subst .,-,$(VERSION))
-SONAME = @SONAME@
-
-PROGS = test whiptail whiptcl.so testgrid testtree
CVSTAG = r$(subst .,-,$(VERSION))
SONAME = @SONAME@
PYTHONVERS = $(shell ls -d /usr/include/python* | sed "s|/usr/include/||g")
-WHIPTCLSO=
-#WHIPTCLSO=whiptcl.so
+.if defined(WITH_TCL)
+WHIPTCLSO=whiptcl.so
+CFLAGS += -I${LOCALBASE}/include/${TCLVERSION}
+LDFLAGS += -L${LOCALBASE}/lib/${TCLVERSION}
+SHLIBS += -l${TCLVERSION:S,.,,}
+.endif
+TARGET=${LIBNEWT} ${PROGS} ${WHIPTCLSO}
-PROGS = test whiptail $(WHIPTCLSO) testgrid testtree
+PROGS = test whiptail testgrid testtree
TESTOBJS = test.o
NDIALOGOBJS = whiptail.o dialogboxes.o
WHIPTCLOBJS = whiptcl.o dialogboxes.o
@@ -25,51 +21,50 @@
@@ -30,7 +32,7 @@
SHCFLAGS = -fPIC
-prefix = /usr
+prefix ?= ${PREFIX}
+prefix = ${PREFIX}
includedir = $(prefix)/include
libdir = $(prefix)/lib
bindir = $(prefix)/bin
-ARCHNAME = $(shell uname -m | sed 's/i.86/i386/')
pythondir = $(prefix)/lib/python1.5
pythonbindir = $(prefix)/lib/python1.5/lib-dynload
#--------------------------------------
-SOURCES = $(subst .o,.c,$(TESTOBJS) $(NDIALOGOBJS) $(LIBOBJS))
+SOURCES = ${TESTOBJS:S/.o/.c/g} ${NDIALOGOBJS:S/.o/.c/g} ${LIBOBJS:S/.o/.c/g}
@@ -41,41 +43,37 @@
SOURCES = $(subst .o,.c,$(TESTOBJS) $(NDIALOGOBJS) $(LIBOBJS))
SHAREDDIR = shared
SHAREDOBJS = $(patsubst %,$(SHAREDDIR)/%, $(LIBOBJS))
+.if defined(WITH_TCL)
+TCLTARGET=whiptcl.so
+.endif
+TARGET=${PROGS} ${TCLTARGET}
+
+.if !exists(.depend)
+TARGET+=depend
+.endif
-SHAREDOBJS = $(patsubst %,$(SHAREDDIR)/%, $(LIBOBJS))
+SHAREDOBJS = ${LIBOBJS}
-ifeq (.depend,$(wildcard .depend))
-TARGET=$(PROGS)
@ -67,31 +63,34 @@
test: $(TESTOBJS) $(LIBNEWT)
- gcc -g -o test $(TESTOBJS) $(LIBNEWT) $(LIBS) -static
+ $(CC) -o test $(TESTOBJS) $(LIBNEWT) $(LIBS) -static
+ ${CC} -g ${LDFLAGS} -o test $(TESTOBJS) $(LIBNEWT) $(LIBS) -static
testgrid: testgrid.o $(LIBNEWT)
- gcc -g -o testgrid testgrid.o $(LIBNEWT) $(LIBS)
+ $(CC) -o testgrid testgrid.o $(LIBNEWT) $(LIBS)
+ ${CC} -g ${LDFLAGS} -o testgrid testgrid.o $(LIBNEWT) $(LIBS)
testtree: testtree.o $(LIBNEWT)
- gcc -g -o testtree testtree.o $(LIBNEWT) $(LIBS)
-
-_snackmodule.so: snackmodule.o $(LIBNEWTSH)
- gcc --shared $(SHCFLAGS) -o _snackmodule.so snackmodule.o -L . $(LIBNEWTSH)
-
-snackmodule.o: snackmodule.c
- gcc -I/usr/include/python1.5 -fPIC $(CFLAGS) -c snackmodule.c
+ $(CC) -o testtree testtree.o $(LIBNEWT) $(LIBS)
+ ${CC} -g ${LDFLAGS} -o testtree testtree.o $(LIBNEWT) $(LIBS)
_snackmodule.so: snackmodule.c $(LIBNEWTSH)
for ver in $(PYTHONVERS) ; do \
if [ ! -f "$$ver/_snackmodule.so" -o $(LIBNEWTSH) -nt "$$ver/_snackmodule.so" ]; then \
mkdir -p $$ver ;\
- gcc $(CFLAGS) -I/usr/include/$$ver -fPIC -c -o $$ver/snackmodule.o snackmodule.c ;\
- gcc --shared $(SHCFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L . $(LIBNEWTSH) ;\
+ ${CC} $(CFLAGS) -I/usr/include/$$ver -fPIC -c -o $$ver/snackmodule.o snackmodule.c ;\
+ ${CC} --shared $(SHCFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L . $(LIBNEWTSH) ;\
fi ; \
done
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
- gcc -g -o whiptail $(NDIALOGOBJS) -L . $(LIBNEWTSH) $(LIBS) -lpopt
+ $(CC) -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS)
+ ${CC} -g ${LDFLAGS} -o whiptail $(NDIALOGOBJS) -L . $(LIBNEWTSH) $(LIBS) -lpopt
+.if defined(WITH_TCL)
whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
- gcc -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . $(LIBNEWTSH) -ltcl -lslang -lpopt -lm
+ $(CC) -shared -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBS) $(TCLLIBS)
+.endif
+ ${CC} -shared ${LDFLAGS} $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . $(LIBNEWTSH) ${LIBS}
-$(LIBNEWT): $(LIBNEWT)($(LIBOBJS))
+$(LIBNEWT): $(LIBOBJS)
@ -100,67 +99,38 @@
newt.o: newt.c Makefile
$(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<
@@ -82,7 +77,7 @@
$(SHAREDOBJS) *.so*
depend:
- $(CPP) $(CFLAGS) -M $(SOURCES) > .depend
+ mkdep $(CFLAGS) $(SOURCES)
$(SHAREDDIR):
mkdir -p $(SHAREDDIR)
@@ -90,7 +85,7 @@
@@ -96,7 +94,7 @@
sharedlib: $(LIBNEWTSH)
$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
- gcc -shared -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
+ $(CC) -shared -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
+ ${CC} -shared ${LDFLAGS} -o $(LIBNEWTSH) -Wl,-soname,$(LIBNEWTSONAME) $(SHAREDOBJS) $(SHLIBS)
$(SHAREDDIR)/%.o : %.c
$(CC) $(SHCFLAGS) -c $(CFLAGS) -o $@ $<
@@ -100,21 +95,20 @@
@@ -113,16 +111,11 @@
install -m 644 $(LIBNEWT) $(instroot)/$(libdir)
install -s -m 755 whiptail $(instroot)/$(bindir)
install: $(LIBNEWT) install-sh whiptail
- [ -d $(instroot)/$(bindir) ] || install -m 755 -d $(instroot)/$(bindir)
- [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
- [ -d $(instroot)/$(includedir) ] || install -m 755 -d $(instroot)/$(includedir)
- install -m 644 newt.h $(instroot)/$(includedir)
- install -m 644 $(LIBNEWT) $(instroot)/$(libdir)
- install -s -m 755 whiptail $(instroot)/$(bindir)
-
-install-sh: sharedlib whiptcl.so _snackmodule.so
- [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
- install -s -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
- ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/libnewt.so
- install -s -m 755 whiptcl.so $(instroot)/$(libdir)
- [ -d $(instroot)/$(pythonbindir) ] || install -m 755 -d $(instroot)/$(pythonbindir)
- install -s -m 755 _snackmodule.so $(instroot)/$(pythonbindir)
- install -m 755 snack.py $(instroot)/$(pythondir)
+ [ -d $(bindir) ] || install -m 755 -d $(bindir)
+ [ -d $(libdir) ] || install -m 755 -d $(libdir)
+ [ -d $(includedir) ] || install -m 755 -d $(includedir)
+ install -c -m 644 newt.h $(includedir)
+ install -c -m 644 $(LIBNEWT) $(libdir)
+ install -c -s -m 755 whiptail $(bindir)
+
+install-sh: sharedlib ${TCLTARGET}
+ [ -d $(libdir) ] || install -m 755 -d $(libdir)
+ install -c -m 755 $(LIBNEWTSH) $(libdir)
+ ln -sf $(LIBNEWTSH) $(libdir)/libnewt.so
+.if defined(WITH_TCL)
+ install -c -m 755 whiptcl.so $(libdir)
+.endif
-install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
+install-sh: sharedlib $(WHIPTCLSO)
[ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
install -s -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/libnewt.so
[ -n "$(WHIPTCLSO)" ] && install -s -m 755 whiptcl.so $(instroot)/$(libdir) || :
- for ver in $(PYTHONVERS) ; do \
- [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
- install -s -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\
- install -m 755 snack.py $(instroot)/$(libdir)/$$ver/site-packages ;\
- done
configure: configure.in
autoconf
@@ -133,6 +127,6 @@
@@ -140,7 +133,3 @@
@rm -f /tmp/newt-$(VERSION).tar.gz
@echo " "
@echo "The final archive is ./newt-$(VERSION).tar.gz."
-
-ifeq (.depend,$(wildcard .depend))
-include .depend
-endif
+.if exists(.depend)
+.include ".depend"
+.endif

View File

@ -2,6 +2,9 @@
import os
from distutils.core import setup, Extension
LOCALBASE = os.environ['LOCALBASE']
PREFIX = os.environ['PREFIX']
setup ( name = 'newt',
version = '0.50.33',
description = 'Python interface to Newt module',
@ -9,7 +12,7 @@ setup ( name = 'newt',
ext_modules = [ Extension(
name='_snack',
sources=['snackmodule.c'],
include_dirs=['.', os.environ['PREFIX']+'/include'],
library_dirs=['.', os.environ['PREFIX']+'/lib'],
include_dirs=['.', LOCALBASE+'/include', PREFIX+'/include'],
library_dirs=['.', LOCALBASE+'/lib', PREFIX+'/lib'],
libraries=['newt', 'popt', 'slang', 'ncurses']
)])