databases/php70-interbase: Allow creation of multiple connections to Interbase
Currently the first connection to the database is closed when a second one is opened. This bug was already reported to upstream: https://bugs.php.net/bug.php?id=72175 Reported by: Marc Muncke <m.muncke@computer1020.at> Reviewed by: Marc Muncke <m.muncke@computer1020.at> MFH: 2017Q1
This commit is contained in:
parent
0370c99292
commit
189858d917
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=430557
@ -5,6 +5,8 @@ CATEGORIES= databases
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php70
|
||||
|
||||
PORTREVISION= 1
|
||||
|
||||
PKGNAMESUFFIX= -interbase
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
11
databases/php70-interbase/files/patch-interbase.c
Normal file
11
databases/php70-interbase/files/patch-interbase.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- interbase.c.orig 2016-12-16 10:59:02 UTC
|
||||
+++ interbase.c
|
||||
@@ -940,7 +940,7 @@ static void _php_ibase_connect(INTERNAL_
|
||||
xlink = (zend_resource*) le->ptr;
|
||||
if ((!persistent && xlink->type == le_link) || xlink->type == le_plink) {
|
||||
if (IBG(default_link)) {
|
||||
- zend_list_close(IBG(default_link));
|
||||
+ zend_list_delete(IBG(default_link));
|
||||
}
|
||||
xlink->gc.refcount++;
|
||||
xlink->gc.refcount++;
|
Loading…
Reference in New Issue
Block a user