o remove all LIB_DEPENDS, replace with USE_GNOME
o add patch files/patch-src::distance.cpp o add CONFIGURE_ENV for ${LOCALBASE}/{include|lib} o fix build problem on 5.1 PR: ports/52199 Submitted by: maintainer
This commit is contained in:
parent
abce81d029
commit
1887dbec7f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81339
@ -19,21 +19,13 @@ DISTFILES= stardict-${PORTVERSION}.tar.gz \
|
||||
MAINTAINER= statue@freebsd.sinica.edu.tw
|
||||
COMMENT= English-Chinese dictionary
|
||||
|
||||
LIB_DEPENDS= gnome-2.200:${PORTSDIR}/x11/libgnome \
|
||||
gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
|
||||
bonobo-2.0:${PORTSDIR}/devel/libbonobo \
|
||||
bonobo-activation.4:${PORTSDIR}/devel/bonobo-activation
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Configure fails"
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= libgnome libgnomeui libbonobo bonoboactivation gconf2
|
||||
WRKSRC= ${WRKDIR}/stardict-${PORTVERSION}
|
||||
|
||||
MAN1= stardict.1
|
||||
@ -53,4 +45,4 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-ce-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
11
chinese/stardict2/files/patch-src::distance.cpp
Normal file
11
chinese/stardict2/files/patch-src::distance.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/distance.cpp.orig Wed May 14 01:25:59 2003
|
||||
+++ src/distance.cpp Wed May 14 01:26:12 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
#include "distance.h"
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <malloc.h>
|
||||
+//#include <malloc.h>
|
||||
#include <string.h>
|
||||
//#include <stdio.h>
|
||||
|
@ -25,7 +25,11 @@ share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
|
||||
share/omf/stardict/stardict-C.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
share/omf/stardict/stardict-zh_CN.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
share/applications/stardict.desktop
|
||||
etc/gconf/schemas/stardict.schemas
|
||||
lib/bonobo/servers/GNOME_Stardict.server
|
||||
|
@ -19,21 +19,13 @@ DISTFILES= stardict-${PORTVERSION}.tar.gz \
|
||||
MAINTAINER= statue@freebsd.sinica.edu.tw
|
||||
COMMENT= English-Chinese dictionary
|
||||
|
||||
LIB_DEPENDS= gnome-2.200:${PORTSDIR}/x11/libgnome \
|
||||
gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
|
||||
bonobo-2.0:${PORTSDIR}/devel/libbonobo \
|
||||
bonobo-activation.4:${PORTSDIR}/devel/bonobo-activation
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Configure fails"
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= libgnome libgnomeui libbonobo bonoboactivation gconf2
|
||||
WRKSRC= ${WRKDIR}/stardict-${PORTVERSION}
|
||||
|
||||
MAN1= stardict.1
|
||||
@ -53,4 +45,4 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-ce-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
11
textproc/stardict2/files/patch-src::distance.cpp
Normal file
11
textproc/stardict2/files/patch-src::distance.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/distance.cpp.orig Wed May 14 01:25:59 2003
|
||||
+++ src/distance.cpp Wed May 14 01:26:12 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
#include "distance.h"
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <malloc.h>
|
||||
+//#include <malloc.h>
|
||||
#include <string.h>
|
||||
//#include <stdio.h>
|
||||
|
@ -25,7 +25,11 @@ share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
|
||||
share/omf/stardict/stardict-C.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
share/omf/stardict/stardict-zh_CN.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
share/applications/stardict.desktop
|
||||
etc/gconf/schemas/stardict.schemas
|
||||
lib/bonobo/servers/GNOME_Stardict.server
|
||||
|
@ -19,21 +19,13 @@ DISTFILES= stardict-${PORTVERSION}.tar.gz \
|
||||
MAINTAINER= statue@freebsd.sinica.edu.tw
|
||||
COMMENT= English-Chinese dictionary
|
||||
|
||||
LIB_DEPENDS= gnome-2.200:${PORTSDIR}/x11/libgnome \
|
||||
gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui \
|
||||
bonobo-2.0:${PORTSDIR}/devel/libbonobo \
|
||||
bonobo-activation.4:${PORTSDIR}/devel/bonobo-activation
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500113
|
||||
BROKEN= "Configure fails"
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= libgnome libgnomeui libbonobo bonoboactivation gconf2
|
||||
WRKSRC= ${WRKDIR}/stardict-${PORTVERSION}
|
||||
|
||||
MAN1= stardict.1
|
||||
@ -53,4 +45,4 @@ post-install:
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
${INSTALL_DATA} ${WRKDIR}/stardict-xdict-ce-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
11
textproc/stardict3/files/patch-src::distance.cpp
Normal file
11
textproc/stardict3/files/patch-src::distance.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/distance.cpp.orig Wed May 14 01:25:59 2003
|
||||
+++ src/distance.cpp Wed May 14 01:26:12 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
#include "distance.h"
|
||||
|
||||
#include <stdlib.h>
|
||||
-#include <malloc.h>
|
||||
+//#include <malloc.h>
|
||||
#include <string.h>
|
||||
//#include <stdio.h>
|
||||
|
@ -25,7 +25,11 @@ share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
|
||||
share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
|
||||
share/omf/stardict/stardict-C.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-C.omf 2>/dev/null || /usr/bin/true
|
||||
share/omf/stardict/stardict-zh_CN.omf
|
||||
@exec scrollkeeper-install -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
@unexec scrollkeeper-uninstall -q %D/share/omf/stardict/stardict-zh_CN.omf 2>/dev/null || /usr/bin/true
|
||||
share/applications/stardict.desktop
|
||||
etc/gconf/schemas/stardict.schemas
|
||||
lib/bonobo/servers/GNOME_Stardict.server
|
||||
|
Loading…
Reference in New Issue
Block a user