New port graphics/mmsclient - A client to let you download internet

streams using Microsoft's MMS protocol.

PR:		35554
Submitted by:	Alexey Dokuchaev <danfe@cytherea.weblab.nsu.ru>
This commit is contained in:
Patrick Li 2002-03-07 07:26:38 +00:00
parent 3b933cea05
commit 184c01e878
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55671
17 changed files with 263 additions and 0 deletions

View File

@ -181,6 +181,7 @@
SUBDIR += linux_mesa3
SUBDIR += maverik
SUBDIR += ming
SUBDIR += mmsclient
SUBDIR += morpheus
SUBDIR += mpeg
SUBDIR += mpeg-lib

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: mmsclient
# Date created: 4 March 2002
# Whom: danfe@regency.nsu.ru
#
# $FreeBSD$
#
PORTNAME= mmsclient
PORTVERSION= 0.0.3
CATEGORIES= graphics audio
MASTER_SITES= http://www.geocities.com/majormms/ \
ftp://danfe.rimusa.org/tmp/ \
http://inet.ssc.nsu.ru/~danfe/
DISTNAME= mms_client-${PORTVERSION}
MAINTAINER= danfe@regency.nsu.ru
GNU_CONFIGURE= yes
MAN1= mmsclient.1
post-install:
@${INSTALL_MAN} ${FILESDIR}/mmsclient.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mms_client-0.0.3.tar.gz) = c91171a0bbbfb94290d362e907432787

View File

@ -0,0 +1,48 @@
.\"
.\"man-page for mmsclient
.\"
.\"Derived from the man-page for axel download manager, which was originally
.\"based on example in the wonderful book called Beginning Linux Programming,
.\"written by Richard Stone and Neil Matthew.
.\"
.TH MMSCLIENT 1
.SH NAME
\fBmmsclient\fP \- download Microsoft Media streams
.SH SYNOPSIS
.B mmsclient
\fIurl1\fP
.SH DESCRIPTION
mmsclient is a simple utility that allows you to download Internet streams
using Microsoft's MMS protocol, e.g. CNN video and similar. Downloaded
stream can be watched/listened with any software that understands Microsoft
Media format, like xine with mms-plugin.
.SH OPTIONS
.PP
Only one argument is required, the URL to the stream you want to download.
Don't let to confuse yourself by verbose output, once it's finished, you'll
find the stream .asf file in the current directory.
.SH CREDITS
This software would never have been possible without the help from
http://get.to/sdp.
.SH EXAMPLES
.nf
mmsclient mms://netshow.msn.com/msnbc8
.fi
This will attempt to download Microsoft Media stream and save it as
`msnbc8' file in the current directory.
.SH BUGS
.PP
Lacks some useful command line options, not to mention probable bugs.
.SH AUTHORS
mmsclient was written by "Major MMS" (http://www.geocities.com/majormms/).
The manual page was written by Alexey Dokuchaev (danfe@regency.nsu.ru).

View File

@ -0,0 +1,41 @@
--- client.c.orig Sat Dec 29 09:40:48 2001
+++ client.c Mon Mar 4 21:42:05 2002
@@ -277,12 +277,12 @@
int packet_len, command;
char data[BUF_SIZE];
- if (!get_data (s, &packet_len, 4)) {
+ if (!get_data (s, (char *)&packet_len, 4)) {
printf ("packet_len read failed\n");
return 0;
}
- packet_len = get_32 (&packet_len, 0) + 4;
+ packet_len = get_32 ((unsigned char *)&packet_len, 0) + 4;
printf ("command packet detected, len=%d\n",
packet_len);
@@ -308,7 +308,7 @@
int interp_header (uint8_t *header, int header_len) {
int i;
- int packet_length;
+ int packet_length = 0;
/*
* parse header
@@ -416,12 +416,12 @@
int packet_len, command;
- if (!get_data (s, &packet_len, 4)) {
+ if (!get_data (s, (char *)&packet_len, 4)) {
printf ("packet_len read failed\n");
return 0;
}
- packet_len = get_32 (&packet_len, 0) + 4;
+ packet_len = get_32 ((unsigned char *)&packet_len, 0) + 4;
printf ("command packet detected, len=%d\n",
packet_len);

View File

@ -0,0 +1,9 @@
--- configure.orig Mon Mar 4 21:23:59 2002
+++ configure Mon Mar 4 21:24:40 2002
@@ -1649,7 +1649,6 @@
fi
-dbl
CFLAGS="$CFLAGS -Wall"

View File

@ -0,0 +1 @@
Download Microsoft Media streams

View File

@ -0,0 +1,6 @@
mmsclient allows you to download Internet streams using Microsoft's
MMS protocol, e.g. CNN video and similar. Downloaded stream can
be watched/listened with any software that understands Microsoft
Media format, like xine with mms-plugin.
WWW: http://www.geocities.com/majormms/

View File

@ -0,0 +1 @@
bin/mmsclient

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: mmsclient
# Date created: 4 March 2002
# Whom: danfe@regency.nsu.ru
#
# $FreeBSD$
#
PORTNAME= mmsclient
PORTVERSION= 0.0.3
CATEGORIES= graphics audio
MASTER_SITES= http://www.geocities.com/majormms/ \
ftp://danfe.rimusa.org/tmp/ \
http://inet.ssc.nsu.ru/~danfe/
DISTNAME= mms_client-${PORTVERSION}
MAINTAINER= danfe@regency.nsu.ru
GNU_CONFIGURE= yes
MAN1= mmsclient.1
post-install:
@${INSTALL_MAN} ${FILESDIR}/mmsclient.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mms_client-0.0.3.tar.gz) = c91171a0bbbfb94290d362e907432787

View File

@ -0,0 +1,48 @@
.\"
.\"man-page for mmsclient
.\"
.\"Derived from the man-page for axel download manager, which was originally
.\"based on example in the wonderful book called Beginning Linux Programming,
.\"written by Richard Stone and Neil Matthew.
.\"
.TH MMSCLIENT 1
.SH NAME
\fBmmsclient\fP \- download Microsoft Media streams
.SH SYNOPSIS
.B mmsclient
\fIurl1\fP
.SH DESCRIPTION
mmsclient is a simple utility that allows you to download Internet streams
using Microsoft's MMS protocol, e.g. CNN video and similar. Downloaded
stream can be watched/listened with any software that understands Microsoft
Media format, like xine with mms-plugin.
.SH OPTIONS
.PP
Only one argument is required, the URL to the stream you want to download.
Don't let to confuse yourself by verbose output, once it's finished, you'll
find the stream .asf file in the current directory.
.SH CREDITS
This software would never have been possible without the help from
http://get.to/sdp.
.SH EXAMPLES
.nf
mmsclient mms://netshow.msn.com/msnbc8
.fi
This will attempt to download Microsoft Media stream and save it as
`msnbc8' file in the current directory.
.SH BUGS
.PP
Lacks some useful command line options, not to mention probable bugs.
.SH AUTHORS
mmsclient was written by "Major MMS" (http://www.geocities.com/majormms/).
The manual page was written by Alexey Dokuchaev (danfe@regency.nsu.ru).

View File

@ -0,0 +1,41 @@
--- client.c.orig Sat Dec 29 09:40:48 2001
+++ client.c Mon Mar 4 21:42:05 2002
@@ -277,12 +277,12 @@
int packet_len, command;
char data[BUF_SIZE];
- if (!get_data (s, &packet_len, 4)) {
+ if (!get_data (s, (char *)&packet_len, 4)) {
printf ("packet_len read failed\n");
return 0;
}
- packet_len = get_32 (&packet_len, 0) + 4;
+ packet_len = get_32 ((unsigned char *)&packet_len, 0) + 4;
printf ("command packet detected, len=%d\n",
packet_len);
@@ -308,7 +308,7 @@
int interp_header (uint8_t *header, int header_len) {
int i;
- int packet_length;
+ int packet_length = 0;
/*
* parse header
@@ -416,12 +416,12 @@
int packet_len, command;
- if (!get_data (s, &packet_len, 4)) {
+ if (!get_data (s, (char *)&packet_len, 4)) {
printf ("packet_len read failed\n");
return 0;
}
- packet_len = get_32 (&packet_len, 0) + 4;
+ packet_len = get_32 ((unsigned char *)&packet_len, 0) + 4;
printf ("command packet detected, len=%d\n",
packet_len);

View File

@ -0,0 +1,9 @@
--- configure.orig Mon Mar 4 21:23:59 2002
+++ configure Mon Mar 4 21:24:40 2002
@@ -1649,7 +1649,6 @@
fi
-dbl
CFLAGS="$CFLAGS -Wall"

View File

@ -0,0 +1 @@
Download Microsoft Media streams

View File

@ -0,0 +1,6 @@
mmsclient allows you to download Internet streams using Microsoft's
MMS protocol, e.g. CNN video and similar. Downloaded stream can
be watched/listened with any software that understands Microsoft
Media format, like xine with mms-plugin.
WWW: http://www.geocities.com/majormms/

View File

@ -0,0 +1 @@
bin/mmsclient