print/teTeX restructuring:

print/teTeX-base installs binaries in the teTeX distribution.  This
	is based on the old version of print/teTeX (repo-copy'd).

PR:		ports/67452
Approved by:	linimon (mentor)
Approved by:	demon (print/teTeX maintainer, in concept)
This commit is contained in:
Hiroki Sato 2004-06-18 15:15:32 +00:00
parent d1f49f6928
commit 1823d59a64
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111730
9 changed files with 174 additions and 14214 deletions

View File

@ -1,31 +1,31 @@
# New ports collection makefile for: teTeX
# New ports collection makefile for: teTeX-base
# Date created: 5 December 1996
# Whom: Bernd Rosauer <br@netland.inka.de>
#
# $FreeBSD$
#
PORTNAME= teTeX
PORTNAME= teTeX-base
PORTVERSION= 2.0.2
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/2.0/distrib/ \
${MASTER_SITE_TEX_CTAN} \
ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/dvips/:1
${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= systems/unix/teTeX/2.0/distrib/
DISTFILES= ${TETEX_SRC} ${TETEX_TEXMF} dvipsk-jpatch-p1.6${EXTRACT_SUFX}:1
DISTNAME= ${TETEX_SRC}
DIST_SUBDIR= teTeX
EXTRACT_ONLY= ${TETEX_SRC} dvipsk-jpatch-p1.6${EXTRACT_SUFX}
MAINTAINER= demon@FreeBSD.org
COMMENT= Thomas Esser's distribution of TeX & friends
COMMENT= Thomas Esser's distribution of TeX & friends (binaries)
BUILD_DEPENDS= ${TEXMF_TREE}/LICENSE.texmf:${PORTSDIR}/print/teTeX-texmf \
tetex-modesw:${PORTSDIR}/print/tex-texmflocal
RUN_DEPENDS= ${TEXMF_TREE}/LICENSE.texmf:${PORTSDIR}/print/teTeX-texmf \
tetex-modesw:${PORTSDIR}/print/tex-texmflocal
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
wwwcore.1:${PORTSDIR}/www/libwww \
t1.5:${PORTSDIR}/devel/t1lib
WRKSRC= ${WRKDIR}/tetex-src-${PORTVERSION}
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-multiplatform \
@ -43,6 +43,7 @@ CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
PLIST_SUB= MKTEXLSR=${MKTEXLSR} TEXMFCNF=${TEXMFCNF}
PKGINSTALL= ${WRKDIR}/pkg-install.sh
PKGDEINSTALL= ${WRKDIR}/pkg-install.sh
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFLICTS= ja-ptex-base*
MAN1= MakeTeXPK.1 access.1 allcm.1 allneeded.1 \
@ -82,7 +83,8 @@ MAN1+= afm2tfm.1 dvips.1
INFO+= dvips
CONFLICTS+= dvips* ja-dvips*
.else
CONFIGURE_ARGS+= --without-dvipsk
CONFIGURE_ARGS+=--without-dvipsk \
--without-odvipsk
PLIST_SUB+= DVIPSK="@comment "
.endif
@ -93,7 +95,8 @@ MAN1+= xdvi.1 t1mapper.1 xdvizilla.1
CONFLICTS+= xdvi* ja-xdvi*
.else
USE_XLIB= yes
CONFIGURE_ARGS+= --without-xdvik
CONFIGURE_ARGS+=--without-xdvik \
--without-oxdvik
PLIST_SUB+= XDVIK="@comment "
.endif
@ -114,15 +117,21 @@ PLIST_SUB+= X11BITS="@comment "
#PKGNAMESUFFIX= ${FLAVOR:S,^,-,:Q:S,\\ ,,g:S,\\-,-,g}
#.endif
TETEX_SRC= tetex-src-${PORTVERSION}.tar.gz
TETEX_TEXMF= tetex-texmf-${PORTVERSION}.tar.gz
TETEX_SRC= tetex-src-${PORTVERSION}
LIBPNG_PREFIX?= ${LOCALBASE}
LIBWWW_PREFIX?= ${LOCALBASE}
LIBT1_PREFIX?= ${LOCALBASE}
TEXMF_TREE= ${PREFIX}/share/texmf
MKTEXLSR?= ${LOCALBASE}/bin/mktexlsr
TEXMFCNF= ${TEXMF_TREE}/web2c/texmf.cnf
DVIPSKCNF= ${TEXMF_TREE}/dvips/config/config.ps
TEXMFVAR= share/texmf-var
TETEX_MODESW= ${LOCALBASE}/bin/tetex-modesw
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
PLIST_SUB+= TEXMF_TREE=${TEXMF_TREE:S,^${PREFIX}/,,} \
TEXMFVAR=${TEXMFVAR}
PKGINSTALL_SUB= TETEX_MODESW=${TETEX_MODESW} \
MKTEXLSR=${MKTEXLSR}
PKGMESSAGE_SUB= TEXMF_TREE=${TEXMF_TREE}
pre-configure:
@${ECHO_MSG}
@ -130,43 +139,16 @@ pre-configure:
@${ECHO_MSG}
post-configure:
${SED} -e 's,%%TEXMFCNF%%,${TEXMFCNF},g;s,%%DVIPSKCNF%%,${DVIPSKCNF},g;s,%%WITH_DVIPSK%%,${WITH_DVIPSK},g;s,%%MKTEXLSR%%,${MKTEXLSR},g' \
${SED} ${PKGINSTALL_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
< ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
${CHMOD} 0755 ${PKGINSTALL}
pre-install:
${MKDIR} ${TEXMF_TREE}
cd ${TEXMF_TREE} && \
${TAR} xUfz ${DISTDIR}/${DIST_SUBDIR}/${TETEX_TEXMF}
${INSTALL_DATA} ${FILESDIR}/listings.sty ${TEXMF_TREE}/tex/latex/listings/
${INSTALL_SCRIPT} ${WRKSRC}/utils/texinfo/util/texi2dvi ${PREFIX}/bin
${SED} -e "s|^TEXMFMAIN = .*|TEXMFMAIN = ${TEXMF_TREE}|g" \
< ${WRKSRC}/texk/kpathsea/texmf.cnf \
> ${TEXMF_TREE}/web2c/texmf.cnf
${CHMOD} 644 ${TEXMF_TREE}/web2c/texmf.cnf
${SED} ${PKGMESSAGE_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
< ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
post-install:
${SETENV} TEXMFMAIN=${TEXMF_TREE} \
${WRKSRC}/texk/tetex/texconfig font ro > /dev/null 2>&1
${SETENV} TEXMFMAIN=${TEXMF_TREE} \
${WRKSRC}/texk/tetex/texconfig font options appendonlydir varfonts
.if !defined(WITH_XDVIK)
${RM} -f ${TEXMF_TREE}/xdvi/XDvi
.endif
cd ${TEXMF_TREE}/dvips/pstricks && \
${PATCH} --quiet < ${WRKDIR}/PSTricks.patch && \
${RM} -f pst-text.pro.orig
${SED} -e 's,^\(o*\),%\1,' \
< ${TEXMF_TREE}/dvips/config/config.ps \
> ${TEXMF_TREE}/dvips/config/config.ps.tetex
${RM} -f ${TEXMF_TREE}/dvips/config/config.ps
cd ${TEXMF_TREE}/web2c && \
${MV} texmf.cnf texmf.cnf.tetex
${INSTALL_SCRIPT} ${WRKSRC}/utils/texinfo/util/texi2dvi ${PREFIX}/bin
@${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${ECHO_MSG} "You may want to run texconfig to configure teTeX for your"
@${ECHO_MSG} "local environment. You will find teTeX's local documentation"
@${ECHO_MSG} "in ${TEXMF_TREE}/doc/."
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,6 +1,2 @@
MD5 (teTeX/tetex-src-2.0.2.tar.gz) = a16f6bba227d55e79aeee46fbbd82d28
SIZE (teTeX/tetex-src-2.0.2.tar.gz) = 11745933
MD5 (teTeX/tetex-texmf-2.0.2.tar.gz) = d3bdb96f9077e43b2115d3cc471743b3
SIZE (teTeX/tetex-texmf-2.0.2.tar.gz) = 52424280
MD5 (teTeX/dvipsk-jpatch-p1.6.tar.gz) = a072a2196015caa15834522728a91a78
SIZE (teTeX/dvipsk-jpatch-p1.6.tar.gz) = 28637

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,11 @@
--- texk/kpathsea/Makefile.in.orig Sun Feb 16 02:21:42 2003
+++ texk/kpathsea/Makefile.in Fri Jun 11 20:49:40 2004
@@ -126,7 +126,7 @@
| sed 's/^\([^ =]*\)[ ]*=*[ ]*\(.*\)/#ifndef DEFAULT_\1%#define DEFAULT_\1 "\2"%#endif/' \
| tr '%' '\012' \
| sed -e 's%\$$TEXMFMAIN%$(texmf)%g' \
- -e 's%\$$TEXMF%$(texmf)%g' \
+ -e 's%\$$TEXMF\([,}/]\)%$(texmf)\1%g' \
-e 's%\$$VARTEXFONTS%$(vartexfonts)%g' \
-e 's%\$$web2cdir%$(web2cdir)%g' \
-e 's%\$$prefix%$(prefix)%g' \

View File

@ -0,0 +1,20 @@
--- texk/kpathsea/texmf.in.orig Sat Jun 5 18:49:55 2004
+++ texk/kpathsea/texmf.in Sat Jun 5 18:50:02 2004
@@ -62,7 +62,7 @@
% If defined, teTeX's texconfig stores modifications here (instead of the
% TEXMFMAIN tree).
-% VARTEXMF = @texmf@-var
+VARTEXMF = @texmf@-var
% User texmf trees can be catered for like this...
HOMETEXMF = $HOME/texmf
@@ -74,7 +74,7 @@
% - list $VARTEXMF in the TEXMF definition;
% - make sure that $VARTEXMF precedes $TEXMFMAIN in the TEXMF definition.
% TEXMF = $TEXMFMAIN
-TEXMF = {$HOMETEXMF,!!$TEXMFLOCAL,!!$TEXMFMAIN}
+TEXMF = {$HOMETEXMF,!!$VARTEXMF,!!$TEXMFLOCAL,!!$TEXMFMAIN}
% The system trees. These are the trees that are shared by all the users.
SYSTEXMF = $TEXMF

View File

@ -1,66 +1,18 @@
# $FreeBSD$
GREP=/usr/bin/grep
SED=/usr/bin/sed
WITH_DVIPSK="%%WITH_DVIPSK%%"
SUFFIX=tetex
TETEX_MODESW=%%TETEX_MODESW%%
MKTEXLSR=%%MKTEXLSR%%
case $2 in
POST-INSTALL)
if [ ! -f %%TEXMFCNF%% ]; then
cp %%TEXMFCNF%%.${SUFFIX} %%TEXMFCNF%%
echo "Notice: installing %%TEXMFCNF%%.${SUFFIX} -> %%TEXMFCNF%%."
%%MKTEXLSR%%
elif ${SED} q < %%TEXMFCNF%% | ${GREP} original > /dev/null 2>&1; then
cp %%TEXMFCNF%%.${SUFFIX} %%TEXMFCNF%%
echo "Notice: installing %%TEXMFCNF%%.${SUFFIX} -> %%TEXMFCNF%%."
%%MKTEXLSR%%
else
echo "Notice: %%TEXMFCNF%% is not installed."
echo " Merge from %%TEXMFCNF%%.${SUFFIX} manually."
fi
case "${WITH_DVIPSK}" in
"") exit 0 ;;
esac
if [ ! -f %%DVIPSKCNF%% ]; then
cp %%DVIPSKCNF%%.${SUFFIX} %%DVIPSKCNF%%
echo "Notice: installing %%DVIPSKCNF%%.${SUFFIX} -> %%DVIPSKCNF%%."
%%MKTEXLSR%%
elif ${SED} q < %%TEXMFCNF%% | ${GREP} "public domain" > /dev/null 2>&1; then
cp %%DVIPSKCNF%%.${SUFFIX} %%DVIPSKCNF%%
echo "Notice: installing %%DVIPSKCNF%%.${SUFFIX} -> %%DVIPSKCNF%%."
%%MKTEXLSR%%
else
echo "Notice: %%DVIPSKCNF%% is not installed."
echo " Merge from %%DVIPSKCNF%%.${SUFFIX} manually."
fi
;;
${TETEX_MODESW} default dvips forceinstall
${TETEX_MODESW} default dvipdfm forceinstall
${TETEX_MODESW} default xdvi forceinstall
${MKTEXLSR}
;;
DEINSTALL)
if [ -f %%TEXMFCNF%% ]; then
if ${SED} q < %%TEXMFCNF%% | ${GREP} original > /dev/null 2>&1; then
rm -f %%TEXMFCNF%%
echo "Notice: %%TEXMFCNF%% is removed."
else
echo "Notice: %%TEXMFCNF%% is NOT removed."
echo " Remove manually."
fi
fi
case "${WITH_DVIPSK}" in
"") exit 0 ;;
esac
if [ -f %%DVIPSKCNF%% ]; then
if ${SED} q < %%DVIPSKCNF%% | ${GREP} "public domain" > /dev/null 2>&1; then
rm -f %%DVIPSKCNF%%
echo "Notice: %%DVIPSKCNF%% is removed."
else
echo "Notice: %%DVIPSKCNF%% is NOT removed."
echo " Remove manually."
fi
fi
;;
${TETEX_MODESW} uninstall dvips
${TETEX_MODESW} uninstall dvipdfm
${TETEX_MODESW} uninstall xdvi
;;
esac

View File

@ -0,0 +1,3 @@
You may want to run texconfig to configure teTeX for your
local environment. You will find teTeX's local documentation
in %%TEXMF_TREE%%/doc/.

View File

@ -3,8 +3,6 @@ contains the latest versions of TeX & friends and nearly everything
you need for happy TeX'ing. For more information have a look at
the lengthy FEATURES file of the distribution.
WWW: http://www.tug.org/tetex/
teTeX-base contains various utilities including TeX and dviware themselves.
--
Bernd Rosauer
br@netland.inka.de
WWW: http://www.tug.org/tetex/

File diff suppressed because it is too large Load Diff