cad/alliance: Update to 5.1.1, remove BROKEN and undeprecate

* The code has been modernized so most of the patches and the workaround
  with USE_CXXSTD are therefore no longer required.  USE_GCC is still needed
  for build as some files cannot be compiled with Clang.

  The updated code also contains no more occurences of the long deprecated
  gets(3) function which has been removed since FreeBSD 1300043. [1]

* A patch from Debian's patchset [2] is required to remedy build issues
  with the documentation.

* Add USE_XORG to pass stage QA as some binaries are linked against various
  X libraries.  Among these libraries is also the recently deprecated
  x11/libXp, which is probably not needed but (still) pulled in by the
  OpenMotif toolkit.

* Also pet portlint/portclippy while I'm here by grouping related USE_*
  variables to the USES block and sort the other variables according to the
  PHB.

PR:		238686
Submitted by:	Loïc Bartoletti <lbartoletti@tuxfamily.org> (based on)
Reported by:	emaste [1]
Obtained from:	Debian [2]
This commit is contained in:
Kai Knoblich 2019-09-28 11:11:14 +00:00
parent a50d596d62
commit 1823b021c2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=513117
10 changed files with 47 additions and 336 deletions

View File

@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= alliance
DISTVERSION= 5.0-20120515
PORTREVISION= 8
DISTVERSION= 5.1.1
CATEGORIES= cad
MASTER_SITES= http://ftp.lyx.org/lip6/softs/alliance/distribution/5.0/ \
http://ftp.jussieu.fr/lip6/softs/alliance/distribution/5.0/ \
http://www-asim.lip6.fr/pub/alliance/distribution/5.0/
MASTER_SITES= ftp://asim.lip6.fr/pub/alliance/distribution/5.0/ \
ftp://ftp.lyx.org/lip6/softs/alliance/distribution/5.0/ \
ftp://ftp.jussieu.fr/lip6/softs/alliance/distribution/5.0/
MAINTAINER= ports@FreeBSD.org
COMMENT= Complete set of CAD tools and libraries for VLSI design
@ -17,33 +16,42 @@ LICENSE_NAME= Alliance VLSI Cad System License
LICENSE_FILE= ${WRKSRC}/LICENCE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN= unfetchable
DEPRECATED= Unfetchable, unmaintained
EXPIRATION_DATE= 2019-10-16
BROKEN_aarch64= fails to link: collect2: error: ld returned 1 exit status
CONFLICTS_INSTALL= fspclient-*
WRKSRC= ${WRKDIR}/alliance-5.0
SUB_FILES= pkg-message
USES= bison gmake libtool motif
BUILD_DEPENDS= convert:graphics/ImageMagick7 \
fig2dev:print/transfig
USES= autoreconf:build gmake libtool motif tar:bz2 xorg
USE_GCC= any
USE_TEX= dvipsk:build latex:build
USE_XORG= ice sm x11 xext xp xt
HAS_CONFIGURE= yes
INSTALL_TARGET= install-strip
ALLIANCE_TOP= ${PREFIX}/alliance
CONFIGURE_ENV+= ALLIANCE_TOP=${ALLIANCE_TOP}
CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
--prefix=${ALLIANCE_TOP}
# The port does not build with C++11 or later (bug 219275).
USE_CXXSTD= gnu++98
MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
CONFLICTS_INSTALL= fspclient-*
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/alliance/src
ALLIANCE_TOP= ${PREFIX}/alliance
post-patch:
${REINPLACE_CMD} -e '/include <malloc.h>/d' \
@${REINPLACE_CMD} -e '/include <malloc.h>/d' \
${WRKSRC}/xgra/src/XSB_parse.c
# These Makefiles contain hardcoded references to make(1). Replace them with
# gmake(1) to avoid build failures of the documentation.
@${REINPLACE_CMD} -e 's/; make/; gmake/' \
${WRKSRC}/documentation/Makefile.am \
${WRKSRC}/documentation/alliance-examples/Makefile \
${WRKSRC}/documentation/tutorials/Makefile.am
pre-configure:
@cd ${WRKSRC} && ./autostuff
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (alliance-5.0-20120515.tar.gz) = a971497699c1725fbde6bb8769e127298bb1171e18add747b2ce2434ad827b8b
SIZE (alliance-5.0-20120515.tar.gz) = 8341111
TIMESTAMP = 1568066206
SHA256 (alliance-5.1.1.tar.bz2) = 811f201881af46d9d36f1c60b184c136fd2b8bebbe932a29e07ced40394ecc10
SIZE (alliance-5.1.1.tar.bz2) = 4486561

View File

@ -1,95 +0,0 @@
Description: Format string fixes
This patch fixes some format string problems with fprintf().
Author: Roland Stigge <stigge@antcom.de>
===================================================================
--- alliance-5.0-20110203.orig/rtd/src/rtd_drive.c 2002-09-30 18:21:10.000000000 +0200
+++ rtd/src/rtd_drive.c 2012-03-24 15:24:00.000000000 +0100
@@ -100,7 +100,7 @@
RtlExprLength = Length;
}
- fprintf( RtlFile, Name );
+ fprintf( RtlFile, "%s", Name );
}
/*------------------------------------------------------------\
===================================================================
--- alliance-5.0-20110203.orig/vpd/src/vpd_drive.c 2002-09-30 18:21:32.000000000 +0200
+++ vpd/src/vpd_drive.c 2012-03-24 15:37:53.000000000 +0100
@@ -100,7 +100,7 @@
VpnExprLength = Length;
}
- fprintf( VpnFile, Name );
+ fprintf( VpnFile, "%s", Name );
}
/*------------------------------------------------------------\
===================================================================
--- alliance-5.0-20110203.orig/boog/src/bog_normalize_message.c 2002-09-30 18:19:58.000000000 +0200
+++ boog/src/bog_normalize_message.c 2012-03-24 15:50:03.000000000 +0100
@@ -106,7 +106,7 @@
}
fprintf(stderr,"BEH: ");
- fprintf(stderr,message);
+ fprintf(stderr,"%s",message);
fprintf(stderr," in '");
fflush(stderr);
display_abl(abl);
===================================================================
--- alliance-5.0-20110203.orig/l2p/src/drive_ps.c 2005-02-17 16:34:44.000000000 +0100
+++ l2p/src/drive_ps.c 2012-03-24 16:02:33.000000000 +0100
@@ -83,22 +83,22 @@
break;
case E_OPEN :
fprintf (stderr, "Problem while opening file ");
- fprintf (stderr, msg);
+ fprintf (stderr, "%s", msg);
break;
case E_CLOSE :
fprintf (stderr, "Problem while closing file ");
- fprintf (stderr, msg);
+ fprintf (stderr, "%s", msg);
break;
case E_WRITE :
fprintf (stderr, "Problem while writing file ");
- fprintf (stderr, msg);
+ fprintf (stderr, "%s", msg);
break;
case E_READ :
fprintf (stderr, "Problem while reading file ");
- fprintf (stderr, msg);
+ fprintf (stderr, "%s", msg);
break;
case E_OUTBOX :
- fprintf (stderr, msg);
+ fprintf (stderr, "%s", msg);
break;
default :
fprintf (stderr, "Unknow internal error");
===================================================================
--- alliance-5.0-20110203.orig/loon/src/lon_normalize_message.c 2004-09-06 23:26:09.000000000 +0200
+++ loon/src/lon_normalize_message.c 2012-03-24 16:15:39.000000000 +0100
@@ -106,7 +106,7 @@
}
fprintf(stderr,"BEH: ");
- fprintf(stderr,message);
+ fprintf(stderr,"%s",message);
fprintf(stderr," in '");
fflush(stderr);
display_abl(abl);
===================================================================
--- alliance-5.0-20110203.orig/sea/src/util_LEFDEF.c 2004-09-29 23:40:46.000000000 +0200
+++ sea/src/util_LEFDEF.c 2012-03-24 16:36:27.000000000 +0100
@@ -213,7 +213,7 @@
*pI = (char)0; pI += 1;
sprintf (asLEF, "%s(%s)", sTmp, pI);
} else {
- sprintf (asLEF, sTmp);
+ sprintf (asLEF, "%s", sTmp);
}
return (asLEF);

View File

@ -1,115 +0,0 @@
Description: Fix segfaults in different executables
Some executables in the package crashed upon certain command line option
combinations. This patch fixes this.
Author: Roland Stigge <stigge@antcom.de>
Bug-Debian: http://bugs.debian.org/715651
Bug-Debian: http://bugs.debian.org/716217
Bug-Debian: http://bugs.debian.org/716529
--- alliance-5.0-20120515.orig/asimut/src/vh_simulad.c
+++ asimut/src/vh_simulad.c
@@ -155,8 +155,8 @@ char **argv;
arg_flg [i ] = 1;
}
- if ((!strcmp (argv [i], "-fixeddelay"))
- || (!strcmp (argv [i], "-fd")))
+ if (((!strcmp (argv [i], "-fixeddelay"))
+ || (!strcmp (argv [i], "-fd"))) && (argc > i + 1))
{
fixdly_flg = 1;
delay_mode |= BEH_DELAY_FIXED;
@@ -165,8 +165,8 @@ char **argv;
arg_flg [i+1] = 1;
}
- if ((!strcmp (argv [i], "-backdelay"))
- || (!strcmp (argv [i], "-bd")))
+ if (((!strcmp (argv [i], "-backdelay"))
+ || (!strcmp (argv [i], "-bd"))) && (argc > i + 1))
{
bckdly_flg = i + 2;
delay_mode |= BEH_DELAY_BACKANOTATED;
@@ -221,14 +221,14 @@ char **argv;
arg_flg [i] = 1;
}
- if (!strcmp (argv [i], "-p"))
+ if (!strcmp (argv [i], "-p") && (argc > i + 1))
{
sscanf (argv [i+1], "%u", &max_pat);
arg_flg [i ] = 1;
arg_flg [i+1] = 1;
}
- if (!strcmp (argv [i], "-l"))
+ if (!strcmp (argv [i], "-l") && (argc > i + 1))
{
sscanf (argv [i+1], "%u", &labelsiz);
arg_flg [i ] = 1;
@@ -241,7 +241,7 @@ char **argv;
arg_flg [i] = 1;
}
- if (!strcmp (argv [i], "-stat"))
+ if (!strcmp (argv [i], "-stat") && (argc > i + 1))
{
stat_flg = i + 2;
sscanf (argv [i+1], "%u", &ref_date);
@@ -264,7 +264,7 @@ char **argv;
arg_flg [i+1] = 1;
}
- if (!strcmp (argv [i], "-inspect"))
+ if (!strcmp (argv [i], "-inspect") && (argc > i + 1))
{
str = namealloc (argv [i+1]);
pt_pains = pat_addpains (pt_pains, str, str);
--- alliance-5.0-20120515.orig/m2e/src/m2e.c
+++ m2e/src/m2e.c
@@ -102,6 +102,8 @@ int ParseCommand(int argc,char *argv[])
switch(argv[i][1])
{
case 'v':
+ if (argc <= i + 1)
+ break;
i++;
sscanf(argv[i],"%d",&VerboseMode);
if(VerboseMode>=VMINFO)
@@ -109,6 +111,8 @@ int ParseCommand(int argc,char *argv[])
break;
case 'o':
+ if (argc <= i + 1)
+ break;
i++;
OutputName=argv[i];
if(VerboseMode>=VMINFO)
--- alliance-5.0-20120515.orig/mips_asm/src/mips_y.y
+++ mips_asm/src/mips_y.y
@@ -92,14 +92,14 @@ char *argv [];
{
if (arg_flg [i] == 0)
{
- if (!strcmp (argv[i], "-textsize"))
+ if (!strcmp (argv[i], "-textsize") && argc > i + 1)
{
sscanf (argv[i+1], "%u", &txt_siz);
arg_flg [i ] = 1;
arg_flg [i+1] = 1;
}
- if (!strcmp (argv[i], "-datasize"))
+ if (!strcmp (argv[i], "-datasize") && argc > i + 1)
{
sscanf (argv[i+1], "%u", &dat_siz);
arg_flg [i ] = 1;
@@ -112,7 +112,7 @@ char *argv [];
arg_flg [i] = 1 ;
}
- if (!strcmp (argv[i], "-symbol"))
+ if (!strcmp (argv[i], "-symbol") && argc > i + 1)
{
MPS_SYMBOL = 'y' ;
symbol_fil = argv [i+1];

View File

@ -1,22 +0,0 @@
--- asimut/src/Makefile.in.orig 2012-05-14 14:46:17 UTC
+++ asimut/src/Makefile.in
@@ -451,8 +451,6 @@ libCst_la_LDFLAGS = -version-info @CST_D
libSch_la_LDFLAGS = -version-info @SCH_DLL_VERSION@
asimut_LDADD = \
-lBvl \
--lBhl \
--L. libCst.la libSch.la \
-L$(top_builddir)/mbkvti/src \
-L$(top_builddir)/mbkedif/src \
-L$(top_builddir)/mbkhilo/src \
@@ -473,7 +471,9 @@ asimut_LDADD = \
-lMlu \
-lMal \
-lMcl -lMel -lMhl -lMgl -lMsl \
- -lMvg -lMlo -lRcn -lBvl -lBeh -lPpt -lPhl -lPat -lLog -lMut
+-lMvg -lMlo -lRcn -lBeh -lPpt -lPhl -lPat -lLog -lMut \
+-lBhl \
+-L. libCst.la libSch.la
asimut_SOURCES = \
beh_delay.h c_fsyn_sr1k_56.c vh_debug.c vh_lspec.c vh_util.h \

View File

@ -0,0 +1,15 @@
Add "float" package to avoid "Unknown float option 'H'" error
Obtained from Debian
--- documentation/tutorials/start/start.tex.orig 2014-08-02 23:38:00 UTC
+++ documentation/tutorials/start/start.tex
@@ -9,7 +9,7 @@
%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\documentclass{article}
-\usepackage{charter,setspace,fancybox}
+\usepackage{charter,setspace,fancybox,float}
\textwidth 15cm
\textheight 23cm
\oddsidemargin +0.75cm

View File

@ -1,44 +0,0 @@
--- elp/src/elp.c.orig 2002-06-12 12:54:39 UTC
+++ elp/src/elp.c
@@ -62,6 +62,7 @@ elpFCT elpenv()
if ( str == (char *)NULL ) str = ALLIANCE_TOP;
sprintf( elpTechnoFile, "%s/%s", str, TECHNOLOGY );
}
+ return (0);
}
/*****************************************************************************/
@@ -249,7 +250,7 @@ if(elpGeneral[elpACM] == 1.0)
lotrs->PS = lotrs->PD = lotrs->WIDTH ;
}
-return ;
+return 0;
}
@@ -457,7 +458,7 @@ if((lotrs->PS != 0.0) && (lotrs->XS != 0
addcapa( lotrs->SOURCE->SIG, elpLotrsCapaSource(lotrs) ) ;
}
-return ;
+return 0;
}
@@ -487,7 +488,7 @@ for(lotrs = lofig->LOTRS ; lotrs != NULL
addcapa( lotrs->GRID->SIG, elpLotrsCapaGrid(lotrs) );
}
-return ;
+return 0;
}
@@ -515,5 +516,5 @@ lotrs_list *lotrs ;
for(lotrs = lofig->LOTRS ; lotrs != NULL ; lotrs = lotrs->NEXT)
elpLotrsShrink(lotrs) ;
-return ;
+return 0;
}

View File

@ -1,11 +0,0 @@
--- ppt/src/Makefile.in.orig 2012-05-14 14:46:35 UTC
+++ ppt/src/Makefile.in
@@ -769,7 +769,7 @@ pat_decl_y.c pat_decl_y.h : $(srcdir)/pa
$(YACC) -d $(YFLAGS) $(srcdir)/pat_decl_y.y \
&& sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.c \
| sed -e "s/int[ ]*pat_decl_y_char;/extern int pat_decl_y_char;/" \
- | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/extern PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
+ | sed -e "s/PAT_DECL_Y_STYPE[ ]*pat_decl_y_lval;/PAT_DECL_Y_STYPE pat_decl_y_lval;/" \
| sed -e "s/int[ ]*pat_decl_y_nerrs;/extern int pat_decl_y_nerrs;/" \
> pat_decl_y.c \
&& sed -e "s/yy/pat_decl_y_/g" -e "s/YY/PAT_DECL_Y_/g" y.tab.h > pat_decl_y.h

View File

@ -5,4 +5,4 @@ of portable CMOS libraries is provided. Alliance is the result of a
twelve year effort spent at ASIM department of LIP6 laboratory of
the Pierre et Marie Curie University (Paris VI, France).
WWW: http://www-asim.lip6.fr/recherche/alliance/
WWW: https://www-soc.lip6.fr/equipe-cian/logiciels/alliance/

View File

@ -41,7 +41,6 @@ alliance/bin/seroute
alliance/bin/sxlib2lef
alliance/bin/syf
alliance/bin/vasy
alliance/bin/x2vy
alliance/bin/x2y
alliance/bin/xfsm
alliance/bin/xgra
@ -1509,7 +1508,6 @@ alliance/lib/libBeh.a
alliance/lib/libBhl.a
alliance/lib/libBtr.a
alliance/lib/libBvl.a
alliance/lib/libCst.a
alliance/lib/libCtl.a
alliance/lib/libCtp.a
alliance/lib/libElp.a
@ -1518,48 +1516,24 @@ alliance/lib/libFsm.a
alliance/lib/libFtl.a
alliance/lib/libFvh.a
alliance/lib/libLog.a
alliance/lib/libMal.a
alliance/lib/libMap.a
alliance/lib/libMcl.a
alliance/lib/libMcp.a
alliance/lib/libMel.a
alliance/lib/libMgl.a
alliance/lib/libMgn.a
alliance/lib/libMhl.a
alliance/lib/libMlo.a
alliance/lib/libMlu.a
alliance/lib/libMmg.a
alliance/lib/libMph.a
alliance/lib/libMpu.a
alliance/lib/libMsl.a
alliance/lib/libMut.a
alliance/lib/libMvg.a
alliance/lib/libMvl.a
alliance/lib/libPat.a
alliance/lib/libPgn.a
alliance/lib/libPhl.a
alliance/lib/libPpt.a
alliance/lib/libRcf.a
alliance/lib/libRcn.a
alliance/lib/libRds.a
alliance/lib/libRfm.a
alliance/lib/libRgs.a
alliance/lib/libRpr.a
alliance/lib/libRtd.a
alliance/lib/libRtl.a
alliance/lib/libRtn.a
alliance/lib/libRut.a
alliance/lib/libRwi.a
alliance/lib/libSch.a
alliance/lib/libScl.a
alliance/lib/libVbh.a
alliance/lib/libVbl.a
alliance/lib/libVex.a
alliance/lib/libVpd.a
alliance/lib/libVpn.a
alliance/lib/libVrd.a
alliance/lib/libVtl.a
alliance/lib/libVvh.a
alliance/tutorials/place_and_route.pdf
alliance/tutorials/place_and_route/src/Makefile
alliance/tutorials/place_and_route/src/amd2901/Makefile