graphics/darktable: update to 3.0.2

This is an upgrade for darktable from 3.0.0 to 3.0.2, with
Ludger's changes from the original PR submission:
- export to Flickr, Facebook and Google Photo removed
  as [they are] no longer supported in 3.0.2

And these changes by mandree@:

- rediff patches
- reshuffle Makefile per portclippy recommendation
- remove COLORD option, it's not technically required to build, but a
  a raw image processing application without color management
  makes little sense. This option was default-on anyways.

Changes 3.0.0 -> 3.0.1:
https://www.darktable.org/2020/03/darktable-301-released/
https://github.com/darktable-org/darktable/releases/tag/release-3.0.1

Changes 3.0.1 -> 3.0.2:
https://www.darktable.org/2020/04/darktable-302-released/
https://github.com/darktable-org/darktable/releases/tag/release-3.0.2

PR:		246065
Submitted by:	Ludger Bolmerg <lbolmerg@posteo.de>
Approved by:	Jean-Sébastien Pédron <dumbbell@> (maintainer)
This commit is contained in:
Matthias Andree 2020-05-13 12:05:35 +00:00
parent e320d53dff
commit 180bb30d42
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=535105
5 changed files with 24 additions and 33 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= darktable
PORTVERSION= 3.0.0
PORTREVISION= 4
PORTVERSION= 3.0.2
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION:C/\.rc/rc/}/
@ -18,7 +17,9 @@ ONLY_FOR_ARCHS_REASON= uses SSE instructions and 64-bit address space
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
xsltproc:textproc/libxslt \
po4a-translate:textproc/po4a
LIB_DEPENDS= libcurl.so:ftp/curl \
LIB_DEPENDS= libcolord.so:graphics/colord \
libcolord-gtk.so:graphics/colord-gtk \
libcurl.so:ftp/curl \
libexiv2.so:graphics/exiv2 \
libjson-glib-1.0.so:devel/json-glib \
liblcms2.so:graphics/lcms2 \
@ -32,34 +33,27 @@ USES= cmake compiler:c++11-lib desktop-file-utils \
gl gnome jpeg pkgconfig sqlite tar:xz xorg
USE_GL= glu
USE_GNOME= cairo gtk30 intltool librsvg2 libxml2
USE_XORG= ice sm x11 xext xrandr
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
INSTALLS_ICONS= yes
OPTIONS_DEFINE= COLORD DOCS FLICKR GEO GPHOTO GRAPHMAGICK \
LIBSECRET LUA NLS OPENEXR OPENJPEG PRINT WEBP
GEO_DESC= Support geotagging
LIBSECRET_DESC= Support libsecret as password backend
OPTIONS_DEFAULT=COLORD FLICKR GEO GPHOTO LUA OPENEXR OPENJPEG \
PRINT WEBP
OPTIONS_SUB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.rc/~rc/}
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_XORG= ice sm x11 xext xrandr
CMAKE_ARGS+= -DBINARY_PACKAGE_BUILD=1
CMAKE_ARGS+= -DBUILD_CMSTEST:BOOL=ON
CMAKE_ARGS+= -DUSE_KWALLET:BOOL=ON
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -fopenmp
LDFLAGS+= -L${LOCALBASE}/lib
COLORD_LIB_DEPENDS= libcolord.so:graphics/colord \
libcolord-gtk.so:graphics/colord-gtk
COLORD_CMAKE_OFF= -DUSE_COLORD:BOOL=OFF
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.rc/~rc/}
FLICKR_LIB_DEPENDS= libflickcurl.so:www/flickcurl
FLICKR_CMAKE_OFF= -DUSE_FLICKR:BOOL=OFF
OPTIONS_DEFINE= DOCS GEO GPHOTO GRAPHMAGICK \
LIBSECRET LUA NLS OPENEXR OPENJPEG PRINT WEBP
OPTIONS_DEFAULT=GEO GPHOTO LUA OPENEXR OPENJPEG \
PRINT WEBP
OPTIONS_SUB= yes
GEO_DESC= Support geotagging
LIBSECRET_DESC= Support libsecret as password backend
GEO_LIB_DEPENDS= libosmgpsmap-1.0.so:x11-toolkits/osm-gps-map
GEO_CMAKE_OFF= -DUSE_MAP:BOOL=OFF

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1577531331
SHA256 (darktable-3.0.0.tar.xz) = 7195a5ff7ee95ab7c5a57e4e84f8c90cc4728b2c917359203c21293ab754c0db
SIZE (darktable-3.0.0.tar.xz) = 3827412
TIMESTAMP = 1588248963
SHA256 (darktable-3.0.2.tar.xz) = 6abaf661fe9414e92bdb33b58b98ef024ccf6132b7876abaf0751ec2109f36fb
SIZE (darktable-3.0.2.tar.xz) = 3931240

View File

@ -1,6 +1,6 @@
--- src/CMakeLists.txt.orig
--- src/CMakeLists.txt.orig 2020-04-15 07:10:53 UTC
+++ src/CMakeLists.txt
@@ -336,7 +336,7 @@ if(USE_OPENJPEG)
@@ -360,7 +360,7 @@ if(USE_OPENJPEG)
add_definitions("-DHAVE_OPENJPEG")
list(APPEND SOURCES "common/imageio_j2k.c")

View File

@ -1,6 +1,6 @@
--- src/external/rawspeed/cmake/Modules/CheckZLIB.cmake.orig 2018-01-18 18:05:10 UTC
--- src/external/rawspeed/cmake/Modules/CheckZLIB.cmake.orig 2020-04-03 21:02:54 UTC
+++ src/external/rawspeed/cmake/Modules/CheckZLIB.cmake
@@ -38,7 +38,7 @@ endif()
@@ -40,7 +40,7 @@ endif()
CHECK_PROTOTYPE_DEFINITION(zError
"const char* zError(int zErrorCode)"
"NULL"

View File

@ -18,9 +18,6 @@ lib/darktable/plugins/imageio/format/libtiff.so
%%WEBP%%lib/darktable/plugins/imageio/format/libwebp.so
lib/darktable/plugins/imageio/storage/libdisk.so
lib/darktable/plugins/imageio/storage/libemail.so
lib/darktable/plugins/imageio/storage/libfacebook.so
lib/darktable/plugins/imageio/storage/libgooglephoto.so
%%FLICKR%%lib/darktable/plugins/imageio/storage/libflickr.so
lib/darktable/plugins/imageio/storage/libgallery.so
lib/darktable/plugins/imageio/storage/liblatex.so
lib/darktable/plugins/imageio/storage/libpiwigo.so