- Update to 1.0

- Add "compiles" argument to USES=cran
This commit is contained in:
TAKATSU Tomonari 2016-07-28 10:17:21 +00:00
parent 23529091f4
commit 1809659a1d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=419208
3 changed files with 5 additions and 18 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= curl
PORTVERSION= 0.9.7
PORTVERSION= 1.0
CATEGORIES= ftp
DISTNAME= ${PORTNAME}_${PORTVERSION}
@ -14,9 +14,6 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:ftp/curl
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cran:auto-plist
post-patch:
@${REINPLACE_CMD} -e '/bin\//s|bash|sh|' ${WRKSRC}/configure
USES= cran:auto-plist,compiles
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (curl_0.9.7.tar.gz) = 46e150998723fd1937da598f47f49fe47e40c1f57ec594436c6ef1e0145b44dc
SIZE (curl_0.9.7.tar.gz) = 263926
TIMESTAMP = 1469528190
SHA256 (curl_1.0.tar.gz) = f8927228754fdfb21dbf08b9e67c5f97e06764c4adf327a4126eed84b1508f3d
SIZE (curl_1.0.tar.gz) = 283402

View File

@ -1,11 +0,0 @@
--- src/nslookup.c.orig 2016-01-23 20:44:53 UTC
+++ src/nslookup.c
@@ -8,6 +8,8 @@ const char *inet_ntop(int af, const void
#else
#include <netdb.h>
#include <arpa/inet.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
#endif
SEXP R_nslookup(SEXP hostname) {