sysutils/usbtop: Update 0.2 -> 1.0
This commit is contained in:
parent
4fb4ec21f6
commit
17a630916d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493972
@ -3,8 +3,7 @@
|
||||
|
||||
PORTNAME= usbtop
|
||||
DISTVERSIONPREFIX= release-
|
||||
DISTVERSION= 0.2
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 1.0
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
@ -13,7 +12,8 @@ COMMENT= Utility that shows an estimated instantaneous USB bandwidth
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libboost_system.so:devel/boost-libs
|
||||
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
|
||||
libpcap.so:net/libpcap
|
||||
|
||||
USES= cmake compiler:c++11-lang
|
||||
USE_GITHUB= yes
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1513559500
|
||||
SHA256 (aguinet-usbtop-release-0.2_GH0.tar.gz) = 6283454ccbfecab44276344b6bc1bf74e86808fb9f539ca63eb0447d7741487e
|
||||
SIZE (aguinet-usbtop-release-0.2_GH0.tar.gz) = 10828
|
||||
TIMESTAMP = 1551197211
|
||||
SHA256 (aguinet-usbtop-release-1.0_GH0.tar.gz) = eea7f2fbdcaacbf1097f62f9e4fb50ffd238cec3085b67d384ab0a419274e1da
|
||||
SIZE (aguinet-usbtop-release-1.0_GH0.tar.gz) = 626770
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2017-12-17 21:14:26 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -16,6 +16,6 @@ find_package(Boost COMPONENTS thread sys
|
||||
|
||||
##
|
||||
|
||||
-include_directories(include)
|
||||
+include_directories(include ${PCAP_INCLUDE_DIR} ${Boost_INCLUDE_DIR})
|
||||
|
||||
add_subdirectory(src)
|
@ -1,14 +0,0 @@
|
||||
https://github.com/aguinet/usbtop/pull/15
|
||||
|
||||
--- src/CMakeLists.txt.orig 2017-12-17 21:14:26 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -21,5 +21,9 @@ usb_stats.cpp
|
||||
|
||||
add_executable(usbtop ${SRC_FILES})
|
||||
target_link_libraries(usbtop ${PCAP_LIBRARIES} ${Boost_LIBRARIES})
|
||||
+if(UNIX AND NOT APPLE)
|
||||
+ # Boost.Thread 1.67+ headers reference pthread_condattr_*
|
||||
+ target_link_libraries(usbtop pthread)
|
||||
+endif()
|
||||
|
||||
install(TARGETS usbtop DESTINATION sbin)
|
@ -1,12 +0,0 @@
|
||||
https://github.com/aguinet/usbtop/pull/15
|
||||
|
||||
--- include/usbtop/usb_stats.h.orig 2017-12-17 21:14:26 UTC
|
||||
+++ include/usbtop/usb_stats.h
|
||||
@@ -35,6 +35,7 @@
|
||||
#include <cstddef>
|
||||
|
||||
#include <boost/circular_buffer.hpp>
|
||||
+#include <boost/noncopyable.hpp>
|
||||
#include <boost/thread/shared_mutex.hpp>
|
||||
|
||||
#define LIVE_SAMPLE_COUNT 128
|
@ -1,11 +0,0 @@
|
||||
--- src/CMakeLists.txt.orig 2017-12-17 21:14:26 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -4,7 +4,7 @@ add_definitions("-std=c++0x -Wall -D_GNU
|
||||
IF(CMAKE_BUILD_TYPE MATCHES "[Dd][Ee][Bb][Uu][Gg]")
|
||||
add_definitions("-g")
|
||||
else()
|
||||
- add_definitions("-O3")
|
||||
+ add_definitions("")
|
||||
endif()
|
||||
|
||||
set(SRC_FILES
|
@ -1,14 +0,0 @@
|
||||
--- src/buses.cpp.orig 2017-12-17 21:14:26 UTC
|
||||
+++ src/buses.cpp
|
||||
@@ -38,7 +38,11 @@
|
||||
|
||||
#include <tuple>
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+#define USB_DEVICE_START "usbus"
|
||||
+#else
|
||||
#define USB_DEVICE_START "usbmon"
|
||||
+#endif
|
||||
|
||||
static size_t g_len_usb_dev_start = 5; // strlen(USB_DEVICE_START
|
||||
|
Loading…
Reference in New Issue
Block a user