- Fix build with clang

PR:		185506
Submitted by:	ports fury
This commit is contained in:
Martin Wilke 2014-01-19 09:28:21 +00:00
parent 15bafe26e9
commit 177df99bd7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340257
13 changed files with 181 additions and 10 deletions

View File

@ -10,15 +10,18 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NetMap%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Make a graphical representation of the surrounding network
LICENSE= GPLv2
RUN_DEPENDS= dotty:${PORTSDIR}/graphics/graphviz
USE_GMAKE= yes
USES= gmake
PLIST_FILES= bin/makelist bin/netmap
NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
.for i in makelist netmap
(cd ${WRKSRC}/${i} && ${INSTALL_PROGRAM} ${i} \
${STAGEDIR}${PREFIX}/bin)
.endfor
.include <bsd.port.mk>

View File

@ -1,14 +1,16 @@
--- belgolib/files.c.orig 2010-01-06 08:00:52.000000000 +0900
+++ belgolib/files.c 2011-11-23 22:22:36.000000000 +0900
@@ -17,7 +17,7 @@
@@ -17,8 +17,8 @@
Infile::Infile() : ifstream() { }
-Infile::Infile(const string& file_name, int mode, bool fatal)
- : ifstream(file_name.c_str(), (std::_Ios_Openmode)mode)
+Infile::Infile(const string& file_name, ios::openmode mode, bool fatal)
: ifstream(file_name.c_str(), (std::_Ios_Openmode)mode)
+ : ifstream(file_name.c_str(), (std::ios_base::openmode)mode)
{
if(cdb>d_list)
@@ -39,7 +39,7 @@
}
@ -18,3 +20,12 @@
{
if(cdb>d_list)
@@ -49,7 +49,7 @@
//file is open, close it first
close();
- open(file_name.c_str(), (std::_Ios_Openmode)mode);
+ open(file_name.c_str(), (std::ios_base::openmode)mode);
if(int error_nr = check_open()) {
if(cdb>d_list)

View File

@ -0,0 +1,29 @@
--- makelist/args.c.orig
+++ makelist/args.c
@@ -1,6 +1,6 @@
-#include <strstream>
+#include <sstream>
#include <iostream>
-#include <stdlib.h>
+#include <cstdlib>
using namespace std;
@@ -35,7 +35,7 @@
exit(-1);
}
-static void set_string_arg(strstream& ss, string& val)
+static void set_string_arg(stringstream& ss, string& val)
{
string argvalue;
ss >> argvalue;
@@ -62,7 +62,7 @@
static void process(const string& argline)
{
- strstream ss;
+ stringstream ss;
ss << argline;
string arg;

View File

@ -10,7 +10,14 @@
CPPFLAGS = -I../belgolib
@@ -34,7 +33,7 @@
@@ -28,13 +27,13 @@
test: $(OFILES)
$(CC) -o $(OEXE) $(OFILES) $(LDFLAGS)
- strip $(OEXE)
+# strip $(OEXE)
clean:
-/bin/rm -f $(OFILES) $(OEXE)
depend:

View File

@ -1,7 +1,7 @@
--- netmap/lookup.c.orig 2010-01-06 07:59:38.000000000 +0900
+++ netmap/lookup.c 2011-11-23 22:32:15.000000000 +0900
@@ -1,6 +1,8 @@
#include <strstream>
@@ -1,6 +1,7 @@
-#include <strstream>
#include <iostream>
+#include <sys/types.h>

View File

@ -1,6 +1,21 @@
--- netmap/misc.c.orig Sun Dec 15 14:54:26 2002
+++ netmap/misc.c Sun Dec 15 14:54:26 2002
@@ -54,7 +54,7 @@
@@ -1,4 +1,4 @@
-#include <strstream>
+#include <sstream>
#include <string>
#include "misc.h"
@@ -17,7 +17,7 @@
string int_to_str(int i)
{
- strstream ost;
+ stringstream ost;
ost << i << char(0);
@@ -55,7 +55,7 @@
return false;
bool had_point = false;

View File

@ -0,0 +1,26 @@
--- netmap/args.c.orig
+++ netmap/args.c
@@ -1,4 +1,4 @@
-#include <strstream>
+#include <sstream>
#include <iostream>
#include <string>
@@ -47,7 +47,7 @@
exit(0);
}
-static void set_string_arg(strstream& ss, string& val)
+static void set_string_arg(stringstream& ss, string& val)
{
string argvalue;
ss >> argvalue;
@@ -60,7 +60,7 @@
static void process(const string& argline)
{
- strstream ss;
+ stringstream ss;
ss << argline;
string arg;

View File

@ -0,0 +1,7 @@
--- netmap/drawmap.c.orig
+++ netmap/drawmap.c
@@ -1,4 +1,3 @@
-#include <strstream>
#include <iostream>
#include <fstream>

View File

@ -0,0 +1,7 @@
--- netmap/hostclass.c.orig
+++ netmap/hostclass.c
@@ -1,4 +1,3 @@
-#include <strstream>
#include <map>
//from belgolib

View File

@ -0,0 +1,15 @@
--- netmap/hostclass.h.orig
+++ netmap/hostclass.h
@@ -48,10 +48,10 @@
HostClass* a;
HostClass* b;
- bool operator==(HostLink& hl)
+ bool operator==(const HostLink& hl) const
{ return a == hl.a && b == hl.b; }
- bool operator <(HostLink& hl)
+ bool operator <(const HostLink& hl) const
{ return a==hl.a ? b < hl.b : a < hl.a; }
};

View File

@ -0,0 +1,15 @@
--- netmap/lookup.h.orig
+++ netmap/lookup.h
@@ -14,10 +14,10 @@
string ip;
string hostname;
- bool operator==(const HostRec& hr)
+ bool operator==(const HostRec& hr) const
{ return ip == hr.ip && hostname == hr.hostname; }
- bool operator<(const HostRec& hr)
+ bool operator<(const HostRec& hr) const
{ return ip==hr.ip ? hostname<hr.hostname : ip<hr.ip; }
};

View File

@ -0,0 +1,10 @@
--- netmap/misc.h.orig
+++ netmap/misc.h
@@ -2,7 +2,6 @@
#define _misc_h_
#include <string>
-#include <strstream>
#include <iostream>
#include <list>

View File

@ -0,0 +1,26 @@
--- netmap/netmap.c.orig
+++ netmap/netmap.c
@@ -1,4 +1,4 @@
-#include <strstream>
+#include <sstream>
#include <iostream>
#include <fstream>
@@ -18,7 +18,7 @@
Dbgfile dbgs;
int cdb = 1;
-static void copy_line(strstream& os, istream& inf)
+static void copy_line(stringstream& os, istream& inf)
{
string result;
@@ -67,7 +67,7 @@
int nr_hops = 0;
int invalid_hosts_found = 0;
while(inf && !inf.eof()) {
- strstream line;
+ stringstream line;
copy_line(line, inf);
if(max_hops && ++nr_hops > max_hops) {