use Motif widgets if HAVE_MOTIF=yes.

This commit is contained in:
Eric L. Hernes 1996-10-11 20:36:10 +00:00
parent 6821941f98
commit 1760aa0a0c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3961
4 changed files with 58 additions and 32 deletions

View File

@ -3,7 +3,7 @@
# Date created: 19 December 1994
# Whom: janek
#
# $Id: Makefile,v 1.7 1995/05/13 09:13:51 asami Exp $
# $Id: Makefile,v 1.8 1995/11/27 04:05:17 asami Exp $
#
DISTNAME= moxftp-2.2
@ -21,13 +21,35 @@ STRIP=
# athena3d - for athena 3 d version, (you should have installed Xaw3d!!!)
# openlook - for open look version - (not tested!!!)
# If you use athena3d uncomment DEPENDS !!!
.if defined(HAVE_MOTIF)
CONFIGURE_ARGS= motif
PROGRAM_NAME=mftp
RESOURCE_NAME=Mftp
.else
CONFIGURE_ARGS= athena
PROGRAM_NAME=xftp
RESOURCE_NAME=Xftp
.endif
#DEPENDS= ${PORTSDIR}/x11/Xaw3d
.if !defined (NOMANCOMPRESS)
GZIP_EXT=.gz
.else
GZIP_EXT=
.endif
pre-install:
sed -e 's,@PROGRAM_NAME@,${PROGRAM_NAME},' \
-e 's,@RESOURCE_NAME@,${RESOURCE_NAME},' \
-e 's,@GZIP_EXT@,${GZIP_EXT},' pkg/PLIST.in >pkg/PLIST
post-install:
strip ${PREFIX}/bin/xftp
install -c -m 0444 ${WRKSRC}/xftp.man ${PREFIX}/man/man1/xftp.1
gzip -9nf ${PREFIX}/man/man1/xftp.1
strip ${PREFIX}/bin/${PROGRAM_NAME}
install -c -m 0444 ${WRKSRC}/${PROGRAM_NAME}.man ${PREFIX}/man/man1/${PROGRAM_NAME}.1
.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/${PROGRAM_NAME}.1
.endif
pre-clean:
@rm -f pkg/PLIST
.include <bsd.port.mk>

View File

@ -1,19 +1,20 @@
*** Imakefile.orig Mon Dec 19 23:25:00 1994
--- Imakefile Mon Dec 19 23:24:38 1994
***************
*** 126,132 ****
OBJS_STANDARD = main.o ftp.o callftp.o connect.o login.o wc_hooks.o \
disconnect.o remote_dir.o pwd.o peek.o syst.o \
bsdstrstr.o get.o lcd.o cd.o initialize.o dir_subs.o \
! local_dir.o put.o mkdir.o type.o fb_rs.o version.o \
regerror.o regexp.o regsub.o translate.o help.o \
tran_table.o sort.o noop.o List.o ListSW.o time.o \
tm_to_time.o archie.o popen.o icons.o myfgets.o \
--- 126,132 ----
OBJS_STANDARD = main.o ftp.o callftp.o connect.o login.o wc_hooks.o \
disconnect.o remote_dir.o pwd.o peek.o syst.o \
bsdstrstr.o get.o lcd.o cd.o initialize.o dir_subs.o \
! local_dir.o put.o mkdir.o type.o fb_rs.o version.o \
regerror.o regexp.o regsub.o translate.o help.o \
tran_table.o sort.o noop.o List.o ListSW.o time.o \
tm_to_time.o archie.o popen.o icons.o myfgets.o \
--- Imakefile.orig Fri May 20 15:44:40 1994
+++ Imakefile Fri Oct 11 11:05:44 1996
@@ -110,7 +110,7 @@
#endif
HP_DEFINE = -DHP_STUFF
#else
- XMLIB = -L$(USRLIBDIR) -lXm
+ XMLIB = -L$(USRLIBDIR) ${MOTIFLIB}
#endif
#endif
@@ -126,7 +126,7 @@
OBJS_STANDARD = main.o ftp.o callftp.o connect.o login.o wc_hooks.o \
disconnect.o remote_dir.o pwd.o peek.o syst.o \
bsdstrstr.o get.o lcd.o cd.o initialize.o dir_subs.o \
- local_dir.o put.o mkdir.o type.o fb_rs.o version.o \
+ local_dir.o put.o mkdir.o type.o fb_rs.o version.o \
regerror.o regexp.o regsub.o translate.o help.o \
tran_table.o sort.o noop.o List.o ListSW.o time.o \
tm_to_time.o archie.o popen.o icons.o myfgets.o \

View File

@ -1,5 +1,14 @@
--- ./configure.org Mon Mar 21 13:43:36 1994
+++ ./configure Sat May 13 01:20:26 1995
--- configure.orig Mon Mar 21 15:43:36 1994
+++ configure Fri Oct 11 13:14:59 1996
@@ -165,7 +165,7 @@
ANAME=Mftp
TYPE="-DMOTIF"
TLNAME=Xmp
- TKLIB="-lXm"
+ TKLIB="\${MOTIFLIB}"
fi
if test "${TK}" = "xaw3d"; then
@@ -321,7 +321,7 @@
cd conftestdir
cat > Imakefile <<EOF

View File

@ -1,6 +0,0 @@
@cwd /usr/X11R6
@mode 555
bin/xftp
@mode 444
lib/X11/app-defaults/Xftp
man/man1/xftp.1.gz