2007-09-22 misc/mango: Depends on broken package qextmdi
2007-04-01 lang/f2py: Replaced by py-numpy Approved by: miwi (co-mentor)
This commit is contained in:
parent
97a1540393
commit
1746cc8caa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=200200
2
MOVED
2
MOVED
@ -3244,3 +3244,5 @@ net-im/micq|net-im/climm|2007-09-18|Project renamed
|
||||
graphics/blender-devel|graphics/blender|2007-09-21|Not needed since binary version is gone
|
||||
print/ghostscript-afpl|print/ghostscript-gpl|2007-09-24|Replaced by print/ghostscript-gpl
|
||||
print/ghostscript-afpl-nox11|print/ghostscript-gpl-nox11|2007-09-24|Replaced by print/ghostscript-gpl-nox11
|
||||
misc/mango||2007-09-27|Has expired: Depends on broken package qextmdi
|
||||
lang/f2py||2007-09-27|Has expired: Replaced by py-numpy
|
||||
|
@ -54,7 +54,6 @@
|
||||
SUBDIR += expect
|
||||
SUBDIR += ezm3
|
||||
SUBDIR += f2c
|
||||
SUBDIR += f2py
|
||||
SUBDIR += f77
|
||||
SUBDIR += fasm
|
||||
SUBDIR += fbbi
|
||||
|
@ -1,49 +0,0 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: f2py
|
||||
# Date created: Jun 12, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= f2py
|
||||
PORTVERSION= 2.45.241.1926
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= lang python
|
||||
MASTER_SITES= http://cens.ioc.ee/projects/f2py2e/2.x/
|
||||
DISTNAME= ${PORTNAME:U}-${PORTVERSION:R}_${PORTVERSION:E}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Fortran to Python Interface Generator
|
||||
|
||||
RUN_DEPENDS= ${PYNUMERIC}
|
||||
|
||||
CONFLICTS= py*-numpy-1.*
|
||||
|
||||
DEPRECATED= Replaced by py-numpy
|
||||
EXPIRATION_DATE= 2007-04-01
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_PKGNAME= F2PY
|
||||
PYDISTUTILS_PKGVERSION= 2.45.241_1926
|
||||
|
||||
PLIST_FILES= bin/f2py
|
||||
MAN1= f2py.1
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= *
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/f2py.1 ${MAN1PREFIX}/man/man1
|
||||
@${FIND} ${PYTHON_SITELIBDIR}/f2py2e ! -type d | \
|
||||
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
|
||||
@${FIND} ${PYTHON_SITELIBDIR}/f2py2e -type d | ${SORT} -r | \
|
||||
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (F2PY-2.45.241_1926.tar.gz) = 8aedac9cad32afdcddcfb026b6393ece
|
||||
SHA256 (F2PY-2.45.241_1926.tar.gz) = f11525d8a3ec167b53cdb1c3882dff673960268bdf5c701bfb28602b3101075f
|
||||
SIZE (F2PY-2.45.241_1926.tar.gz) = 139482
|
@ -1,11 +0,0 @@
|
||||
--- setup.py.orig Sun Jan 30 12:22:14 2005
|
||||
+++ setup.py Thu Nov 16 18:46:25 2006
|
||||
@@ -40,7 +40,7 @@
|
||||
f2py2e.main()
|
||||
'''%(os.path.basename(sys.executable))
|
||||
|
||||
-f2py_exe = 'f2py'+os.path.basename(sys.executable)[6:]
|
||||
+f2py_exe = 'f2py'
|
||||
if f2py_exe[-4:]=='.exe':
|
||||
f2py_exe = f2py_exe[:-4] + '.py'
|
||||
if 'bdist_wininst' in sys.argv and f2py_exe[-3:] != '.py':
|
@ -1,9 +0,0 @@
|
||||
Writing Python C/API wrappers for Fortran routines can be a very tedious task,
|
||||
especially if a Fortran routine takes more than 20 arguments but only few of
|
||||
them are relevant for the problems that they solve. So, I have developed a
|
||||
tool that generates the C/API modules containing wrapper functions of Fortran
|
||||
routines. I call this tool as F2PY - Fortran to Python Interface Generator.
|
||||
It is completely written in Python language and can be called from the command
|
||||
line as f2py.
|
||||
|
||||
WWW: http://cens.ioc.ee/projects/f2py2e/
|
@ -311,7 +311,6 @@
|
||||
SUBDIR += lv
|
||||
SUBDIR += magicpoint
|
||||
SUBDIR += man.el
|
||||
SUBDIR += mango
|
||||
SUBDIR += mbuffer
|
||||
SUBDIR += mc
|
||||
SUBDIR += mc-light
|
||||
|
@ -1,72 +0,0 @@
|
||||
# New ports collection makefile for: mango
|
||||
# Date created: 23 March 2001
|
||||
# Whom: Roland Jesse <roland.jesse@gmx.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mango
|
||||
PORTVERSION= 0.27
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR=mango
|
||||
DIST_SUBDIR= KDE
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A recipe management software
|
||||
|
||||
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
|
||||
|
||||
DEPRECATED= Depends on broken package qextmdi
|
||||
EXPIRATION_DATE=2007-09-22
|
||||
|
||||
.if defined(WITH_KDE)
|
||||
LIB_DEPENDS+= kextmdi.2:${PORTSDIR}/devel/qextmdi
|
||||
PKGNAMESUFFIX= -kde
|
||||
.else
|
||||
LIB_DEPENDS+= qextmdi.2:${PORTSDIR}/devel/qextmdi
|
||||
PKGNAMESUFFIX= -nokde
|
||||
.endif
|
||||
|
||||
PLIST_FILES= bin/mango
|
||||
USE_BZIP2= yes
|
||||
USE_GL= yes
|
||||
MAKE_ENV+= QTDIR=${QT_PREFIX} LDFLAGS="-lkextmdi"
|
||||
.if defined(WITH_KDE)
|
||||
USE_KDELIBS_VER= 3
|
||||
.else
|
||||
USE_QT_VER= 3
|
||||
.endif
|
||||
.if defined(MAKE_JOBS)
|
||||
MAKE_ARGS+= -j${MAKE_JOBS}
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_KDE)
|
||||
pre-configure:
|
||||
@${ECHO_CMD}
|
||||
@${ECHO_CMD} "Note: Mango can be build with KDE support."
|
||||
@${ECHO_CMD} " Please specify WITH_KDE in case you want to do so."
|
||||
@${ECHO_CMD} " Make sure that the prerequisite QextMDI library"
|
||||
@${ECHO_CMD} " was also installed with KDE support. The easiest"
|
||||
@${ECHO_CMD} " way to accomplish this is to set WITH_KDE=yes in"
|
||||
@${ECHO_CMD} " /etc/make.conf."
|
||||
@${ECHO_CMD}
|
||||
.endif
|
||||
|
||||
do-configure:
|
||||
.if defined(WITH_KDE)
|
||||
@(cd ${WRKSRC} && \
|
||||
${REINPLACE_CMD} -e 's|warn_on debug|warn_off release kde|' mango.pro)
|
||||
.else
|
||||
@(cd ${WRKSRC} && \
|
||||
${REINPLACE_CMD} -e 's|warn_on debug|warn_off release|' mango.pro)
|
||||
.endif
|
||||
@(cd ${WRKSRC} && \
|
||||
${SETENV} ${MAKE_ENV} PREFIX=${PREFIX} \
|
||||
qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ mango.pro)
|
||||
|
||||
pre-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/mango ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (KDE/mango-0.27.tar.bz2) = e4986dd09251fb660e031cff38340c2d
|
||||
SHA256 (KDE/mango-0.27.tar.bz2) = fcb713ef91cdf1e9c94dccae0bcefb4142d138bf8d91e630247dcd67a7ddc027
|
||||
SIZE (KDE/mango-0.27.tar.bz2) = 119600
|
@ -1,9 +0,0 @@
|
||||
--- AdvancedSearchForm.ui.orig Tue Sep 27 21:13:16 2005
|
||||
+++ AdvancedSearchForm.ui Tue Sep 27 21:13:27 2005
|
||||
@@ -422,6 +422,5 @@
|
||||
<layoutdefaults spacing="6" margin="11"/>
|
||||
<includehints>
|
||||
<includehint>qextmdichildview.h</includehint>
|
||||
- <includehint>busywidget.h</includehint>
|
||||
</includehints>
|
||||
</UI>
|
@ -1,5 +0,0 @@
|
||||
Mango is a recipe management software. The main motivation of the
|
||||
project is to provide an open source mealmaster compatible
|
||||
application.
|
||||
|
||||
- Roland
|
Loading…
Reference in New Issue
Block a user