New port: audio/libaudec: Wrapper library over ffmpeg, sndfile and libsamplerate

This commit is contained in:
Yuri Victorovich 2020-01-06 04:51:41 +00:00
parent 6d388c3a5f
commit 173bb602cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=522202
5 changed files with 46 additions and 0 deletions

View File

@ -372,6 +372,7 @@
SUBDIR += libamrnb
SUBDIR += libamrwb
SUBDIR += libao
SUBDIR += libaudec
SUBDIR += libaudiofile
SUBDIR += libbpm
SUBDIR += libbs2b

26
audio/libaudec/Makefile Normal file
View File

@ -0,0 +1,26 @@
# $FreeBSD$
PORTNAME= libaudec
DISTVERSIONPREFIX= v
DISTVERSION= 0.1
CATEGORIES= audio devel
MAINTAINER= yuri@FreeBSD.org
COMMENT= Wrapper library over ffmpeg, sndfile and libsamplerate
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile
USES= compiler:c11 meson pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= alex-tee
USE_LDCONFIG= yes
PLIST_FILES= include/audec/audec.h \
lib/libaudec.so \
libdata/pkgconfig/audec.pc
.include <bsd.port.mk>

3
audio/libaudec/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1578285717
SHA256 (alex-tee-libaudec-v0.1_GH0.tar.gz) = 5a001391ce208a1abaf21064e4069418919e175258a23c3c748fad22ae42fd0a
SIZE (alex-tee-libaudec-v0.1_GH0.tar.gz) = 75019

View File

@ -0,0 +1,11 @@
--- meson.build.orig 2020-01-06 04:43:34 UTC
+++ meson.build
@@ -160,7 +160,7 @@ config_h_dep = declare_dependency (
)
audec_deps += config_h_dep
-audec = static_library (
+audec = shared_library (
'audec',
sources: srcs,
dependencies: [

5
audio/libaudec/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
libaudec (lib audio decoder) is a wrapper library over ffmpeg, sndfile and
libsamplerate for reading and resampling audio files, based on Robin Gareus'
audio_decoder code (https://github.com/x42/silan/tree/master/audio_decoder).
WWW: https://github.com/alex-tee/libaudec