Bridge betwean ClamAV antivirus software and Squid caching proxy.

Squidclam is a replacement for SquidClamAV-Redirector.py written
in C using libclamav and libcurl

Author:	squidclam@users.sourceforge.net
WWW:	http://sourceforge.net/projects/squidclam/

PR:		ports/82652
Submitted by:	Alexander Novitsky <alecn2002@yandex.ru>
Approved by:	flz (mentor)
This commit is contained in:
Renato Botelho 2005-07-20 17:43:59 +00:00
parent 060901806e
commit 172f2acbd8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139724
6 changed files with 129 additions and 0 deletions

View File

@ -483,6 +483,7 @@
SUBDIR += snortsms
SUBDIR += snortsnarf
SUBDIR += spike-proxy
SUBDIR += squidclam
SUBDIR += srm
SUBDIR += srp
SUBDIR += sscep

View File

@ -0,0 +1,53 @@
# New ports collection makefile for: squidclam
# Date created: 2005-06-26
# Whom: Alexander Novitsky <alecn2002@yandex.ru>
#
# $FreeBSD$
#
PORTNAME= squidclam
PORTVERSION= 0.11
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= alecn2002@yandex.ru
COMMENT= Bridge betwean ClamAV antivirus software and Squid caching proxy
BUILD_DEPENDS= ${LOCALBASE}/bin/clamscan:${PORTSDIR}/security/clamav \
${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
NO_INSTALL_MANPAGES= yes
PORTDOCS= README Changelog
SUB_FILES= pkg-message
PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}/$f
.endfor
.endif
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample.conf ${EXAMPLESDIR}/${PORTNAME}.conf
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (squidclam-0.11.tar.gz) = a15a1f1d61f79c7f6b7830b9a45906b7
SIZE (squidclam-0.11.tar.gz) = 10495

View File

@ -0,0 +1,57 @@
--- configure.orig Sun Apr 24 23:40:07 2005
+++ configure Sun Jun 26 01:49:42 2005
@@ -4,52 +4,16 @@
CLAMLIBS="`clamav-config --libs || exit -1`"
CURLLIBS="`curl-config --libs || exit -1`"
-CFLAGS="$CFLAGS $CURLLIBS $CLAMLIBS -lclamav -lcurl"
+CFLAGS="-I%%LOCALBASE%%/include $CFLAGS $CURLLIBS $CLAMLIBS -lclamav -lcurl"
OUTFILE=Makefile
BINARY=squidclam
-TMPFILE=`mktemp`
# only use libs once
CFLAGS="`echo $CFLAGS | tr ' ' '\n' | sort -u | tr '\n' ' '`"
-# no options allowed
-if test $# -ne 0
-then
- echo ""
- echo "This is just a very small script. No Options available."
- echo "If you like to provide me with a better one please do :)"
- echo ""
- exit -1
-fi
-
-# compiler test
-if test x"$CC" = "x"
-then
- CC="gcc -Wall"
-fi
-
-# can we generate an executable
-cat > $TMPFILE.c << EOF
-int main (void) {
- return 0;
-}
-EOF
-
-$CC -o $TMPFILE.exe $TMPFILE.c
-
-if test $? -ne 0
-then
- echo "compiler not able to generate an executable"
- exit -1
-else
- rm -f $TMPFILE*
-fi
-
# write makefile
cat > $OUTFILE << EOF
-ifndef \$(DESTDIR)
- DESTDIR="/usr/local/bin"
-endif
+DESTDIR?= "%%PREFIX%%/bin"
CFLAGS=$CFLAGS

View File

@ -0,0 +1,9 @@
***********************************************************************
*
* To use this software you need to make changes in squid config file.
* Please refer to %%DOCSDIR%%/README.
* You may find example of config file for this software here:
* %%EXAMPLESDIR%%/squidclam.conf
* Plce your work copy of squidclam.conf into %%PREFIX%%/etc/ directory.
*
***********************************************************************

View File

@ -0,0 +1,7 @@
Bridge betwean ClamAV antivirus software and Squid caching proxy.
Squidclam is a replacement for SquidClamAV-Redirector.py written
in C using libclamav and libcurl
Author: squidclam@users.sourceforge.net
WWW: http://sourceforge.net/projects/squidclam/