add cfv
cfv is a utility to both test and create .sfv, .csv and md5sum files
This commit is contained in:
parent
78405deff0
commit
172b30f771
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=45272
@ -17,6 +17,7 @@
|
||||
SUBDIR += ca-roots
|
||||
SUBDIR += calife
|
||||
SUBDIR += cfs
|
||||
SUBDIR += cfv
|
||||
SUBDIR += checkpassword
|
||||
SUBDIR += chkrootkit
|
||||
SUBDIR += chrootuid
|
||||
|
28
security/cfv/Makefile
Normal file
28
security/cfv/Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
# ex:ts=8
|
||||
# New ports collection makefile for: cfv
|
||||
# Date created: Jul 20, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cfv
|
||||
PORTVERSION= 1.8
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/fchksum.so:${PORTSDIR}/security/py-fchksum
|
||||
|
||||
USE_PYTHON= yes
|
||||
ALL_TARGET= cfv.wrapper
|
||||
INSTALL_TARGET= install-wrapper
|
||||
|
||||
MAN1= cfv.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/cfv/distinfo
Normal file
1
security/cfv/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (cfv-1.8.tar.gz) = ab9aeb688709187e42c995c97ef4411a
|
18
security/cfv/files/patch-Makefile
Normal file
18
security/cfv/files/patch-Makefile
Normal file
@ -0,0 +1,18 @@
|
||||
--- Makefile.orig Fri Jul 20 16:53:10 2001
|
||||
+++ Makefile Fri Jul 20 16:53:53 2001
|
||||
@@ -1,5 +1,5 @@
|
||||
PYTHON=python
|
||||
-prefix=/usr/local
|
||||
+prefix=%%PREFIX%%
|
||||
exec_prefix=${prefix}
|
||||
|
||||
#finds the site-packages dir that matches the selected prefix, or if none do, falls back to wherever it can find one..
|
||||
@@ -10,7 +10,7 @@
|
||||
mandir=${prefix}/man
|
||||
install=/usr/bin/install -c
|
||||
user=root
|
||||
-group=root
|
||||
+group=wheel
|
||||
|
||||
foo:
|
||||
@echo 'to install cfv, type make install or install-wrapper.'
|
1
security/cfv/pkg-comment
Normal file
1
security/cfv/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
cfv is a utility to both test and create .sfv, .csv and md5sum files
|
14
security/cfv/pkg-descr
Normal file
14
security/cfv/pkg-descr
Normal file
@ -0,0 +1,14 @@
|
||||
cfv is a utility to both test and create .sfv, .csv and md5sum files. These
|
||||
files are commonly used to ensure the correct retrieval or storage of data.
|
||||
|
||||
Features:
|
||||
- supports .sfv, .csv(2, 3, and 4 field variants) and md5sum file formats
|
||||
- automatic checksum file naming ability in create mode
|
||||
- recursive operation
|
||||
- show unverified files option
|
||||
- ignore case and fix path seperator options for cross platform use
|
||||
- transparent gzip support for checksum files
|
||||
- configurable renaming of bad files (with testing against previous bad
|
||||
files, to save only unique differing copies)
|
||||
|
||||
WWW: http://cfv.sourceforge.net/
|
4
security/cfv/pkg-plist
Normal file
4
security/cfv/pkg-plist
Normal file
@ -0,0 +1,4 @@
|
||||
bin/cfv
|
||||
lib/%%PYTHON_VERSION%%/site-packages/cfv.py
|
||||
lib/%%PYTHON_VERSION%%/site-packages/cfv.pyc
|
||||
lib/%%PYTHON_VERSION%%/site-packages/cfv.pyo
|
Loading…
Reference in New Issue
Block a user