Remove patches left over from the old mpd port.
This commit is contained in:
parent
57df438c1f
commit
1671c22aea
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57151
@ -1,11 +0,0 @@
|
||||
--- src/Makefile.orig Thu Feb 25 22:18:47 1999
|
||||
+++ src/Makefile Fri Apr 30 12:24:58 1999
|
||||
@@ -69,7 +69,7 @@
|
||||
|
||||
MPD_VERSION!= echo -n "${VERSION} (`id -un`@`uname -n` `date +'%R %v'`)"
|
||||
|
||||
-COPTS+= -g -Wall -Wmissing-prototypes -Wnested-externs -Werror
|
||||
+COPTS+= -g -Wall -Wmissing-prototypes -Wnested-externs
|
||||
COPTS+= -DPATH_CONF_DIR=\"${MPD_CONF_DIR}\"
|
||||
COPTS+= -DSYSLOG_FACILITY=${SYSLOG_FACILITY}
|
||||
COPTS+= -DMPD_VERSION='"${MPD_VERSION}"'
|
@ -1,24 +0,0 @@
|
||||
--- src/log.c.orig Sun Sep 19 17:44:02 1999
|
||||
+++ src/log.c Sun Sep 19 18:07:49 1999
|
||||
@@ -271,7 +271,21 @@
|
||||
va_start(args, fmt);
|
||||
LogTimeStamp(logprintf);
|
||||
vlogprintf(fmt, args);
|
||||
+#if defined(__FreeBSD__) && defined(__alpha__)
|
||||
+ /*
|
||||
+ * This is an ugly hack! On FreeBSD/Alpha va_list is a non-scalar
|
||||
+ * type so to accommodate logging a simple string we steal a few
|
||||
+ * lines from vlogprintf below. Ick!
|
||||
+ */
|
||||
+#ifdef SYSLOG_FACILITY
|
||||
+ syslog(SYSLOG_FACILITY|LOG_INFO, "\n\n");
|
||||
+#else
|
||||
+ fprintf(logfp, "\n\n");
|
||||
+ fflush(logfp);
|
||||
+#endif
|
||||
+#else
|
||||
vlogprintf("\n", NULL);
|
||||
+#endif
|
||||
if (gLogOptions & LG_CONSOLE)
|
||||
{
|
||||
vfprintf(stdout, fmt, args);
|
Loading…
Reference in New Issue
Block a user