gsnapshot is a GTK2 application. It provides for capturing a screen snapshot of

the entire screen, a window or a region, with a simple user The package also
provides the gdisplay program, a simple image viewer with built-in directory
file browser.

WWW: http://www.softcraft.org/gsnapshot/

PR:		ports/114829
Submitted by:	Yinghong.Liu <relaxbsd@gmail.com>
This commit is contained in:
Pav Lucistnik 2007-07-28 21:30:46 +00:00
parent 5af82a7175
commit 1658e38003
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196508
7 changed files with 110 additions and 0 deletions

View File

@ -232,6 +232,7 @@
SUBDIR += grx
SUBDIR += gscan2pdf
SUBDIR += gsculpt
SUBDIR += gsnapshot
SUBDIR += gstreamer-plugins-aalib
SUBDIR += gstreamer-plugins-cairo
SUBDIR += gstreamer-plugins-jpeg

View File

@ -0,0 +1,44 @@
# New ports collection makefile for: gsnapshot
# Date created: 23 July 2007
# Whom: Yinghong.Liu <relaxbsd@gmail.com>
#
# $FreeBSD$
#
PORTNAME= gsnapshot
PORTVERSION= 1.0
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= relaxbsd@gmail.com
COMMENT= A gtk+ based screen capture
USE_AUTOTOOLS= automake:15:env libtool:15
USE_GNOME= gtk20
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
DESKTOP_ENTRIES= "gsnapshot" \
"A gtk+ based screen capture" \
"" \
"gsnapshot" \
"Application;Graphics;" \
"false"
pre-configure:
@${LN} -sf ${AUTOMAKE_DIR}/install-sh ${WRKSRC}
@${LN} -sf ${AUTOMAKE_DIR}/depcomp ${WRKSRC}
@${LN} -sf ${AUTOMAKE_DIR}/missing ${WRKSRC}
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (gsnapshot-1.0.tar.gz) = ef609075546f38e7a14f6ca59f8187df
SHA256 (gsnapshot-1.0.tar.gz) = 69dd5826ab94e65e04c5177789c8cd899ed6245e8aebf446fe250a1f32d55192
SIZE (gsnapshot-1.0.tar.gz) = 182662

View File

@ -0,0 +1,27 @@
--- src/filechooser.c.orig Mon Jul 16 06:05:22 2007
+++ src/filechooser.c Mon Jul 23 21:26:21 2007
@@ -19,9 +19,14 @@
*/
#include "filechooser.h"
+#include <sys/param.h>
#ifndef get_current_dir_name
-extern char *get_current_dir_name(void);
+extern char *get_current_dir_name_2() {
+ char *buf = malloc(MAXPATHLEN);
+ getwd(buf);
+ return buf;
+}
#endif
/*
@@ -325,7 +330,7 @@
gchar *path;
if (dirname == FILECHOOSER_CWD)
- path = (gchar *)get_current_dir_name ();
+ path = (gchar *)get_current_dir_name_2 ();
else
path = (gchar *)dirname;

View File

@ -0,0 +1,18 @@
--- src/gdisplay.c.orig Mon Jul 16 06:05:23 2007
+++ src/gdisplay.c Mon Jul 23 20:28:31 2007
@@ -19,9 +19,14 @@
#include "gdisplay.h"
#include "language.h"
+#include <sys/param.h>
#ifndef get_current_dir_name
-extern char *get_current_dir_name(void);
+extern char *get_current_dir_name() {
+ char *buf = malloc(MAXPATHLEN);
+ getwd(buf);
+ return buf;
+}
#endif
static gdisplay_t global; /* (protected) encapsulated program data */

View File

@ -0,0 +1,6 @@
gsnapshot is a GTK2 application. It provides for capturing a screen snapshot of
the entire screen, a window or a region, with a simple user The package also
provides the gdisplay program, a simple image viewer with built-in directory
file browser.
WWW: http://www.softcraft.org/gsnapshot/

View File

@ -0,0 +1,11 @@
bin/gdisplay
bin/gsnapshot
include/dialog.h
include/filechooser.h
include/grabber.h
include/iconbox.h
include/language.h
include/print.h
include/window.h
include/xpmglyphs.h
lib/libsnapshot.a