- Fix compilation error under XFree86 4.x

- Add USE_GMAKE
- Strip binary
- Support NOPORTDOCS
- Exclude GPL doc from package

PR: 24007
Submitted by: MAINTAINER
This commit is contained in:
Kevin Lo 2001-01-02 15:25:39 +00:00
parent 9cb7b46fd9
commit 1657710323
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36602
4 changed files with 71 additions and 9 deletions

View File

@ -16,14 +16,18 @@ MAINTAINER= anders@fix.no
BUILD_DEPENDS= ${LOCALBASE}/include/sidplay/compconf.h:${PORTSDIR}/audio/libsidplay
CXXFLAGS+= -I${PREFIX}/include -DHAVE_FREEBSD -DHAVE_MACHINE_SOUNDCARD_H
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/fcplay-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-install:
${INSTALL} -d -m 555 ${PREFIX}/share/doc/fcplay
@${INSTALL_DATA} ${WRKSRC}/ABOUT ${PREFIX}/share/doc/fcplay/
@${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/fcplay/
@${INSTALL_DATA} ${WRKSRC}/POINTER ${PREFIX}/share/doc/fcplay/
USE_GMAKE= yes
GNU_CONFIGURE= yes
CXXFLAGS+= -I${LOCALBASE}/include
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/fcplay
${INSTALL_DATA} ${WRKSRC}/ABOUT ${PREFIX}/share/doc/fcplay
${INSTALL_DATA} ${WRKSRC}/POINTER ${PREFIX}/share/doc/fcplay
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,10 @@
--- AudioDriver.h.orig Tue Mar 4 06:47:00 1997
+++ AudioDriver.h Tue Dec 12 02:46:01 2000
@@ -7,6 +7,7 @@
#include <string.h>
#include <sys/ioctl.h>
#include <unistd.h>
+#include "Config.h"
// These next includes were not required if libsidplay would not
// provide related HAVE_* definitions.

View File

@ -0,0 +1,49 @@
--- configure.orig Thu May 28 04:08:00 1998
+++ configure Tue Dec 12 02:51:01 2000
@@ -1631,41 +1631,6 @@
fi;
-# Extract the first word of "makedepend", so it can be a program name with args.
-set dummy makedepend; ac_word=$2
-echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1638: checking for $ac_word" >&5
-if eval "test \"`echo '$''{'ac_cv_prog_MAKEDEP'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- if test -n "$MAKEDEP"; then
- ac_cv_prog_MAKEDEP="$MAKEDEP" # Let the user override the test.
-else
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
- ac_dummy="$PATH"
- for ac_dir in $ac_dummy; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/$ac_word; then
- ac_cv_prog_MAKEDEP="makedepend"
- break
- fi
- done
- IFS="$ac_save_ifs"
- test -z "$ac_cv_prog_MAKEDEP" && ac_cv_prog_MAKEDEP="nomakedep"
-fi
-fi
-MAKEDEP="$ac_cv_prog_MAKEDEP"
-if test -n "$MAKEDEP"; then
- echo "$ac_t""$MAKEDEP" 1>&6
-else
- echo "$ac_t""no" 1>&6
-fi
-
-if test "$MAKEDEP" = "nomakedep"; then
- { echo "configure: error: No ``makedepend'' found." 1>&2; exit 1; }
-fi;
-
-
# Extract the first word of "ranlib", so it can be a program name with args.
set dummy ranlib; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
@@ -2297,4 +2262,3 @@
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
-$MAKE depend

View File

@ -1,5 +1,4 @@
bin/fcplay
share/doc/fcplay/ABOUT
share/doc/fcplay/COPYING
share/doc/fcplay/POINTER
@dirrm share/doc/fcplay