- update to 4.1b

- add new URL
Thanks to watchman@ludd.luth.se for the pointer
- make portlint happy
- honor given CFLAGS
This commit is contained in:
Dirk Meyer 2003-09-05 19:43:12 +00:00
parent b1ab77137a
commit 163a2ffc79
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88604
9 changed files with 112 additions and 95 deletions

View File

@ -6,12 +6,10 @@
#
PORTNAME= frodo
PORTVERSION= 4.1a
PORTREVISION= 1
PORTVERSION= 4.1b
CATEGORIES= emulators tk84
MASTER_SITES= ftp://metalab.unc.edu/pub/micro/commodore/crossplatform/emulators/Frodo/ \
ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/Frodo/
DISTNAME= FrodoV4_1a.Src
MASTER_SITES= http://iphcip1.physik.uni-mainz.de/~cbauer/
DISTNAME= FrodoV4_1b.Src
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Emulates a Commodore 64
@ -20,40 +18,40 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
USE_X_PREFIX= yes
ALL_TARGET= Frodo
WRKSRC= ${WRKDIR}/Frodo/Src
WRKNAME= Frodo-4.1b
WRKSRC= ${WRKDIR}/${WRKNAME}/Src
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
ROM= 1541 Basic Char Kernal
post-patch:
@${MV} ${WRKDIR}/Frodo/TkGui.tcl ${WRKDIR}/Frodo/TkGui.tcl.sed
@${MV} ${WRKDIR}/${WRKNAME}/TkGui.tcl ${WRKDIR}/${WRKNAME}/TkGui.tcl.sed
${SED} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
${WRKDIR}/Frodo/TkGui.tcl.sed > ${WRKDIR}/Frodo/TkGui.tcl
do-configure:
@(cd ${WRKSRC}; ${SH} ./configure)
${WRKDIR}/${WRKNAME}/TkGui.tcl.sed > ${WRKDIR}/${WRKNAME}/TkGui.tcl
do-install:
${SED} -e 's=\$${PREFIX}=${PREFIX}=g' \
< ${FILESDIR}/frodo > ${WRKDIR}/frodo
${INSTALL_SCRIPT} ${WRKDIR}/frodo ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/frodo
${INSTALL_PROGRAM} ${WRKDIR}/Frodo/Frodo ${PREFIX}/libexec/frodo
${INSTALL_PROGRAM} ${WRKDIR}/${WRKNAME}/Frodo ${PREFIX}/libexec/frodo
.for i in ${ROM}
${INSTALL_DATA} "${WRKDIR}/Frodo/${i} ROM" ${PREFIX}/libexec/frodo
${INSTALL_DATA} "${WRKDIR}/${WRKNAME}/${i} ROM" ${PREFIX}/libexec/frodo
.endfor
${INSTALL_DATA} "${WRKDIR}/Frodo/Frodo Logo" ${PREFIX}/libexec/frodo
${INSTALL_SCRIPT} "${WRKDIR}/Frodo/TkGui.tcl" ${PREFIX}/libexec/frodo
${INSTALL_DATA} "${WRKDIR}/${WRKNAME}/Frodo Logo" ${PREFIX}/libexec/frodo
${INSTALL_SCRIPT} "${WRKDIR}/${WRKNAME}/TkGui.tcl" ${PREFIX}/libexec/frodo
${MKDIR} ${PREFIX}/libexec/frodo/64prgs
@${TAR} -C ${WRKDIR}/Frodo/64prgs -cf - . | \
@${TAR} -C ${WRKDIR}/${WRKNAME}/64prgs -cf - . | \
${TAR} -C ${PREFIX}/libexec/frodo/64prgs -xf -
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in CHANGES
${INSTALL_DATA} ${WRKDIR}/Frodo/${i} ${DOCSDIR}/
${INSTALL_DATA} ${WRKDIR}/${WRKNAME}/${i} ${DOCSDIR}/
.endfor
@${TAR} -C ${WRKDIR}/Frodo/Docs -cf - . | ${TAR} -C ${DOCSDIR} -xf -
@${TAR} -C ${WRKDIR}/${WRKNAME}/Docs -cf - . | ${TAR} -C ${DOCSDIR} -xf -
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (FrodoV4_1a.Src.tar.gz) = 9a4b502f66275cb95c4f42631ca340fe
MD5 (FrodoV4_1b.Src.tar.gz) = 095b9f21c03204cc13f7f249e8866cd9

View File

@ -1,21 +1,10 @@
$FreeBSD$
--- CmdPipe.cpp.orig Wed Aug 6 20:56:26 1997
+++ CmdPipe.cpp Sat Nov 30 01:29:18 2002
@@ -9,16 +9,18 @@
extern "C" {
- #include <string.h>
+ #include <stdlib.h>
#include <unistd.h>
#include <sys/wait.h>
#include <sys/types.h>
--- CmdPipe.cpp.orig Wed Jan 2 22:19:34 2002
+++ CmdPipe.cpp Fri Sep 5 21:13:34 2003
@@ -17,9 +17,11 @@
#include <string.h>
#include <signal.h>
+#if ! defined(__FreeBSD__)
+#if !defined(__FreeBSD__)
#if defined(__alpha__)
#include <cma.h>
#endif
@ -23,7 +12,7 @@ $FreeBSD$
#if defined(AIX)
#include <sys/select.h>
@@ -27,6 +29,9 @@
@@ -28,6 +30,9 @@
#endif
#if defined(__linux__)

View File

@ -1,8 +0,0 @@
--- CmdPipe.h.orig Wed Aug 6 20:56:26 1997
+++ CmdPipe.h Mon Nov 18 05:31:41 2002
@@ -82,4 +82,4 @@
};
-#endif CmdPipe_h
+#endif // CmdPipe_h

View File

@ -1,14 +1,8 @@
--- ../TkGui.tcl.orig Wed Aug 6 20:56:34 1997
+++ ../TkGui.tcl Mon Apr 26 21:49:18 1999
@@ -1,9 +1,9 @@
-#!/usr/local/bin/X11/wish
--- ../TkGui.tcl.orig Wed May 30 19:03:47 2001
+++ ../TkGui.tcl Fri Sep 5 21:19:11 2003
@@ -1,4 +1,4 @@
-#!/usr/bin/wish
+#!%%LOCALBASE%%/bin/wish8.4 -f
# Frodo Tk GUI by Lutz Vieweg <lkv@mania.robin.de>
# requires Tk >= 4.1
-package require Tk 4.1
+## package require Tk 4.1
set prefname "$env(HOME)/.frodorc"

View File

@ -0,0 +1,31 @@
--- configure.orig Wed Jan 2 17:44:11 2002
+++ configure Fri Sep 5 21:39:45 2003
@@ -1602,15 +1602,15 @@
CFLAGS=$ac_save_CFLAGS
elif test $ac_cv_prog_cc_g = yes; then
if test "$GCC" = yes; then
- CFLAGS="-g -O2"
+ CFLAGS="${CFLAGS} -g -O2"
else
- CFLAGS="-g"
+ CFLAGS="${CFLAGS} -g"
fi
else
if test "$GCC" = yes; then
- CFLAGS="-O2"
+ CFLAGS="${CFLAGS} -O2"
else
- CFLAGS=
+ CFLAGS="${CFLAGS}"
fi
fi
# Some people use a C++ compiler to compile C. Since we use `exit',
@@ -2283,7 +2283,7 @@
fi
if [ x"$GXX" = "xyes" ]; then
- CFLAGS="-O2 -g -fomit-frame-pointer -Wall -Wno-unused -Wno-format"
+ CFLAGS="${CFLAGS} -O2 -g -fomit-frame-pointer -Wall -Wno-unused -Wno-format"
fi
UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown

View File

@ -0,0 +1,12 @@
--- sysdeps.h.orig Wed Jan 2 22:15:27 2002
+++ sysdeps.h Fri Sep 5 21:24:44 2003
@@ -25,7 +25,9 @@
#endif
#ifdef HAVE_VALUES_H
+#if !defined(__FreeBSD__)
#include <values.h>
+#endif
#endif
#ifdef HAVE_STRINGS_H

View File

@ -1,23 +1,24 @@
Frodo is a freeware C64 emulator for BeOS, Unix, MacOS, AmigaOS, Win32
and RiscOS systems and the world's first C64 emulator not bearing a
"64" in its name. :-) (No, it has absolutely nothing to do with
frodo.hiof.no, that's a pure coincidence.)
Frodo is a freeware C64 emulator for BeOS, Unix, MacOS, AmigaOS, Win32
and RiscOS systems and the world's first C64 emulator not bearing a
"64" in its name. :-) (No, it has absolutely nothing to do with
frodo.hiof.no, that's a pure coincidence.)
Frodo was developed to reproduce the graphics of games and demos
better than the existing C64 emulators. Therefore Frodo has relatively
high system requirements: It should only be run on systems with at
least a PowerPC/Pentium/68060. But on the other hand, Frodo can
display raster effects correctly that only result in a flickering mess
with other emulators.
Frodo was developed to reproduce the graphics of games and demos
better than the existing C64 emulators. Therefore Frodo has relatively
high system requirements: It should only be run on systems with at
least a PowerPC/Pentium/68060. But on the other hand, Frodo can
display raster effects correctly that only result in a flickering mess
with other emulators.
Frodo comes in three flavours: The "normal" Frodo with a line-based
emulation, the improved line-based emulation "Frodo PC", and the
single-cycle emulation Frodo SC that is slower but far more
compatible.
Frodo comes in three flavours: The "normal" Frodo with a line-based
emulation, the improved line-based emulation "Frodo PC", and the
single-cycle emulation Frodo SC that is slower but far more
compatible.
In addition to a precise 6510/VIC emulation, Frodo features a
processor-level 1541 emulation that is even able to handle about 95%
of all fast loaders. There is also a faster 1541 emulation for four
drives in .d64/x64 disk images, .t64/LYNX archives, or directories of
the host system.
In addition to a precise 6510/VIC emulation, Frodo features a
processor-level 1541 emulation that is even able to handle about 95%
of all fast loaders. There is also a faster 1541 emulation for four
drives in .d64/x64 disk images, .t64/LYNX archives, or directories of
the host system.
WWW: http://www.uni-mainz.de/~bauec002/FRMain.html

View File

@ -20,25 +20,25 @@ libexec/frodo/64prgs/tech-tech
libexec/frodo/64prgs/text26
@dirrm libexec/frodo/64prgs
@dirrm libexec/frodo
%%PORTDOCS%%share/doc/frodo/CHANGES
%%PORTDOCS%%share/doc/frodo/Main.html
%%PORTDOCS%%share/doc/frodo/author.html
%%PORTDOCS%%share/doc/frodo/bugreports.html
%%PORTDOCS%%share/doc/frodo/demoprograms.html
%%PORTDOCS%%share/doc/frodo/emulwindow.html
%%PORTDOCS%%share/doc/frodo/files.html
%%PORTDOCS%%share/doc/frodo/flavours.html
%%PORTDOCS%%share/doc/frodo/future.html
%%PORTDOCS%%share/doc/frodo/history.html
%%PORTDOCS%%share/doc/frodo/installation.html
%%PORTDOCS%%share/doc/frodo/kernal.html
%%PORTDOCS%%share/doc/frodo/keyboard.html
%%PORTDOCS%%share/doc/frodo/legalmush.html
%%PORTDOCS%%share/doc/frodo/overview.html
%%PORTDOCS%%share/doc/frodo/sam.html
%%PORTDOCS%%share/doc/frodo/settings.html
%%PORTDOCS%%share/doc/frodo/systemspecific.html
%%PORTDOCS%%share/doc/frodo/technicalinfo.html
%%PORTDOCS%%share/doc/frodo/thanks.html
%%PORTDOCS%%share/doc/frodo/whatsnew.html
%%PORTDOCS%%@dirrm share/doc/frodo
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/Main.html
%%PORTDOCS%%%%DOCSDIR%%/author.html
%%PORTDOCS%%%%DOCSDIR%%/bugreports.html
%%PORTDOCS%%%%DOCSDIR%%/demoprograms.html
%%PORTDOCS%%%%DOCSDIR%%/emulwindow.html
%%PORTDOCS%%%%DOCSDIR%%/files.html
%%PORTDOCS%%%%DOCSDIR%%/flavours.html
%%PORTDOCS%%%%DOCSDIR%%/future.html
%%PORTDOCS%%%%DOCSDIR%%/history.html
%%PORTDOCS%%%%DOCSDIR%%/installation.html
%%PORTDOCS%%%%DOCSDIR%%/kernal.html
%%PORTDOCS%%%%DOCSDIR%%/keyboard.html
%%PORTDOCS%%%%DOCSDIR%%/legalmush.html
%%PORTDOCS%%%%DOCSDIR%%/overview.html
%%PORTDOCS%%%%DOCSDIR%%/sam.html
%%PORTDOCS%%%%DOCSDIR%%/settings.html
%%PORTDOCS%%%%DOCSDIR%%/systemspecific.html
%%PORTDOCS%%%%DOCSDIR%%/technicalinfo.html
%%PORTDOCS%%%%DOCSDIR%%/thanks.html
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%