Update to 2.8.8.

PR:		ports/148442
Submitted by:	"Joseph S. Atkinson" <jsa@wickedmachine.net>
This commit is contained in:
Koop Mast 2010-07-13 18:03:37 +00:00
parent f34e4a8986
commit 162f8947f9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257728
5 changed files with 14 additions and 90 deletions

View File

@ -7,16 +7,17 @@
#
PORTNAME= xchat
PORTVERSION= 2.8.6
PORTREVISION= 7
PORTVERSION= 2.8.8
CATEGORIES= irc gnome ipv6
MASTER_SITES= SF \
MASTER_SITES= SF/${PORTNAME}/ \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= An X11 IRC client using the GTK+ 2 toolkit
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= xchat-1* xchat-systray-plugin-[0-9]*
USE_BZIP2= yes
@ -38,6 +39,10 @@ OPTIONS= DBUS "Enable DBUS support" on \
TCL "Enable TCL support" off \
SOCKS "Build with socks5 support" off
.if defined(WITH_PYTHON)
USE_PYTHON= yes
.endif
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_DBUS)
@ -86,7 +91,6 @@ PLIST_SUB+= PERL=""
.endif
.if defined(WITH_PYTHON)
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
@ -118,10 +122,6 @@ CONFIGURE_ARGS+=--enable-socks
post-patch:
@${REINPLACE_CMD} -E -e 's|PY_LIBS=.*|PY_LIBS="-L\$$PY_EXEC_PREFIX/lib/python\$$PY_VER/config -lpython\$$PY_VER ${PTHREAD_LIBS} -lutil"|' \
${WRKSRC}/configure
.for file in dccgui.c fe-gtk.c maingui.c menu.c plugin-tray.c sexy-spell-entry.c xtext.c xtext.h
@${REINPLACE_CMD} -e 's|#define GTK_DISABLE_DEPRECATED||g' \
${WRKSRC}/src/fe-gtk/${file}
.endfor
# Create plugins directory even when no plugins are installed
post-install:

View File

@ -1,3 +1,3 @@
MD5 (xchat-2.8.6.tar.bz2) = 1f2670865d43a23a9abc596dde999aca
SHA256 (xchat-2.8.6.tar.bz2) = 8c89dbf36304b99363a7f090d695447653102b4528ca2aa367a2abe5cff1746d
SIZE (xchat-2.8.6.tar.bz2) = 1423645
MD5 (xchat-2.8.8.tar.bz2) = 6775c44f38e84d06c06c336b32c4a452
SHA256 (xchat-2.8.8.tar.bz2) = 0d6d69437b5e1e45f3e66270fe369344943de8a1190e498fafa5296315a27db0
SIZE (xchat-2.8.8.tar.bz2) = 1509993

View File

@ -1,10 +0,0 @@
--- src/fe-gtk/xtext.h.orig 2008-08-06 09:47:05.000000000 +0200
+++ src/fe-gtk/xtext.h 2008-08-06 09:51:01.000000000 +0200
@@ -270,6 +270,6 @@ void gtk_xtext_set_wordwrap (GtkXText *x
xtext_buffer *gtk_xtext_buffer_new (GtkXText *xtext);
void gtk_xtext_buffer_free (xtext_buffer *buf);
void gtk_xtext_buffer_show (GtkXText *xtext, xtext_buffer *buf, int render);
-GtkType gtk_xtext_get_type (void);
+GType gtk_xtext_get_type (void);
#endif

View File

@ -1,68 +0,0 @@
#
# Various small fixes from CVS that are considered safe to apply to 2.8.6.
#
--- xchat-2.8.6/src/common/cfgfiles.c 2008-02-05 21:02:47.000000000 +1100
+++ src/common/cfgfiles.c 2008-06-15 13:45:43.000000000 +1000
@@ -886,7 +886,6 @@
set_showval (session *sess, const struct prefs *var, char *tbuf)
{
int len, dots, j;
- static const char *offon[] = { "OFF", "ON" };
len = strlen (var->name);
memcpy (tbuf, var->name, len);
@@ -909,8 +908,10 @@
*((int *) &prefs + var->offset));
break;
case TYPE_BOOL:
- sprintf (tbuf + len, "\0033:\017 %s\n", offon[
- *((int *) &prefs + var->offset)]);
+ if (*((int *) &prefs + var->offset))
+ sprintf (tbuf + len, "\0033:\017 %s\n", "ON");
+ else
+ sprintf (tbuf + len, "\0033:\017 %s\n", "OFF");
break;
}
PrintText (sess, tbuf);
--- xchat-2.8.6/src/common/chanopt.c 2008-06-10 22:00:55.000000000 +1000
+++ src/common/chanopt.c 2008-06-15 13:48:04.000000000 +1000
@@ -32,7 +32,7 @@
#define S_F(xx) STRUCT_OFFSET_STR(struct session,xx)
-channel_options chanopt[] =
+static const channel_options chanopt[] =
{
{"alert_beep", "BEEP", S_F(alert_beep)},
{"alert_taskbar", NULL, S_F(alert_taskbar)},
--- xchat-2.8.6/src/common/servlist.c 2008-04-01 19:22:34.000000000 +1100
+++ src/common/servlist.c 2008-06-15 13:57:41.000000000 +1000
@@ -509,6 +509,8 @@
list = g_slist_nth (net->servlist, net->selected);
if (!list)
list = net->servlist;
+ if (!list)
+ return;
ircserv = list->data;
/* incase a protocol switch is added to the servlist gui */
--- xchat-2.8.6/src/common/text.c 2008-03-28 13:20:04.000000000 +1100
+++ src/common/text.c 2008-06-15 13:59:59.000000000 +1000
@@ -216,7 +216,7 @@
static void
scrollback_save (session *sess, char *text)
{
- char buf[1024];
+ char buf[512 * 4];
time_t stamp;
int len;
@@ -266,7 +266,7 @@
scrollback_load (session *sess)
{
int fh;
- char buf[1024];
+ char buf[512 * 4];
char *text;
time_t stamp;
int lines;

View File

@ -19,11 +19,13 @@ share/locale/gl/LC_MESSAGES/xchat.mo
share/locale/hu/LC_MESSAGES/xchat.mo
share/locale/it/LC_MESSAGES/xchat.mo
share/locale/ja/LC_MESSAGES/xchat.mo
share/locale/kn/LC_MESSAGES/xchat.mo
share/locale/ko/LC_MESSAGES/xchat.mo
share/locale/lt/LC_MESSAGES/xchat.mo
share/locale/mk/LC_MESSAGES/xchat.mo
share/locale/nl/LC_MESSAGES/xchat.mo
share/locale/pa/LC_MESSAGES/xchat.mo
share/locale/pl/LC_MESSAGES/xchat.mo
share/locale/pt/LC_MESSAGES/xchat.mo
share/locale/ru/LC_MESSAGES/xchat.mo
share/locale/sq/LC_MESSAGES/xchat.mo