- Support X11BASE properly

- Remove USE_GMAKE

PR: 20547
Submitted by: Ports Fury
This commit is contained in:
Kevin Lo 2000-08-12 08:23:35 +00:00
parent c882dd7d13
commit 1623b2c8a2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31564
2 changed files with 36 additions and 12 deletions

View File

@ -14,15 +14,10 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME}/wmMand
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
ALL_TARGET= clean all
MAN1= wmMand.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmMand ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/wmMand.1 ${PREFIX}/man/man1/
.include <bsd.port.mk>

View File

@ -1,13 +1,42 @@
--- Makefile.orig Fri Apr 16 14:55:02 1999
+++ Makefile Fri Apr 16 14:55:26 1999
@@ -1,6 +1,7 @@
--- Makefile.orig Tue Feb 16 01:43:51 1999
+++ Makefile Fri Aug 11 02:34:35 2000
@@ -1,8 +1,8 @@
-CC = gcc
-CFLAGS = -O2 -Wall
-INCDIR = -I/usr/X11R6/include/X11
-DESTDIR= /usr/X11R6
-LIBDIR = -L/usr/X11R6/lib
+CC ?= gcc
+CFLAGS ?= -O2
+CFLAGS += -Wall
+INCDIR = -I/usr/X11R6/include
DESTDIR= /usr/X11R6
LIBDIR = -L/usr/X11R6/lib
+INCDIR = -I${X11BASE}/include
+DESTDIR= ${PREFIX}
+LIBDIR = -L${X11BASE}/lib
# for linux
LIBS = -lXpm -lX11 -lXext
# for Solaris
@@ -12,14 +12,14 @@
.c.o:
- $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+ $(CC) $(CFLAGS) -D$(OPSYS) -c $< -o $@ $(INCDIR)
all: wmMand.o wmMand
wmMand.o: wmMand_master.xpm wmMand_mask.xbm
wmMand: $(OBJS)
- $(CC) $(CFLAGS) $(SYSTEM) -o wmMand $^ $(INCDIR) $(LIBDIR) $(LIBS)
+ $(CC) $(CFLAGS) $(SYSTEM) -o wmMand $(OBJS) $(LIBDIR) $(LIBS)
clean:
for i in $(OBJS) ; do \
@@ -28,6 +28,6 @@
rm -f wmMand
install:: wmMand
- install -s -m 0755 wmMand $(DESTDIR)/bin
- install -m 0644 wmMand.1 $(DESTDIR)/man/man1
+ ${BSD_INSTALL_PROGRAM} wmMand $(DESTDIR)/bin
+ ${BSD_INSTALL_MAN} wmMand.1 $(DESTDIR)/man/man1