- Fix build with gcc 4.2

- Use SF macro

PR:		117865
Submitted by:	Philippe Audeoud <jadawin@tuxaco.net>
Approved by:	portmgr (erwin)
This commit is contained in:
Martin Wilke 2007-11-11 14:44:05 +00:00
parent 4ded024af7
commit 15e25baec9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202621
2 changed files with 13 additions and 9 deletions

View File

@ -9,8 +9,7 @@ PORTNAME= hammerhead
PORTVERSION= 2.1.3
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A webserver stressing tool
@ -18,16 +17,10 @@ COMMENT= A webserver stressing tool
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Broken with gcc 4.2
.endif
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/src/Makefile
MAN1= hammerhead.1
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- src/connection.h.orig 2007-11-08 07:30:05.000000000 +0000
+++ src/connection.h 2007-11-08 07:30:21.000000000 +0000
@@ -25,7 +25,7 @@
String *name;
Session *sess;
- int Connection::fdConnect(void);
+ int fdConnect(void);
public:
virtual int connect(void) = 0;