Update PyGreSQL to 3.4. Previous version was packed with the
postgresql dist, and while postgresql was version 7.3.5, PyGreSQL's own version just bumped from 3.3 to 3.4. Hence portepoch. PR: ports/61597 Submitted by: Palle Girgensohn <girgen@pingpong.net> (maintainer)
This commit is contained in:
parent
391b3f9f3b
commit
15c98e8f3b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99464
@ -6,34 +6,33 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= PyGreSQL
|
PORTNAME= PyGreSQL
|
||||||
PORTREVISION= 0
|
PORTVERSION= 3.4
|
||||||
|
PORTEPOCH= 1
|
||||||
CATEGORIES= databases python
|
CATEGORIES= databases python
|
||||||
|
MASTER_SITES= ftp://ftp.pygresql.org/pub/distrib/
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
EXTRACT_SUFX= .tgz
|
||||||
|
|
||||||
MAINTAINER= girgen@pingpong.net
|
MAINTAINER= girgen@pingpong.net
|
||||||
COMMENT= A Python interface to PostgreSQL, including a DP-API 2.0 wrapper
|
COMMENT= A Python interface to PostgreSQL, both classic interface and DP-API 2.0
|
||||||
|
|
||||||
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
|
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
|
||||||
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
|
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
|
||||||
LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
|
LIB_DEPENDS= pq:${PORTSDIR}/${POSTGRESQL_PORT}
|
||||||
|
|
||||||
POSTGRESQL_PORT?= databases/postgresql7
|
POSTGRESQL_PORT?= databases/postgresql7
|
||||||
POSTGRESQL_SUBPORT=YES
|
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
|
|
||||||
|
|
||||||
# The PyGreSQL distfile is nowhere to be found, but exists in
|
|
||||||
# postgresql-7.3 distribution so do not be alarmed if you use
|
|
||||||
# a newer version of postgresql
|
|
||||||
.include <${.CURDIR}/../postgresql73/Makefile>
|
|
||||||
|
|
||||||
USE_PYTHON= yes
|
USE_PYTHON= yes
|
||||||
CONFIGURE_ARGS= --with-python --prefix=${PREFIX}
|
|
||||||
MAKE_ARGS+= -C src/interfaces/python
|
|
||||||
CFLAGS+= -L${LOCALBASE}/lib
|
|
||||||
MAKEFILE= GNUmakefile
|
|
||||||
|
|
||||||
DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
|
DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
|
||||||
|
USE_REINPLACE=yes
|
||||||
|
|
||||||
|
pre-build:
|
||||||
|
@ cd ${WRKSRC} ; ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' setup.py
|
||||||
|
|
||||||
|
do-build:
|
||||||
|
@ cd ${WRKSRC} ; ${PYTHON_CMD} setup.py build
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
@ cd ${WRKSRC} ; ${PYTHON_CMD} setup.py install
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -lf \
|
@ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -lf \
|
||||||
@ -41,9 +40,9 @@ post-install:
|
|||||||
@ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -lf \
|
@ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -lf \
|
||||||
${PYTHONPREFIX_SITELIBDIR}
|
${PYTHONPREFIX_SITELIBDIR}
|
||||||
.if !defined(NOPORTDOCS)
|
.if !defined(NOPORTDOCS)
|
||||||
.for docfile in Announce ChangeLog README
|
.for docfile in Announce ChangeLog
|
||||||
@ ${MKDIR} ${DOCSDIR}
|
@ ${MKDIR} ${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/src/interfaces/python/${docfile} \
|
${INSTALL_DATA} ${WRKSRC}/${docfile} \
|
||||||
${DOCSDIR}
|
${DOCSDIR}
|
||||||
.endfor
|
.endfor
|
||||||
.endif
|
.endif
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- configure.orig Tue Oct 1 05:34:27 2002
|
|
||||||
+++ configure Wed Oct 23 15:50:31 2002
|
|
||||||
@@ -3239,7 +3239,7 @@
|
|
||||||
echo $ac_n "checking Python installation directories""... $ac_c" 1>&6
|
|
||||||
echo "configure:3241: checking Python installation directories" >&5
|
|
||||||
python_version=`${PYTHON} -c "import sys; print sys.version[:3]"`
|
|
||||||
-python_prefix=`${PYTHON} -c "import sys; print sys.prefix"`
|
|
||||||
+python_prefix="${prefix}"
|
|
||||||
python_execprefix=`${PYTHON} -c "import sys; print sys.exec_prefix"`
|
|
||||||
python_configdir="${python_execprefix}/lib/python${python_version}/config"
|
|
||||||
python_moduledir="${python_prefix}/lib/python${python_version}/site-packages"
|
|
13
databases/py-PyGreSQL/files/patch-setup.py
Normal file
13
databases/py-PyGreSQL/files/patch-setup.py
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- setup.py~ Tue Jan 13 13:29:57 2004
|
||||||
|
+++ setup.py Tue Jan 13 16:14:50 2004
|
||||||
|
@@ -30,8 +30,8 @@
|
||||||
|
optional_libs=[ 'libpqdll', 'wsock32', 'advapi32' ]
|
||||||
|
data_files = [ 'libpq.dll' ]
|
||||||
|
else:
|
||||||
|
- include_dirs=['/usr/include/pgsql']
|
||||||
|
- library_dirs=['/usr/lib/pgsql']
|
||||||
|
+ include_dirs=['%%LOCALBASE%%/include', '%%LOCALBASE%%/include/postgresql', '%%LOCALBASE%%/include/postgresql/server']
|
||||||
|
+ library_dirs=['%%LOCALBASE%%/lib']
|
||||||
|
optional_libs=['pq']
|
||||||
|
data_files = []
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
--- src/interfaces/python/GNUmakefile.orig Thu Dec 13 20:39:04 2001
|
|
||||||
+++ src/interfaces/python/GNUmakefile Wed Oct 23 15:52:18 2002
|
|
||||||
@@ -34,9 +34,9 @@
|
|
||||||
echo "*** become the appropriate user, and do '$(MAKE) install'."; }
|
|
||||||
|
|
||||||
install: all installdirs
|
|
||||||
- @if test -w $(DESTDIR)$(python_moduleexecdir) && test -w $(DESTDIR)$(python_moduledir); then \
|
|
||||||
- echo "$(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduleexecdir)/_pgmodule$(DLSUFFIX)"; \
|
|
||||||
- $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduleexecdir)/_pgmodule$(DLSUFFIX); \
|
|
||||||
+ @if test -w $(DESTDIR)$(python_moduledir); then \
|
|
||||||
+ echo "$(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduledir)/_pgmodule$(DLSUFFIX)"; \
|
|
||||||
+ $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(python_moduledir)/_pgmodule$(DLSUFFIX); \
|
|
||||||
\
|
|
||||||
echo "$(INSTALL_DATA) $(srcdir)/pg.py $(DESTDIR)$(python_moduledir)/pg.py"; \
|
|
||||||
$(INSTALL_DATA) $(srcdir)/pg.py $(DESTDIR)$(python_moduledir)/pg.py; \
|
|
||||||
@@ -48,10 +48,10 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
installdirs:
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(python_moduleexecdir) $(DESTDIR)$(python_moduledir)
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)$(python_moduledir)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
- rm -f $(DESTDIR)$(python_moduleexecdir)/_pgmodule$(DLSUFFIX) \
|
|
||||||
+ rm -f $(DESTDIR)$(python_moduledir)/_pgmodule$(DLSUFFIX) \
|
|
||||||
$(DESTDIR)$(python_moduledir)/pg.py \
|
|
||||||
$(DESTDIR)$(python_moduledir)/pgdb.py
|
|
||||||
|
|
@ -1,7 +1,6 @@
|
|||||||
%%PORTDOCS%%%%DOCSDIR%%/Announce
|
%%PORTDOCS%%%%DOCSDIR%%/Announce
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
%%PYTHON_SITELIBDIR%%/_pg.so
|
||||||
%%PYTHON_SITELIBDIR%%/_pgmodule.so
|
|
||||||
%%PYTHON_SITELIBDIR%%/pg.py
|
%%PYTHON_SITELIBDIR%%/pg.py
|
||||||
%%PYTHON_SITELIBDIR%%/pg.pyc
|
%%PYTHON_SITELIBDIR%%/pg.pyc
|
||||||
%%PYTHON_SITELIBDIR%%/pg.pyo
|
%%PYTHON_SITELIBDIR%%/pg.pyo
|
||||||
|
Loading…
Reference in New Issue
Block a user