net-im/profanity: Use upstream release archive and some other fixes
- Use upstream release archive as recommended in USE_GITHUB section in Porters Handbook - Remove OpenSSL dependency - Add USE_LDCONFIG - Rearrange Makefile to follow Porters Handbook more closely - Fix Python detection (patch provided by maintainer) PR: 266430 Reviewed by: ashish (maintainer)
This commit is contained in:
parent
ac2b2aa872
commit
15b2c42e96
@ -1,6 +1,7 @@
|
||||
PORTNAME= profanity
|
||||
PORTVERSION= 0.13.0
|
||||
DISTVERSION= 0.13.0
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= https://github.com/${PORTNAME}-im/${PORTNAME}/releases/download/${DISTVERSION}/
|
||||
|
||||
MAINTAINER= ashish@FreeBSD.org
|
||||
COMMENT= Console based XMPP client
|
||||
@ -21,27 +22,25 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libstrophe.so:net-im/libstrophe \
|
||||
libqrencode.so:graphics/libqrencode
|
||||
|
||||
USES= cpe ncurses pkgconfig ssl python:3.8+ readline autoreconf libtool gnome \
|
||||
sqlite:3
|
||||
USES= autoreconf cpe gnome libtool ncurses pkgconfig python:3.8+ \
|
||||
readline sqlite:3 tar:xz
|
||||
CPE_VENDOR= ${PORTNAME}_project
|
||||
USE_GNOME= glib20
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= profanity-im
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= glib20
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CONFIGURE_ARGS= --enable-otr --enable-python-plugins --enable-c-plugins \
|
||||
--enable-pgp --disable-icons-and-clipboard \
|
||||
--without-xscreensaver --disable-gdk-pixbuf \
|
||||
--enable-omemo --enable-omemo-qrcode
|
||||
CONFIGURE_ENV= LIBS="${CFLAGS} -lcrypto"
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
OPTIONS_DEFINE= NOTIFY
|
||||
|
||||
NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
|
||||
NOTIFY_CONFIGURE_ENABLE=notifications
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} "s,python3-embed,python-${PYTHON_VER}-embed,g" \
|
||||
${WRKSRC}/configure.ac
|
||||
@ -49,4 +48,4 @@ post-patch:
|
||||
post-install:
|
||||
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/man/man1 "-name *\.1"
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1663179502
|
||||
SHA256 (profanity-im-profanity-0.13.0_GH0.tar.gz) = ee38119ed3bd3995675d7da787f52c7576403be678bc9a8f5170812597547d7b
|
||||
SIZE (profanity-im-profanity-0.13.0_GH0.tar.gz) = 566611
|
||||
TIMESTAMP = 1663273219
|
||||
SHA256 (profanity-0.13.0.tar.xz) = dbf43e02a8ef2a0ffc48a02c635f14f0c247ac7fd1683d009b9c1f91c250a559
|
||||
SIZE (profanity-0.13.0.tar.xz) = 621344
|
||||
|
@ -1,14 +1,5 @@
|
||||
--- configure.ac.orig 2022-09-13 09:50:49 UTC
|
||||
+++ configure.ac
|
||||
@@ -104,7 +104,7 @@ elif test "x$enable_python_plugins" != xno; then
|
||||
rm -f Python.framework
|
||||
ln -s $PYTHON_FRAMEWORK Python.framework ])
|
||||
PKG_CHECK_MODULES([python], [python-embed], [PYTHON_CONFIG_EXISTS=yes], [PYTHON_CONFIG_EXISTS=no])
|
||||
- PKG_CHECK_MODULES([python], [python3-embed], [PYTHON3_CONFIG_EXISTS=yes; AC_DEFINE(PY_IS_PYTHON3, [1], [Is Python version 3])], [PYTHON3_CONFIG_EXISTS=no])
|
||||
+ PKG_CHECK_MODULES([python], [python-3.9-embed], [PYTHON3_CONFIG_EXISTS=yes; AC_DEFINE(PY_IS_PYTHON3, [1], [Is Python version 3])], [PYTHON3_CONFIG_EXISTS=no])
|
||||
if test "$PYTHON_CONFIG_EXISTS" = "yes" || test "$PYTHON3_CONFIG_EXISTS" = "yes"; then
|
||||
AM_CONDITIONAL([BUILD_PYTHON_API], [true])
|
||||
AC_DEFINE([HAVE_PYTHON], [1], [Python support])
|
||||
@@ -272,11 +272,11 @@ AS_IF([test "x$PLATFORM" = xosx],
|
||||
[AC_MSG_NOTICE([libnotify support will be disabled])])])])])
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user