Add sdcc, Small Device C Compiler, a Freeware, retargettable, optimizing
ANSI-C compiler that targets the Intel 8051, Maxim 80DS390 and the Zilog Z80 based MCUs. PR: ports/66262 Submitted by: Tijl Coosemans <tijl@ulyssis.org>
This commit is contained in:
parent
28555d54ec
commit
158d385fd1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108778
@ -237,6 +237,7 @@
|
||||
SUBDIR += screamer
|
||||
SUBDIR += scriba
|
||||
SUBDIR += scsh
|
||||
SUBDIR += sdcc
|
||||
SUBDIR += siod
|
||||
SUBDIR += sisc
|
||||
SUBDIR += slib
|
||||
|
113
lang/sdcc-devel/Makefile
Normal file
113
lang/sdcc-devel/Makefile
Normal file
@ -0,0 +1,113 @@
|
||||
# New ports collection makefile for: sdcc
|
||||
# Date created: 3 May 2004
|
||||
# Whom: Tijl Coosemans <tijl@ulyssis.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdcc
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= sdcc
|
||||
|
||||
MAINTAINER= tijl@ulyssis.org
|
||||
COMMENT= Small Device C Compiler
|
||||
|
||||
WRKSRC= ${WRKDIR}/sdcc
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
|
||||
OPTIONS= MCS51 "Intel mcs51 port" on \
|
||||
GBZ80 "Gameboy gbz80 port" on \
|
||||
Z80 "Z80 port" on \
|
||||
AVR "AVR port" on \
|
||||
DS390 "DS390 port" on \
|
||||
DS400 "DS400 port" on \
|
||||
PIC "PIC port" on \
|
||||
PIC16 "PIC16 port" on \
|
||||
XA51 "XA51 port" on \
|
||||
HC08 "HC08 port" on \
|
||||
UCSIM "The ucSim simulator" on \
|
||||
PACKIHX "A tool to pack (compress) Intel hex files" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_MCS51)
|
||||
CONFIGURE_ARGS+= --disable-mcs51-port
|
||||
PLIST_SUB+= MCS51="@comment "
|
||||
.else
|
||||
PLIST_SUB+= MCS51=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GBZ80)
|
||||
CONFIGURE_ARGS+= --disable-gbz80-port
|
||||
PLIST_SUB+= GBZ80="@comment "
|
||||
.else
|
||||
PLIST_SUB+= GBZ80=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_Z80)
|
||||
CONFIGURE_ARGS+= --disable-z80-port
|
||||
PLIST_SUB+= Z80="@comment "
|
||||
.else
|
||||
PLIST_SUB+= Z80=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_AVR)
|
||||
CONFIGURE_ARGS+= --disable-avr-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_DS390)
|
||||
CONFIGURE_ARGS+= --disable-ds390-port
|
||||
PLIST_SUB+= DS390="@comment "
|
||||
.else
|
||||
PLIST_SUB+= DS390=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_DS400)
|
||||
CONFIGURE_ARGS+= --disable-ds400-port
|
||||
PLIST_SUB+= DS400="@comment "
|
||||
.else
|
||||
PLIST_SUB+= DS400=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PIC)
|
||||
CONFIGURE_ARGS+= --disable-pic-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PIC16)
|
||||
CONFIGURE_ARGS+= --disable-pic16-port
|
||||
PLIST_SUB+= PIC16="@comment "
|
||||
.else
|
||||
PLIST_SUB+= PIC16=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_XA51)
|
||||
CONFIGURE_ARGS+= --disable-xa51-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_HC08)
|
||||
CONFIGURE_ARGS+= --disable-hc08-port
|
||||
PLIST_SUB+= HC08="@comment "
|
||||
.else
|
||||
PLIST_SUB+= HC08=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_UCSIM)
|
||||
CONFIGURE_ARGS+= --disable-ucsim
|
||||
PLIST_SUB+= UCSIM="@comment "
|
||||
.else
|
||||
PLIST_SUB+= UCSIM=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PACKIHX)
|
||||
CONFIGURE_ARGS+= --disable-packihx
|
||||
PLIST_SUB+= PACKIHX="@comment "
|
||||
.else
|
||||
PLIST_SUB+= PACKIHX=""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
lang/sdcc-devel/distinfo
Normal file
2
lang/sdcc-devel/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (sdcc-2.4.0.tar.gz) = ef959381f292d8857d8679f92a71582d
|
||||
SIZE (sdcc-2.4.0.tar.gz) = 3021296
|
11
lang/sdcc-devel/files/patch-device-lib-Makefile.in
Normal file
11
lang/sdcc-devel/files/patch-device-lib-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- device/lib/Makefile.in.orig Tue May 4 16:55:47 2004
|
||||
+++ device/lib/Makefile.in Tue May 4 16:56:55 2004
|
||||
@@ -240,7 +240,7 @@
|
||||
# Compiling and installing everything and runing test
|
||||
# ---------------------------------------------------
|
||||
install: all installdirs
|
||||
- cp -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
+ -cp -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
cp -r ds390 ds400 gbz80 z80 hc08 *.c $(sdcc_libdir)/src
|
||||
rm -r `find $(sdcc_libdir)/src -name '*.rel' -or -name '*.dump*' -or -name '*.sym' -or -name '*.o' -or -name '*.lst' -or -name '*.asm' -or -name 'CVS'`
|
||||
|
10
lang/sdcc-devel/pkg-descr
Normal file
10
lang/sdcc-devel/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
SDCC is a Freeware, retargettable, optimizing ANSI-C compiler that
|
||||
targets the Intel 8051, Maxim 80DS390 and the Zilog Z80 based MCUs.
|
||||
|
||||
SDCC also comes with the source level debugger SDCDB, using the
|
||||
current version of Daniel's s51 simulator.
|
||||
|
||||
WWW: http://sdcc.sourceforge.net/
|
||||
|
||||
- Tijl Coosemans
|
||||
tijl@ulyssis.org
|
1682
lang/sdcc-devel/pkg-plist
Normal file
1682
lang/sdcc-devel/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
113
lang/sdcc/Makefile
Normal file
113
lang/sdcc/Makefile
Normal file
@ -0,0 +1,113 @@
|
||||
# New ports collection makefile for: sdcc
|
||||
# Date created: 3 May 2004
|
||||
# Whom: Tijl Coosemans <tijl@ulyssis.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= sdcc
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= sdcc
|
||||
|
||||
MAINTAINER= tijl@ulyssis.org
|
||||
COMMENT= Small Device C Compiler
|
||||
|
||||
WRKSRC= ${WRKDIR}/sdcc
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
|
||||
OPTIONS= MCS51 "Intel mcs51 port" on \
|
||||
GBZ80 "Gameboy gbz80 port" on \
|
||||
Z80 "Z80 port" on \
|
||||
AVR "AVR port" on \
|
||||
DS390 "DS390 port" on \
|
||||
DS400 "DS400 port" on \
|
||||
PIC "PIC port" on \
|
||||
PIC16 "PIC16 port" on \
|
||||
XA51 "XA51 port" on \
|
||||
HC08 "HC08 port" on \
|
||||
UCSIM "The ucSim simulator" on \
|
||||
PACKIHX "A tool to pack (compress) Intel hex files" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_MCS51)
|
||||
CONFIGURE_ARGS+= --disable-mcs51-port
|
||||
PLIST_SUB+= MCS51="@comment "
|
||||
.else
|
||||
PLIST_SUB+= MCS51=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GBZ80)
|
||||
CONFIGURE_ARGS+= --disable-gbz80-port
|
||||
PLIST_SUB+= GBZ80="@comment "
|
||||
.else
|
||||
PLIST_SUB+= GBZ80=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_Z80)
|
||||
CONFIGURE_ARGS+= --disable-z80-port
|
||||
PLIST_SUB+= Z80="@comment "
|
||||
.else
|
||||
PLIST_SUB+= Z80=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_AVR)
|
||||
CONFIGURE_ARGS+= --disable-avr-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_DS390)
|
||||
CONFIGURE_ARGS+= --disable-ds390-port
|
||||
PLIST_SUB+= DS390="@comment "
|
||||
.else
|
||||
PLIST_SUB+= DS390=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_DS400)
|
||||
CONFIGURE_ARGS+= --disable-ds400-port
|
||||
PLIST_SUB+= DS400="@comment "
|
||||
.else
|
||||
PLIST_SUB+= DS400=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PIC)
|
||||
CONFIGURE_ARGS+= --disable-pic-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PIC16)
|
||||
CONFIGURE_ARGS+= --disable-pic16-port
|
||||
PLIST_SUB+= PIC16="@comment "
|
||||
.else
|
||||
PLIST_SUB+= PIC16=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_XA51)
|
||||
CONFIGURE_ARGS+= --disable-xa51-port
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_HC08)
|
||||
CONFIGURE_ARGS+= --disable-hc08-port
|
||||
PLIST_SUB+= HC08="@comment "
|
||||
.else
|
||||
PLIST_SUB+= HC08=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_UCSIM)
|
||||
CONFIGURE_ARGS+= --disable-ucsim
|
||||
PLIST_SUB+= UCSIM="@comment "
|
||||
.else
|
||||
PLIST_SUB+= UCSIM=""
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_PACKIHX)
|
||||
CONFIGURE_ARGS+= --disable-packihx
|
||||
PLIST_SUB+= PACKIHX="@comment "
|
||||
.else
|
||||
PLIST_SUB+= PACKIHX=""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
lang/sdcc/distinfo
Normal file
2
lang/sdcc/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (sdcc-2.4.0.tar.gz) = ef959381f292d8857d8679f92a71582d
|
||||
SIZE (sdcc-2.4.0.tar.gz) = 3021296
|
11
lang/sdcc/files/patch-device-lib-Makefile.in
Normal file
11
lang/sdcc/files/patch-device-lib-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- device/lib/Makefile.in.orig Tue May 4 16:55:47 2004
|
||||
+++ device/lib/Makefile.in Tue May 4 16:56:55 2004
|
||||
@@ -240,7 +240,7 @@
|
||||
# Compiling and installing everything and runing test
|
||||
# ---------------------------------------------------
|
||||
install: all installdirs
|
||||
- cp -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
+ -cp -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
cp -r ds390 ds400 gbz80 z80 hc08 *.c $(sdcc_libdir)/src
|
||||
rm -r `find $(sdcc_libdir)/src -name '*.rel' -or -name '*.dump*' -or -name '*.sym' -or -name '*.o' -or -name '*.lst' -or -name '*.asm' -or -name 'CVS'`
|
||||
|
10
lang/sdcc/pkg-descr
Normal file
10
lang/sdcc/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
SDCC is a Freeware, retargettable, optimizing ANSI-C compiler that
|
||||
targets the Intel 8051, Maxim 80DS390 and the Zilog Z80 based MCUs.
|
||||
|
||||
SDCC also comes with the source level debugger SDCDB, using the
|
||||
current version of Daniel's s51 simulator.
|
||||
|
||||
WWW: http://sdcc.sourceforge.net/
|
||||
|
||||
- Tijl Coosemans
|
||||
tijl@ulyssis.org
|
1682
lang/sdcc/pkg-plist
Normal file
1682
lang/sdcc/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user