math/py-heyoka: Update 0.19.0 -> 0.20.0

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2022-12-21 01:04:54 -08:00
parent a1fdb33ba4
commit 157b2563d1
4 changed files with 19 additions and 16 deletions

View File

@ -1,7 +1,6 @@
PORTNAME= heyoka
DISTVERSIONPREFIX= v
DISTVERSION= 0.19.0
PORTREVISION= 4
DISTVERSION= 0.20.0
CATEGORIES= math
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -16,8 +15,10 @@ BUILD_DEPENDS= pybind11>0:devel/pybind11 \
${PYNUMPY}
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libfmt.so:devel/libfmt \
libgmp.so:math/gmp \
libheyoka.so:math/heyoka \
libmp++.so:math/mppp \
libmpfr.so:math/mpfr \
libtbb.so:devel/onetbb \
libspdlog.so:devel/spdlog
RUN_DEPENDS= ${PYNUMPY} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1663734102
SHA256 (bluescarni-heyoka.py-v0.19.0_GH0.tar.gz) = 5191a6976fe89f14c6cde0d69607397db059009fecb0a3390c4b33c29e5d31ea
SIZE (bluescarni-heyoka.py-v0.19.0_GH0.tar.gz) = 101947693
TIMESTAMP = 1671607325
SHA256 (bluescarni-heyoka.py-v0.20.0_GH0.tar.gz) = 65c90a5ffb870b4d2d19eef066b56964777f03eb7d081e331ae5bf903bbf94af
SIZE (bluescarni-heyoka.py-v0.20.0_GH0.tar.gz) = 102109366

View File

@ -1,16 +1,15 @@
--- CMakeLists.txt.orig 2022-09-19 07:53:52 UTC
--- CMakeLists.txt.orig 2022-12-18 12:54:30 UTC
+++ CMakeLists.txt
@@ -144,7 +144,7 @@ else()
# and Python3 is *not* found, we try again, this time with the full Development
# component (rather than only Development.Module). This seems to work around the
# issue, for now at least.
- find_package(Python3 QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
+ find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
@@ -140,14 +140,14 @@ set(_HEYOKA_PY_PYTHON3_COMPONENTS Interpreter NumPy De
# and Python3 is *not* found, we try again, this time with the full Development
# component (rather than only Development.Module). This seems to work around the
# issue, for now at least.
-find_package(Python3 QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
+find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} QUIET COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})
if(NOT Python3_FOUND)
list(POP_BACK _HEYOKA_PY_PYTHON3_COMPONENTS)
@@ -152,7 +152,7 @@ else()
endif()
if(NOT Python3_FOUND)
list(POP_BACK _HEYOKA_PY_PYTHON3_COMPONENTS)
list(APPEND _HEYOKA_PY_PYTHON3_COMPONENTS Development)
endif()
-find_package(Python3 QUIET REQUIRED COMPONENTS ${_HEYOKA_PY_PYTHON3_COMPONENTS})

View File

@ -1,6 +1,9 @@
%%PYTHON_SITELIBDIR%%/heyoka/__init__.py
%%PYTHON_SITELIBDIR%%/heyoka/_ensemble_impl.py
%%PYTHON_SITELIBDIR%%/heyoka/_sympy_utils.py
%%PYTHON_SITELIBDIR%%/heyoka/_test_mp.py
%%PYTHON_SITELIBDIR%%/heyoka/_test_real.py
%%PYTHON_SITELIBDIR%%/heyoka/_test_real128.py
%%PYTHON_SITELIBDIR%%/heyoka/_version.py
%%PYTHON_SITELIBDIR%%/heyoka/core%%PYTHON_EXT_SUFFIX%%.so
%%PYTHON_SITELIBDIR%%/heyoka/test.py