Fix the build on bento and a few other users' machines.

* Add USE_GMAKE
* Patch a problem with generating the glib-marshal code

Approved by:	portmgr (kris)
This commit is contained in:
Joe Marcus Clarke 2003-03-15 18:21:04 +00:00
parent 1d6100e342
commit 153aa7492e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77133
2 changed files with 17 additions and 0 deletions

View File

@ -20,6 +20,7 @@ LIB_DEPENDS= gpgme.9:${PORTSDIR}/security/gpgme \
glade-2.0.0:${PORTSDIR}/devel/libglade2
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomehack gnomeprefix
GNU_CONFIGURE= yes

View File

@ -0,0 +1,16 @@
--- src/Makefile.in.orig Sat Mar 15 13:18:02 2003
+++ src/Makefile.in Sat Mar 15 13:18:35 2003
@@ -586,11 +586,11 @@
seahorse-marshal.h: seahorse-marshal.list $(GLIB_GENMARSHAL)
- $(GLIB_GENMARSHAL) $< --header --prefix=seahorse-marshal > $@
+ $(GLIB_GENMARSHAL) $< --header --prefix=seahorse_marshal > $@
seahorse-marshal.c: seahorse-marshal.list $(GLIB_GENMARSHAL)
echo "#include \"seahorse-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) $< --body --prefix=seahorse-marshal >> $@
+ $(GLIB_GENMARSHAL) $< --body --prefix=seahorse_marshal >> $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: