devel/py-gitosis: Update to 0.3 and limit to Python 2.7

Python 3 handles octal numbers in a different way as with Python 2.7. The
latter one uses leading zeroes (e.g. 0755) to signify that a number is an
octal number but this is invalid for Python 3 where the required syntax is
0o755 for that case.

Also there are some references to the "cStringIO" module that is gone in
Python 3. Thus limit this port to Python 2.7 only.

While I'm here:

* Add location to license file
* Update URL in pkg-message
* Add test target with the required dependencies
* Pet portlint

Changelog:

https://github.com/tv42/gitosis/releases/tag/release%2F0.3

PR:		235441 [1], 235894 [2]
Submitted by:	Keith Gaughan <k@stereochro.me> [2]
Reported by:	Dan McGrath <danmcgrath.ca@gmail.com> [1]
Approved by:	miwi (mentor), maintainer timeout (> ~25 days) [1], maintainer [2]
Differential Revision:	https://reviews.freebsd.org/D19379
This commit is contained in:
Kai Knoblich 2019-02-28 15:36:27 +00:00
parent 05d2098f53
commit 14ff569c13
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=494156
4 changed files with 28 additions and 10 deletions

View File

@ -2,26 +2,32 @@
# $FreeBSD$
PORTNAME= gitosis
PORTVERSION= 0.2.20090917
PORTREVISION= 1
PORTVERSION= 0.3
DISTVERSIONPREFIX= release/
CATEGORIES= devel python
MASTER_SITES= http://dl1.douglasthrift.net/${PORTNAME}/ \
http://dl2.douglasthrift.net/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Software for hosting git repositories
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= git:devel/git
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
USES= python tar:bzip2
USES= python:2.7
USE_PYTHON= distutils autoplist
USE_GITHUB= yes
GH_ACCOUNT= tv42
NO_ARCH= yes
USERS= git
GROUPS= ${USERS}
WRKSRC= ${WRKDIR}/${PORTNAME}
PYDISTUTILS_PKGVERSION= ${PORTVERSION:R}
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -s gitosis/test/
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (gitosis-0.2.20090917.tar.bz2) = f5cc21ce98400afa345d614e381717d957755f4c0cb68e2dd96fd1f9a1996299
SIZE (gitosis-0.2.20090917.tar.bz2) = 158966
TIMESTAMP = 1550465853
SHA256 (tv42-gitosis-release-0.3_GH0.tar.gz) = 9eb7dd1051663b72411b697c737aced0ea87d2971d6ccc381f0550794f56acd4
SIZE (tv42-gitosis-release-0.3_GH0.tar.gz) = 31175

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2019-02-18 05:26:38 UTC
+++ setup.py
@@ -18,7 +18,7 @@ def subdir_contents(path):
setup(
name = "gitosis",
- version = "0.2",
+ version = "0.3",
packages = find_packages(),
author = "Tommi Virtanen",

View File

@ -1,5 +1,5 @@
================================================================================
For more information, see http://eagain.net/gitweb/?p=gitosis.git.
For more information, see https://github.com/tv42/gitosis/blob/master/README.rst
================================================================================