MFH: r517610

Fix build on GCC architectures

PR:		241894
Submitted by:	pkubaj
Approved by:	portmgr blanket
This commit is contained in:
Emanuel Haupt 2019-11-14 20:10:05 +00:00
parent 27efb443c6
commit 14bef85bbe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q4/; revision=517611
2 changed files with 11 additions and 1 deletions

View File

@ -19,6 +19,7 @@ BUILD_DEPENDS= makedepend:devel/makedepend
GNU_CONFIGURE= yes
USES= autoreconf gettext-runtime gmake gnome jpeg localbase:ldflags \
pkgconfig
USE_CSTD= c99
USE_GITHUB= yes
USE_GNOME= gtk20
USE_XORG= x11 xext xi

View File

@ -1,4 +1,4 @@
--- configure.ac.orig 2018-09-15 19:08:05 UTC
--- configure.ac.orig 2019-10-19 17:01:57 UTC
+++ configure.ac
@@ -22,7 +22,7 @@ build_linux=no
build_mac=no
@ -9,3 +9,12 @@
build_linux=yes
;;
cygwin*|mingw*)
@@ -69,7 +69,7 @@ AC_ARG_ENABLE([debug],
[enable_debug=yes])
if test "x$enable_debug" = xyes; then
- CFLAGS="-O2 -g -DDEBUG"
+ CFLAGS+="-O2 -g -DDEBUG"
else
CFLAGS="-O2 -DNDEBUG"
fi