Update to 1.0.2

Changes:	https://github.com/Zulko/moviepy/releases
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-04-05 19:54:43 +00:00
parent 1822711f79
commit 14aae109df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=530819
4 changed files with 20 additions and 7 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= moviepy
PORTVERSION= 1.0.1
PORTVERSION= 1.0.2
CATEGORIES= multimedia python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1570031407
SHA256 (moviepy-1.0.1.tar.gz) = 9d5b0a0e884c0eb92c431baa110e560059720aab15d2ef3e4cba3892c34cf1ed
SIZE (moviepy-1.0.1.tar.gz) = 373968
TIMESTAMP = 1586082593
SHA256 (moviepy-1.0.2.tar.gz) = 00591a8a5288d323c45a49538dce2cf3ed4211b8cbf63e05c7c2a4c66a175c2a
SIZE (moviepy-1.0.2.tar.gz) = 7848478

View File

@ -1,6 +1,6 @@
--- moviepy/editor.py.orig 2019-02-14 01:02:48 UTC
--- moviepy/editor.py.orig 2020-03-24 20:20:06 UTC
+++ moviepy/editor.py
@@ -20,15 +20,6 @@ clip.preview().
@@ -20,18 +20,6 @@ clip.preview().
import os
import sys
@ -8,10 +8,13 @@
-import imageio
-# Checks to see if the user has set a place for their own version of ffmpeg
-
-if os.getenv('FFMPEG_BINARY', 'ffmpeg-imageio') == 'ffmpeg-imageio':
-if os.getenv('FFMPEG_BINARY') is None:
- if sys.version_info < (3, 4):
- #uses an old version of imageio with ffmpeg.download.
- imageio.plugins.ffmpeg.download()
-
-# Hide the welcome message from pygame: https://github.com/pygame/pygame/issues/542
-os.environ['PYGAME_HIDE_SUPPORT_PROMPT'] = "1"
-
# Clips
from .video.io.VideoFileClip import VideoFileClip

View File

@ -0,0 +1,10 @@
--- setup.py.orig 2020-03-24 20:20:07 UTC
+++ setup.py
@@ -67,7 +67,6 @@ requires = [
"imageio>=2.0,<2.5; python_version<'3.4'",
"imageio_ffmpeg>=0.2.0; python_version>='3.4'",
'tqdm>=4.11.2,<5.0',
- "numpy>=1.17.3; python_version!='2.7'",
"numpy; python_version>='2.7'",
'requests>=2.8.1,<3.0',
'proglog<=1.0.0'