Adding login.app version 2.0.0.a4.

A nice looking login interface to your favorite X-server.

PR:		16161
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Steve Price 2000-01-29 22:42:59 +00:00
parent e08ba3a685
commit 142e06cf65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25293
15 changed files with 266 additions and 0 deletions

View File

@ -30,6 +30,7 @@
SUBDIR += libdnd
SUBDIR += libhelp
SUBDIR += libsx
SUBDIR += login.app
SUBDIR += lupe
SUBDIR += offix-clipboard
SUBDIR += offix-execute

24
x11/login.app/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: login.app
# Version required: 2.0.0-Alpha-4
# Date created: 17 January 1999
# Whom: Maxim Sobolev <sobomax@altavista.net>
#
# $FreeBSD$
#
DISTNAME= Login.app-2.0.0-Alpha-4
PKGNAME= login.app-2.0.0.a4
CATEGORIES= x11 windowmaker
MASTER_SITES= http://www.fukt.hk-r.se/~per/login/
MAINTAINER= sobomax@altavista.net
LIB_DEPENDS= wraster.3:${PORTSDIR}/x11-wm/windowmaker \
PropList.2:${PORTSDIR}/devel/libPropList \
Xpm.4:${PORTSDIR}/graphics/xpm
USE_X_PREFIX= yes
ALL_TARGET= Login
.include <bsd.port.mk>

1
x11/login.app/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (Login.app-2.0.0-Alpha-4.tar.gz) = d47d5b5a5a041b51c2f2c7bb70b20786

View File

@ -0,0 +1,49 @@
--- Makefile.orig Fri Oct 29 18:55:32 1999
+++ Makefile Mon Jan 17 18:23:36 2000
@@ -2,12 +2,12 @@
# Login.app Makefile
#
-INSTALL_DIR = /usr/local/GNUstep/Apps/Login.app
+INSTALL_DIR = ${X11BASE}/GNUstep/Apps/Login.app
-INSTALL = /usr/bin/install
+INSTALL = /usr/bin/install -c
CC = cc
-CFLAGS += -g -Wall -pedantic -D_GNU_SOURCE `get-wraster-flags --cflags`
-LDFLAGS += `get-wraster-flags --ldflags` `get-wraster-flags --libs` -lXmu -lPropList -lcrypt
+CFLAGS += -g -Wall -pedantic -D_GNU_SOURCE `${X11BASE}/bin/get-wraster-flags --cflags`
+LDFLAGS += `${X11BASE}/bin/get-wraster-flags --ldflags` `${X11BASE}/bin/get-wraster-flags --libs` -lXmu -lPropList -lcrypt
TARGET = Login
@@ -19,8 +19,16 @@
graphics.o \
util.o
+SCRIPTS = Login.root \
+ Login.user \
+ Logout.root \
+ Restart \
+ Suspend \
+ PowerOff \
+ Startup
+
$(TARGET): $(OBJS)
- $(CC) -o $(TARGET) $^ $(LDFLAGS)
+ $(CC) -o $(TARGET) $(OBJS) $(LDFLAGS)
clean:
rm -rf $(TARGET) $(OBJS) core `find -name \*~`
@@ -31,9 +39,9 @@
$(INSTALL) -d $(INSTALL_DIR)/Themes
$(INSTALL) -d $(INSTALL_DIR)/Themes/Linux
$(INSTALL) -d $(INSTALL_DIR)/Themes/GNUstep
- $(INSTALL) $(TARGET) $(INSTALL_DIR)
+ $(INSTALL) -s $(TARGET) $(INSTALL_DIR)
$(INSTALL) -m 644 Preferences $(INSTALL_DIR)/Preferences
- $(INSTALL) Scripts/* $(INSTALL_DIR)/Scripts/
+ cd Scripts && $(INSTALL) $(SCRIPTS) $(INSTALL_DIR)/Scripts/
$(INSTALL) -m 644 Themes/Linux/* $(INSTALL_DIR)/Themes/Linux/
$(INSTALL) -m 644 Themes/GNUstep/* $(INSTALL_DIR)/Themes/GNUstep/

View File

@ -0,0 +1,11 @@
--- config.h.orig Mon Jan 17 16:35:19 2000
+++ config.h Mon Jan 17 16:38:24 2000
@@ -23,7 +23,7 @@
#define CONFIG_H
/* Enable shadow passwords, comment out to disable */
-#define SHADOW_PASSWD
+/*#define SHADOW_PASSWD*/
/* xinit */
#define XINIT "/usr/X11R6/bin/xinit"

View File

@ -0,0 +1,19 @@
--- switchuser.c.orig Mon Jan 17 16:23:02 2000
+++ switchuser.c Mon Jan 17 16:38:50 2000
@@ -25,10 +25,16 @@
#include <grp.h>
#include <paths.h>
#include <sys/types.h>
+#ifndef __FreeBSD__
#include <shadow.h>
+#endif
#include <proplist.h>
#include "util.h"
#include "config.h"
+
+#ifdef __FreeBSD__
+extern char **environ;
+#endif
static char* baseName(const char* name) {
const char *base;

View File

@ -0,0 +1,12 @@
--- util.c.orig Mon Jan 17 16:37:49 2000
+++ util.c Mon Jan 17 16:38:11 2000
@@ -28,6 +28,9 @@
#include <stdarg.h>
#include <string.h>
+#ifdef __FreeBSD__
+extern char **environ;
+#endif
void printError(const char *msg, ...) {
va_list args;

View File

@ -0,0 +1,26 @@
--- Scripts/Login.user.orig Sun Aug 1 01:37:50 1999
+++ Scripts/Login.user Mon Jan 17 18:10:27 2000
@@ -15,18 +15,18 @@
xinitrc=$HOME/.xinitrc
xsession=$HOME/.xsession
xclients=$HOME/.Xclients
-systemxinitrc=/etc/X11/xinit/xinitrc
+systemxinitrc=/usr/X11R6/lib/X11/xinit/xinitrc
twm=/usr/X11R6/bin/twm
xterm=/usr/X11R6/bin/xterm
if [ -r $xinitrc ]; then
- exec sh -login $xinitrc
+ exec sh $xinitrc
elif [ -r $xsession ]; then
- exec sh -login $xsession
+ exec sh $xsession
elif [ -r $xclients ]; then
- exec sh -login $xclients
+ exec sh $xclients
elif [ -r $systemxinitrc ]; then
- exec sh -login $systemxinitrc
+ exec sh $systemxinitrc
elif [ -x $twm ]; then
exec $twm
elif [ -x $xterm ]; then

View File

@ -0,0 +1,9 @@
--- Preferences.orig Mon Jan 17 16:51:19 2000
+++ Preferences Mon Jan 17 16:51:33 2000
@@ -1,5 +1,5 @@
{
- WelcomeMessage = "Welcome to LINUX";
+ WelcomeMessage = "Welcome to FreeBSD";
RestartMessage = "System is rebooting...";
PowerOffMessage = "System is shutting down...";
ConfirmRestartMessage = "Do you really want to restart the computer?";

View File

@ -0,0 +1,28 @@
--- resources.c.orig Sun Jul 25 11:09:29 1999
+++ resources.c Mon Jan 17 19:08:45 2000
@@ -80,10 +80,22 @@
}
/* Load fonts */
- resources->messageFont = XLoadQueryFont(dpy, preferences->messageFont);
- resources->inputFont = XLoadQueryFont(dpy, preferences->inputFont);
+ if ((resources->messageFont = XLoadQueryFont(dpy, preferences->messageFont)) == NULL) {
+ printError("could not load message font: %s\n%s%s%s%s%s", preferences->messageFont, \
+ "Try to edit your configuration file: ", appPath, "Themes/", preferences->theme, "/Settings");
+ return 0;
+ }
+ if ((resources->inputFont = XLoadQueryFont(dpy, preferences->inputFont)) == NULL) {
+ printError("could not load input font: %s\n%s%s%s%s%s", preferences->inputFont, \
+ "Try to edit your configuration file: ", appPath, "Themes/", preferences->theme, "/Settings");
+ return 0;
+ }
if (preferences->disableHostname == NO) {
- resources->hostnameFont = XLoadQueryFont(dpy, preferences->hostnameFont);
+ if ((resources->hostnameFont = XLoadQueryFont(dpy, preferences->hostnameFont)) == NULL) {
+ printError("could not load hostname font: %s\n%s%s%s%s%s", preferences->hostnameFont, \
+ "Try to edit your configuration file: ", appPath, "Themes/", preferences->theme, "/Settings");
+ return 0;
+ }
}
/* Get hostname */

View File

@ -0,0 +1,16 @@
--- Scripts/Login.root.orig Mon Jan 17 18:12:33 2000
+++ Scripts/Login.root Mon Jan 17 18:13:18 2000
@@ -5,11 +5,11 @@
#
# Make user the owner of /dev/console.
#
-chown $USER /dev/console
+/usr/sbin/chown $USER /dev/console
#
# Add user to utmp/wtmp.
#
-sessreg -a $USER
+/usr/X11R6/bin/sessreg -a $USER
# End of file

View File

@ -0,0 +1,24 @@
--- Scripts/Logout.root.orig Mon Jan 17 18:35:09 2000
+++ Scripts/Logout.root Mon Jan 17 18:35:44 2000
@@ -7,17 +7,17 @@
# window. This will prevent some Motif applications from
# crashing the next time they are started.
#
-xprop -root -remove _MOTIF_DRAG_WINDOW
+/usr/X11R6/bin/xprop -root -remove _MOTIF_DRAG_WINDOW
#
# Remove user from utmp/wtmp.
#
-sessreg -d $USER
+/usr/X11R6/bin/sessreg -d $USER
#
# Make root the owner of /dev/console.
#
-chmod 622 /dev/console
-chown root /dev/console
+/bin/chmod 622 /dev/console
+/usr/sbin/chown root /dev/console
# End of file

View File

@ -0,0 +1 @@
Nice looking login interface to your favorite X-Server

13
x11/login.app/pkg-descr Normal file
View File

@ -0,0 +1,13 @@
Login.app is a graphical login program that will give you a nice looking login
interface to your favorite X-Server. It will also make it easy for you to
reboot or halt your system. It has support for themes, so you can easily
change the look of the login panel.
PLEASE NOTE: Login.app is not a display manager and does not try to be.
Login.app is only a fast and nice looking graphical login panel that let's you
login on your system (you could say it's a graphical version of /bin/login).
Also, it does have some nice features to halt, reboot and suspend you system.
It will serve the needs of most users that just want a nice looking login
interface on their FreeBSD workstation.
WWW: http://www.fukt.hk-r.se/~per/login/

32
x11/login.app/pkg-plist Normal file
View File

@ -0,0 +1,32 @@
GNUstep/Apps/Login.app/Login
GNUstep/Apps/Login.app/Preferences
GNUstep/Apps/Login.app/Scripts/Login.root
GNUstep/Apps/Login.app/Scripts/Login.user
GNUstep/Apps/Login.app/Scripts/Logout.root
GNUstep/Apps/Login.app/Scripts/PowerOff
GNUstep/Apps/Login.app/Scripts/Restart
GNUstep/Apps/Login.app/Scripts/Startup
GNUstep/Apps/Login.app/Scripts/Suspend
GNUstep/Apps/Login.app/Themes/GNUstep/Settings
GNUstep/Apps/Login.app/Themes/GNUstep/fieldlabels.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/inputfield.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/panel.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/powerbuttondown.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/powerbuttonup.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/restartbuttondown.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/restartbuttonup.tiff
GNUstep/Apps/Login.app/Themes/GNUstep/stop.tiff
GNUstep/Apps/Login.app/Themes/Linux/Settings
GNUstep/Apps/Login.app/Themes/Linux/fieldlabels.tiff
GNUstep/Apps/Login.app/Themes/Linux/inputfield.tiff
GNUstep/Apps/Login.app/Themes/Linux/panel.tiff
GNUstep/Apps/Login.app/Themes/Linux/powerbuttondown.tiff
GNUstep/Apps/Login.app/Themes/Linux/powerbuttonup.tiff
GNUstep/Apps/Login.app/Themes/Linux/restartbuttondown.tiff
GNUstep/Apps/Login.app/Themes/Linux/restartbuttonup.tiff
GNUstep/Apps/Login.app/Themes/Linux/stop.tiff
@dirrm GNUstep/Apps/Login.app/Scripts
@dirrm GNUstep/Apps/Login.app/Themes/GNUstep
@dirrm GNUstep/Apps/Login.app/Themes/Linux
@dirrm GNUstep/Apps/Login.app/Themes
@dirrm GNUstep/Apps/Login.app