- Update to 2.51

PR:		84056
Submitted by:	leeym
Approved by:	janos.mohacsi@bsd.hu
This commit is contained in:
Yen-Ming Lee 2005-07-28 15:37:45 +00:00
parent 057318f32b
commit 13c47d4622
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140326
6 changed files with 12 additions and 82 deletions

View File

@ -5,12 +5,12 @@
# $FreeBSD$
#
PORTNAME= INET6
PORTVERSION= 2.01
PORTNAME= IO-Socket-INET6
PORTVERSION= 2.51
CATEGORIES= net perl5 ipv6
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IO
PKGNAMEPREFIX= p5-IO-
PKGNAMEPREFIX= p5-
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Perl module with object interface to AF_INET6 domain sockets
@ -22,10 +22,4 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (INET6-2.01.tar.gz) = 032a6e50c8c16e400836a9565cdb2f0b
SIZE (INET6-2.01.tar.gz) = 8628
MD5 (IO-Socket-INET6-2.51.tar.gz) = e4ef8b7944fa036cda19dc3e1cc688a6
SIZE (IO-Socket-INET6-2.51.tar.gz) = 9618

View File

@ -1,29 +0,0 @@
--- INET6.pm.orig Tue Jun 24 14:14:26 2003
+++ INET6.pm Wed Jul 2 21:33:28 2003
@@ -10,7 +10,7 @@
package IO::Socket::INET6;
use strict;
-our(@ISA, $VERSION);
+use vars qw(@ISA $VERSION);
use IO::Socket;
use Socket6;
use Carp;
@@ -20,7 +20,7 @@
@ISA = qw(IO::Socket);
$VERSION = "1.27";
-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
IO::Socket::INET6->register_domain( AF_INET6 );
@@ -183,7 +183,7 @@
}
if ($arg->{ReusePort}) {
- $sock->sockopt(SO_REUSEPORT,1) or
+ $sock->sockopt(0x0200,1) or
return _error($sock, $!, "$!");
}

View File

@ -5,12 +5,12 @@
# $FreeBSD$
#
PORTNAME= INET6
PORTVERSION= 2.01
PORTNAME= IO-Socket-INET6
PORTVERSION= 2.51
CATEGORIES= net perl5 ipv6
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IO
PKGNAMEPREFIX= p5-IO-
PKGNAMEPREFIX= p5-
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Perl module with object interface to AF_INET6 domain sockets
@ -22,10 +22,4 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (INET6-2.01.tar.gz) = 032a6e50c8c16e400836a9565cdb2f0b
SIZE (INET6-2.01.tar.gz) = 8628
MD5 (IO-Socket-INET6-2.51.tar.gz) = e4ef8b7944fa036cda19dc3e1cc688a6
SIZE (IO-Socket-INET6-2.51.tar.gz) = 9618

View File

@ -1,29 +0,0 @@
--- INET6.pm.orig Tue Jun 24 14:14:26 2003
+++ INET6.pm Wed Jul 2 21:33:28 2003
@@ -10,7 +10,7 @@
package IO::Socket::INET6;
use strict;
-our(@ISA, $VERSION);
+use vars qw(@ISA $VERSION);
use IO::Socket;
use Socket6;
use Carp;
@@ -20,7 +20,7 @@
@ISA = qw(IO::Socket);
$VERSION = "1.27";
-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
IO::Socket::INET6->register_domain( AF_INET6 );
@@ -183,7 +183,7 @@
}
if ($arg->{ReusePort}) {
- $sock->sockopt(SO_REUSEPORT,1) or
+ $sock->sockopt(0x0200,1) or
return _error($sock, $!, "$!");
}