- Update to version 0.4.1
PR: 20098 Submitted by: Ports Fury
This commit is contained in:
parent
35b75c97bb
commit
13769c5bd4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30955
@ -6,33 +6,27 @@
|
||||
#
|
||||
|
||||
PORTNAME= flux
|
||||
PORTVERSION= 0.3.0
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.styx.net/projects/flux/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/flux/html/img
|
||||
.for DIR in builds howto ideas reference
|
||||
@${MKDIR} ${PREFIX}/share/flux/plain/${DIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/plain/${DIR}/* ${PREFIX}/share/flux/plain/${DIR}/
|
||||
.endfor
|
||||
.for DIR in tex xml
|
||||
@${MKDIR} ${PREFIX}/share/flux/${DIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/${DIR}/* ${PREFIX}/share/flux/${DIR}/
|
||||
.endfor
|
||||
@${MKDIR} ${PREFIX}/share/doc/flux
|
||||
${TAR} -C ${WRKSRC}/doc --exclude ChangeLog -cf - . | \
|
||||
${TAR} -C ${PREFIX}/share/doc/flux --unlink -xf -
|
||||
@find ${PREFIX}/share/doc/flux | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
|
||||
@find ${PREFIX}/share/doc/flux -type f | xargs ${CHMOD} ${SHAREMODE}
|
||||
.for DOC in AUTHORS NEWS README TODO
|
||||
@${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/flux/
|
||||
${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/doc/flux
|
||||
.endfor
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/html/img/* ${PREFIX}/share/flux/html/img
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/html/*.html ${PREFIX}/share/flux/html
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/html/*.css ${PREFIX}/share/flux/html
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (flux-0.3.0.tar.gz) = 08cafc95346afbec344f02ffa9638eb2
|
||||
MD5 (flux-0.4.1.tar.gz) = 959cf209acfed3af40baf6a3bcd9c26b
|
||||
|
11
devel/flux/files/patch-ab
Normal file
11
devel/flux/files/patch-ab
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.in.orig Thu Feb 10 08:02:07 2000
|
||||
+++ configure.in Sat Jul 22 02:14:02 2000
|
||||
@@ -120,8 +120,6 @@
|
||||
|
||||
dnl --- Set compiler flags ---
|
||||
|
||||
-CFLAGS="$CFLAGS -O2 -Wall"
|
||||
-
|
||||
if test "$debug" = yes; then
|
||||
CFLAGS="$CFLAGS -g"
|
||||
fi
|
15
devel/flux/files/patch-ac
Normal file
15
devel/flux/files/patch-ac
Normal file
@ -0,0 +1,15 @@
|
||||
--- Makefile.am.orig Thu Feb 10 07:02:05 2000
|
||||
+++ Makefile.am Sat Jul 22 14:38:33 2000
|
||||
@@ -1,10 +1,9 @@
|
||||
-SUBDIRS = include src util examples
|
||||
+SUBDIRS = include src util
|
||||
|
||||
EXTRA_DIST = acconfig.h
|
||||
|
||||
all: all-recursive
|
||||
- if which bash >/dev/null 2>&1; then bash ./test.sh; \
|
||||
-else ./test.sh; fi
|
||||
+ util/test/test
|
||||
|
||||
dist-hook:
|
||||
sed "s/\[CVS\]/$(VERSION)/" <test.sh >$(distdir)/test.sh
|
@ -1,16 +1,26 @@
|
||||
include/flux/bmem.h
|
||||
include/flux/bt.h
|
||||
include/flux/cache.h
|
||||
include/flux/cgi.h
|
||||
include/flux/cipher.h
|
||||
include/flux/comm.h
|
||||
include/flux/db.h
|
||||
include/flux/fifobuf.h
|
||||
include/flux/flux.h
|
||||
include/flux/fstring.h
|
||||
include/flux/irc.h
|
||||
include/flux/log.h
|
||||
include/flux/mem.h
|
||||
include/flux/misc.h
|
||||
include/flux/mpi.h
|
||||
include/flux/mt.h
|
||||
include/flux/nvtp.h
|
||||
include/flux/ph.h
|
||||
include/flux/proc.h
|
||||
include/flux/proxy.h
|
||||
include/flux/random.h
|
||||
include/flux/rmd160.h
|
||||
include/flux/smtp.h
|
||||
include/flux/sock.h
|
||||
include/flux/tn.h
|
||||
include/flux/tt.h
|
||||
@ -18,65 +28,107 @@ include/flux/types.h
|
||||
include/flux/url.h
|
||||
include/flux/xml.h
|
||||
lib/libflux.a
|
||||
lib/libflux.so.0
|
||||
lib/libflux.so
|
||||
share/flux/AUTHORS
|
||||
share/flux/NEWS
|
||||
share/flux/README
|
||||
share/flux/TODO
|
||||
share/flux/html/authors.html
|
||||
share/flux/html/img/dot.gif
|
||||
share/flux/html/img/flux-logo.gif
|
||||
share/flux/html/index.html
|
||||
share/flux/html/notes.css
|
||||
share/flux/html/plans.html
|
||||
share/flux/html/platforms.html
|
||||
share/flux/html/ref-comm.html
|
||||
share/flux/html/ref-log.html
|
||||
share/flux/html/ref-mt.html
|
||||
share/flux/html/ref-proxy.html
|
||||
share/flux/html/ref-sock.html
|
||||
share/flux/html/ref-tt.html
|
||||
share/flux/html/ref.css
|
||||
share/flux/plain/builds/Summary
|
||||
share/flux/plain/builds/billy
|
||||
share/flux/plain/builds/domination
|
||||
share/flux/plain/builds/fili
|
||||
share/flux/plain/builds/foo
|
||||
share/flux/plain/builds/gluttony
|
||||
share/flux/plain/builds/harald
|
||||
share/flux/plain/builds/kassad
|
||||
share/flux/plain/builds/morten
|
||||
share/flux/plain/builds/nerdhaven
|
||||
share/flux/plain/builds/nocto
|
||||
share/flux/plain/builds/totem
|
||||
share/flux/plain/builds/vodka
|
||||
share/flux/plain/builds/wrath
|
||||
share/flux/plain/howto/comm-howto
|
||||
share/flux/plain/howto/fifobuf-howto
|
||||
share/flux/plain/howto/sock-howto
|
||||
share/flux/plain/howto/ttree-howto
|
||||
share/flux/plain/howto/xml-howto
|
||||
share/flux/plain/ideas/db-ideas
|
||||
share/flux/plain/ideas/ttree_rules-ideas
|
||||
share/flux/plain/ideas/xml_conversion-ideas
|
||||
share/flux/plain/reference/sock-reference
|
||||
share/flux/tex/comm.fig
|
||||
share/flux/tex/concepts.fig
|
||||
share/flux/tex/fifobuf.fig
|
||||
share/flux/tex/proxy.fig
|
||||
share/flux/tex/sock.fig
|
||||
share/flux/tex/tt.fig
|
||||
share/flux/tex/ttree-rules.fig
|
||||
share/flux/xml/api-ref-c.dtd
|
||||
lib/libflux.so.1
|
||||
share/doc/flux/AUTHORS
|
||||
share/doc/flux/NEWS
|
||||
share/doc/flux/README
|
||||
share/doc/flux/TODO
|
||||
share/doc/flux/html/.#index.html.1.15
|
||||
share/doc/flux/html/about.html
|
||||
share/doc/flux/html/benchmarks.html
|
||||
share/doc/flux/html/contact.html
|
||||
share/doc/flux/html/docs/future.html
|
||||
share/doc/flux/html/docs/hacking.html
|
||||
share/doc/flux/html/docs/index.html
|
||||
share/doc/flux/html/docs/platforms.html
|
||||
share/doc/flux/html/docs/ref-bmem.html
|
||||
share/doc/flux/html/docs/ref-comm.html
|
||||
share/doc/flux/html/docs/ref-log.html
|
||||
share/doc/flux/html/docs/ref-mt.html
|
||||
share/doc/flux/html/docs/ref-proxy.html
|
||||
share/doc/flux/html/docs/ref-sock.html
|
||||
share/doc/flux/html/docs/ref-tt.html
|
||||
share/doc/flux/html/docs/ref.css
|
||||
share/doc/flux/html/download.html
|
||||
share/doc/flux/html/img/background-gray.png
|
||||
share/doc/flux/html/img/frontpage-bottom.png
|
||||
share/doc/flux/html/img/frontpage-glass.png
|
||||
share/doc/flux/html/img/frontpage-header.png
|
||||
share/doc/flux/html/img/frontpage-menu-about.png
|
||||
share/doc/flux/html/img/frontpage-menu-contact.png
|
||||
share/doc/flux/html/img/frontpage-menu-cvs.png
|
||||
share/doc/flux/html/img/frontpage-menu-docs.png
|
||||
share/doc/flux/html/img/frontpage-menu-download.png
|
||||
share/doc/flux/html/img/frontpage-menu-footer.png
|
||||
share/doc/flux/html/img/frontpage-nurse.png
|
||||
share/doc/flux/html/img/graph-ballocbenchmark-alpha.png
|
||||
share/doc/flux/html/img/graph-ballocbenchmark-pentium.png
|
||||
share/doc/flux/html/img/menu-about.png
|
||||
share/doc/flux/html/img/menu-contact.png
|
||||
share/doc/flux/html/img/menu-cvs.png
|
||||
share/doc/flux/html/img/menu-docs.png
|
||||
share/doc/flux/html/img/menu-download-bottom.png
|
||||
share/doc/flux/html/img/menu-download-top.png
|
||||
share/doc/flux/html/img/subpage-header-left.png
|
||||
share/doc/flux/html/img/subpage-header-picturefooter.png
|
||||
share/doc/flux/html/img/subpage-header-pictureheader0.png
|
||||
share/doc/flux/html/img/subpage-header-pictureheader1.png
|
||||
share/doc/flux/html/img/subpage-header-pictureheader2.png
|
||||
share/doc/flux/html/img/subpage-header-pictureheader3.png
|
||||
share/doc/flux/html/img/subpage-header-topright.png
|
||||
share/doc/flux/html/img/subpage-icon-about.png
|
||||
share/doc/flux/html/img/subpage-icon-benchmarks.png
|
||||
share/doc/flux/html/img/subpage-icon-contact.png
|
||||
share/doc/flux/html/img/subpage-icon-docs.png
|
||||
share/doc/flux/html/img/subpage-icon-download.png
|
||||
share/doc/flux/html/img/subpage-icon-hacking.png
|
||||
share/doc/flux/html/img/subpage-icon-proxies.png
|
||||
share/doc/flux/html/img/subpage-icon-tree.png
|
||||
share/doc/flux/html/img/subpage-title-about.png
|
||||
share/doc/flux/html/img/subpage-title-benchmarks.png
|
||||
share/doc/flux/html/img/subpage-title-contact.png
|
||||
share/doc/flux/html/img/subpage-title-docs.png
|
||||
share/doc/flux/html/img/subpage-title-download.png
|
||||
share/doc/flux/html/img/subpage-title-hacking.png
|
||||
share/doc/flux/html/img/subpage-title-markuptrees.png
|
||||
share/doc/flux/html/img/subpage-title-proxies.png
|
||||
share/doc/flux/html/img/subpage-title-tokentrees.png
|
||||
share/doc/flux/html/index.html
|
||||
share/doc/flux/plain/builds/0.3.0/billy
|
||||
share/doc/flux/plain/builds/0.3.0/domination
|
||||
share/doc/flux/plain/builds/0.3.0/fili
|
||||
share/doc/flux/plain/builds/0.3.0/foo
|
||||
share/doc/flux/plain/builds/0.3.0/gluttony
|
||||
share/doc/flux/plain/builds/0.3.0/harald
|
||||
share/doc/flux/plain/builds/0.3.0/kassad
|
||||
share/doc/flux/plain/builds/0.3.0/morten
|
||||
share/doc/flux/plain/builds/0.3.0/nerdhaven
|
||||
share/doc/flux/plain/builds/0.3.0/nocto
|
||||
share/doc/flux/plain/builds/0.3.0/totem
|
||||
share/doc/flux/plain/builds/0.3.0/vodka
|
||||
share/doc/flux/plain/builds/0.3.0/wrath
|
||||
share/doc/flux/plain/builds/0.4.0/gluttony
|
||||
share/doc/flux/plain/builds/0.4.0/nocto
|
||||
share/doc/flux/plain/builds/0.4.0/wrath
|
||||
share/doc/flux/plain/builds/Summary
|
||||
share/doc/flux/tex/comm.fig
|
||||
share/doc/flux/tex/concepts.fig
|
||||
share/doc/flux/tex/depend.fig
|
||||
share/doc/flux/tex/fifobuf.fig
|
||||
share/doc/flux/tex/proxy.fig
|
||||
share/doc/flux/tex/refcard-gen.sh
|
||||
share/doc/flux/tex/refcard.tex
|
||||
share/doc/flux/tex/sock.fig
|
||||
share/doc/flux/tex/tt.fig
|
||||
share/doc/flux/tex/ttree-rules.fig
|
||||
@dirrm share/doc/flux/tex
|
||||
@dirrm share/doc/flux/plain/builds/0.4.0
|
||||
@dirrm share/doc/flux/plain/builds/0.3.0
|
||||
@dirrm share/doc/flux/plain/builds
|
||||
@dirrm share/doc/flux/plain
|
||||
@dirrm share/doc/flux/html/img
|
||||
@dirrm share/doc/flux/html/docs
|
||||
@dirrm share/doc/flux/html
|
||||
@dirrm share/doc/flux
|
||||
@dirrm include/flux
|
||||
@dirrm share/flux/html/img
|
||||
@dirrm share/flux/html
|
||||
@dirrm share/flux/plain/builds
|
||||
@dirrm share/flux/plain/howto
|
||||
@dirrm share/flux/plain/ideas
|
||||
@dirrm share/flux/plain/reference
|
||||
@dirrm share/flux/plain
|
||||
@dirrm share/flux/tex
|
||||
@dirrm share/flux/xml
|
||||
@dirrm share/flux
|
||||
|
Loading…
Reference in New Issue
Block a user