Rename devel/calltree to callgrind.

Update it to 0.9.8.
Update related ports.

PR:		ports/70936
Submitted by:	maintainer
This commit is contained in:
Sergey Matveychuk 2004-09-01 16:27:21 +00:00
parent 68322422c6
commit 12ffbba738
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117847
23 changed files with 108 additions and 113 deletions

1
MOVED
View File

@ -1256,3 +1256,4 @@ security/keyprint|security/opieprint|2004-08-28|newer version with a new name
www/quanta|www/kdewebdev|2004-08-30|renamed
net/kontact-plugins||2004-08-30|removed
palm/kpilot|deskutils/kdepim3|2004-08-30|kpilot has been reintegrated into kdepim
devel/calltree|devel/callgrind|2004-09-01|renamed by author

View File

@ -98,7 +98,7 @@
SUBDIR += c_c++_reference
SUBDIR += c_parser
SUBDIR += calibrator
SUBDIR += calltree
SUBDIR += callgrind
SUBDIR += cbrowser
SUBDIR += cc65
SUBDIR += ccache

View File

@ -5,11 +5,10 @@
# $FreeBSD$
#
PORTNAME= calltree
PORTVERSION= 0.9.7
PORTNAME= callgrind
PORTVERSION= 0.9.8
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= kcachegrind
MASTER_SITES= http://kcachegrind.sourceforge.net/
MAINTAINER= barner@gmx.de
COMMENT= Valgrind skin for cache simulation and call tracing
@ -21,4 +20,15 @@ ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.mk>
OPTIONS= VALGRIND_SNAPSHOT "Depend on snapshot version of valgrind" off
.include <bsd.port.pre.mk>
.if defined (WITH_VALGRIND_SNAPSHOT)
RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind-snapshot
BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind-snapshot
.else
RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (calltree-0.9.7.tar.gz) = f1bb4e6446f26219cf5772849630b380
SIZE (calltree-0.9.7.tar.gz) = 156812
MD5 (callgrind-0.9.8.tar.gz) = 5d98a82128b66a8ad4a931b728db420b
SIZE (callgrind-0.9.8.tar.gz) = 178524

View File

@ -1,11 +1,13 @@
--- src/Makefile.in.orig Thu Jun 3 05:08:28 2004
+++ src/Makefile.in Thu Jun 3 05:08:54 2004
@@ -116,7 +116,7 @@
--- src/Makefile.in.orig Thu Aug 19 22:46:55 2004
+++ src/Makefile.in Wed Aug 25 10:07:20 2004
@@ -167,8 +167,8 @@
target_alias = @target_alias@
SUBDIRS = .
AM_CFLAGS = $(WERROR) -DVG_LIBDIR="\"$(libdir)"\" \
- -Winline -Wall -Wshadow -O -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@ -g
+ -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@
- -Winline -Wall -Wshadow -O2 -fomit-frame-pointer \
- @PREFERRED_STACK_BOUNDARY@ -g
+ -fomit-frame-pointer \
+ @PREFERRED_STACK_BOUNDARY@
valdir = $(libdir)/valgrind
incincdir = $(includedir)/valgrind

View File

@ -1,11 +1,10 @@
--- src/ct_main.c.orig Thu Jun 3 05:04:08 2004
+++ src/ct_main.c Thu Jun 3 05:05:51 2004
@@ -5758,7 +5758,7 @@
/* Install own SIGILL handler */
sigill_new.ksa_handler = cpuid_SIGILL_handler;
sigill_new.ksa_flags = 0;
- sigill_new.ksa_restorer = NULL;
+ // sigill_new.ksa_restorer = NULL;
res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
CT_ASSERT(res == 0);
--- src/ct_main.c.orig Wed Aug 25 10:10:18 2004
+++ src/ct_main.c Wed Aug 25 10:13:36 2004
@@ -32,6 +32,7 @@
*/
#include "vg_skin.h"
+#include "vg_unistd.h"
#include "callgrind.h"
#include "ct_include.h"
#include "ct_events.h"

View File

@ -1,11 +1,11 @@
--- src/ct_main.c.orig Thu Jun 3 05:04:08 2004
+++ src/ct_main.c Thu Jun 3 05:05:51 2004
@@ -5758,7 +5758,7 @@
--- src/ct_sim.c.orig Tue Aug 31 13:05:51 2004
+++ src/ct_sim.c Tue Aug 31 13:06:00 2004
@@ -537,7 +537,7 @@
/* Install own SIGILL handler */
sigill_new.ksa_handler = cpuid_SIGILL_handler;
sigill_new.ksa_flags = 0;
- sigill_new.ksa_restorer = NULL;
+ // sigill_new.ksa_restorer = NULL;
+ //sigill_new.ksa_restorer = NULL;
res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
CT_ASSERT(res == 0);

View File

@ -1,9 +1,9 @@
Calltree uses runtime instrumentation via the Valgrind framework for its
Callgrind uses runtime instrumentation via the Valgrind framework for its
cache simulation and call tracing. This way, even shared libraries and
dynamically opened plugins can be profiled. The data files generated by
Calltree can be loaded into KCachegrind for browsing the performance results.
Callgrind can be loaded into KCachegrind for browsing the performance results.
But there is also a command line tool in the Calltree package to get ASCII
reports from Calltree data files without the need to use KCachegrind.
But there is also a command line tool in the Callgrind package to get ASCII
reports from Callgrind data files without the need to use KCachegrind.
WWW: http://kcachegrind.sourceforge.net

View File

@ -1,7 +1,7 @@
bin/calltree
bin/ct_annotate
bin/ct_control
include/valgrind/calltree.h
lib/valgrind/vgskin_calltree.so
bin/callgrind
bin/callgrind_annotate
bin/callgrind_control
include/valgrind/callgrind.h
lib/valgrind/vgskin_callgrind.so
share/doc/valgrind/ct_main.html
share/doc/valgrind/ct_techdocs.html

View File

@ -1,24 +0,0 @@
# New ports collection makefile for: calltree
# Date created: Jun 3 2004
# Whom: Simon Barner <barner@gmx.de>
#
# $FreeBSD$
#
PORTNAME= calltree
PORTVERSION= 0.9.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= kcachegrind
MAINTAINER= barner@gmx.de
COMMENT= Valgrind skin for cache simulation and call tracing
RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
MD5 (calltree-0.9.7.tar.gz) = f1bb4e6446f26219cf5772849630b380
SIZE (calltree-0.9.7.tar.gz) = 156812

View File

@ -1,19 +0,0 @@
--- configure.orig Sat Jul 31 20:09:02 2004
+++ configure Sat Jul 31 20:09:18 2004
@@ -3212,16 +3212,9 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
-int
-main ()
-{
-
#include "vg_skin.h"
int main() { return 0 ; }
- ;
- return 0;
-}
_ACEOF
rm -f conftest.$ac_objext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5

View File

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Thu Jun 3 05:08:28 2004
+++ src/Makefile.in Thu Jun 3 05:08:54 2004
@@ -116,7 +116,7 @@
SUBDIRS = .
AM_CFLAGS = $(WERROR) -DVG_LIBDIR="\"$(libdir)"\" \
- -Winline -Wall -Wshadow -O -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@ -g
+ -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@
valdir = $(libdir)/valgrind

View File

@ -1,9 +0,0 @@
Calltree uses runtime instrumentation via the Valgrind framework for its
cache simulation and call tracing. This way, even shared libraries and
dynamically opened plugins can be profiled. The data files generated by
Calltree can be loaded into KCachegrind for browsing the performance results.
But there is also a command line tool in the Calltree package to get ASCII
reports from Calltree data files without the need to use KCachegrind.
WWW: http://kcachegrind.sourceforge.net

View File

@ -1,7 +0,0 @@
bin/calltree
bin/ct_annotate
bin/ct_control
include/valgrind/calltree.h
lib/valgrind/vgskin_calltree.so
share/doc/valgrind/ct_main.html
share/doc/valgrind/ct_techdocs.html

View File

@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= kcachegrind
MAINTAINER= barner@gmx.de
COMMENT= Profiling Visualization Tool
RUN_DEPENDS= calltree:${PORTSDIR}/devel/calltree
RUN_DEPENDS= callgrind:${PORTSDIR}/devel/callgrind
ONLY_FOR_ARCHS= i386
CONFLICTS= kdesdk3-[0-9]*
@ -24,8 +24,16 @@ USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_REINPLACE= yes
OPTIONS= DOT "Use GraphViz/dot to render call graphs" on
.include <bsd.port.pre.mk>
.if defined (WITH_DOT)
RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,20 @@
--- aclocal.m4.orig Wed Apr 28 21:47:24 2004
+++ aclocal.m4 Sat Jul 31 16:24:17 2004
@@ -2773,7 +2773,7 @@
CFLAGS="-g -O2 $CFLAGS"
fi
else
- CFLAGS="-O2 $CFLAGS"
+ CFLAGS="$CFLAGS"
fi
fi
@@ -2815,7 +2815,7 @@
if test "$CXX" = "KCC"; then
CXXFLAGS="+K3 $CXXFLAGS"
else
- CXXFLAGS="-O2 $CXXFLAGS"
+ CXXFLAGS="$CXXFLAGS"
fi
fi
fi

View File

@ -12,6 +12,7 @@ share/apps/kcachegrind/icons/hicolor/22x22/actions/percent.png
share/apps/kcachegrind/icons/hicolor/32x32/actions/percent.png
share/apps/kcachegrind/kcachegrindui.rc
share/apps/kcachegrind/tips
share/doc/HTML/en/kcachegrind/common
share/doc/HTML/en/kcachegrind/index.docbook
share/doc/HTML/en/kcachegrind/index.cache.bz2
share/icons/hicolor/32x32/apps/kcachegrind.png

View File

@ -7,6 +7,7 @@
PORTNAME= valgrind
PORTVERSION= 352
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.rabson.org/
PKGNAMESUFFIX= -snapshot
@ -59,4 +60,8 @@ pre-patch:
${REINPLACE_CMD} -e "s/docs//g" {} \;
.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/coregrind/vg_unistd.h \
${PREFIX}/include/valgrind
.include <bsd.port.post.mk>

View File

@ -0,0 +1,15 @@
--- coregrind/vg_signals.c.orig Tue Aug 31 22:39:50 2004
+++ coregrind/vg_signals.c Tue Aug 31 22:41:36 2004
@@ -1374,6 +1374,12 @@
#define NT_PRXFPREG 0x46e62b7f /* copied from gdb5.1/include/elf/common.h */
#endif /* NT_PRXFPREG */
+// FIXME: Needed for FreeBSD 4, same ugly hack as in coregrind/ume.c XXX
+#ifndef ELFMAG
+#define ELFMAG "\177ELF"
+#define SELFMAG 4
+#endif
+
/* If true, then this Segment may be mentioned in the core */
static Bool may_dump(const Segment *seg)
{

View File

@ -7,6 +7,7 @@ include/valgrind/valgrind.h
include/valgrind/vg_constants_skin.h
include/valgrind/vg_kerneliface.h
include/valgrind/vg_skin.h
include/valgrind/vg_unistd.h
lib/valgrind/default.supp
lib/valgrind/glibc-2.1.supp
lib/valgrind/glibc-2.2.supp

View File

@ -7,6 +7,7 @@
PORTNAME= valgrind
PORTVERSION= 352
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.rabson.org/
DISTNAME= ${PORTNAME}-stable-${PORTVERSION}
@ -64,10 +65,13 @@ pre-patch:
.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/coregrind/vg_unistd.h \
${PREFIX}/include/valgrind
@${ECHO} ""
@${ECHO} ""
@${CAT} ${PKGMESSAGE}
@${ECHO} ""
++ pkg-plist Wed Aug 25 11:23:09 2004
@${ECHO} ""
.include <bsd.port.post.mk>

View File

@ -7,6 +7,7 @@ include/valgrind/valgrind.h
include/valgrind/vg_constants_skin.h
include/valgrind/vg_kerneliface.h
include/valgrind/vg_skin.h
include/valgrind/vg_unistd.h
lib/valgrind/default.supp
lib/valgrind/glibc-2.1.supp
lib/valgrind/glibc-2.2.supp