- Convert to USE_LDCONFIG.
PR: ports/93186 Submitted by: $self Approved by: maintainer
This commit is contained in:
parent
a7686ddbe1
commit
128460e57c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163869
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= portupgrade
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
|
||||
@ -27,12 +27,15 @@ PATCH_DIST_STRIP= -p1
|
||||
|
||||
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
|
||||
|
||||
USE_RC_SUBR= yes
|
||||
USE_BZIP2= yes
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_FEATURES= optparse ruby18
|
||||
USE_PERL5_RUN= yes
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
|
||||
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
|
||||
|
||||
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
|
||||
|
||||
MAN1= pkg_deinstall.1 \
|
||||
@ -57,6 +60,7 @@ INSTALL_TARGET+= install-doc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
|
||||
|
||||
.if defined(WITH_BDB4)
|
||||
# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
|
||||
@ -72,7 +76,7 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
|
||||
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
post-install: install-ldconfig-file
|
||||
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
|
||||
fi
|
||||
|
19
ports-mgmt/portupgrade-devel/files/patch-etc_Makefile
Normal file
19
ports-mgmt/portupgrade-devel/files/patch-etc_Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
--- etc/Makefile.orig Sat Feb 11 16:39:34 2006
|
||||
+++ etc/Makefile Sat Feb 11 16:39:49 2006
|
||||
@@ -2,15 +2,9 @@
|
||||
|
||||
ETCDIR?= ${PREFIX}/etc
|
||||
|
||||
-SCRIPTSDIR?= ${ETCDIR}/rc.d
|
||||
-
|
||||
BUILDDIR= .build
|
||||
|
||||
-SCRIPTS= ${BUILDDIR}/pkgtools.sh \
|
||||
- ${BUILDDIR}/status-pkg.sh
|
||||
-
|
||||
-SCRIPTSDIR_pkgtools.sh= ${ETCDIR}/rc.d
|
||||
-SCRIPTSNAME_pkgtools.sh= 000.pkgtools.sh
|
||||
+SCRIPTS= ${BUILDDIR}/status-pkg.sh
|
||||
|
||||
#SCRIPTSDIR_status-pkg.sh= /etc/periodic/weekly
|
||||
#SCRIPTSNAME_status-pkg.sh= 400.status-pkg.sh
|
@ -1,7 +1,5 @@
|
||||
etc/rc.d/000.pkgtools.sh
|
||||
@exec /bin/mkdir -p %D/lib/compat/pkg
|
||||
@dirrmtry lib/compat/pkg
|
||||
@dirrmtry lib/compat
|
||||
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
|
||||
sbin/pkg_deinstall
|
||||
sbin/pkg_fetch
|
||||
sbin/pkg_glob
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= portupgrade
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
|
||||
@ -27,12 +27,15 @@ PATCH_DIST_STRIP= -p1
|
||||
|
||||
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
|
||||
|
||||
USE_RC_SUBR= yes
|
||||
USE_BZIP2= yes
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_FEATURES= optparse ruby18
|
||||
USE_PERL5_RUN= yes
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
|
||||
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
|
||||
|
||||
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
|
||||
|
||||
MAN1= pkg_deinstall.1 \
|
||||
@ -57,6 +60,7 @@ INSTALL_TARGET+= install-doc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
|
||||
|
||||
.if defined(WITH_BDB4)
|
||||
# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
|
||||
@ -72,7 +76,7 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
|
||||
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
post-install: install-ldconfig-file
|
||||
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
|
||||
fi
|
||||
|
19
ports-mgmt/portupgrade/files/patch-etc_Makefile
Normal file
19
ports-mgmt/portupgrade/files/patch-etc_Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
--- etc/Makefile.orig Sat Feb 11 16:39:34 2006
|
||||
+++ etc/Makefile Sat Feb 11 16:39:49 2006
|
||||
@@ -2,15 +2,9 @@
|
||||
|
||||
ETCDIR?= ${PREFIX}/etc
|
||||
|
||||
-SCRIPTSDIR?= ${ETCDIR}/rc.d
|
||||
-
|
||||
BUILDDIR= .build
|
||||
|
||||
-SCRIPTS= ${BUILDDIR}/pkgtools.sh \
|
||||
- ${BUILDDIR}/status-pkg.sh
|
||||
-
|
||||
-SCRIPTSDIR_pkgtools.sh= ${ETCDIR}/rc.d
|
||||
-SCRIPTSNAME_pkgtools.sh= 000.pkgtools.sh
|
||||
+SCRIPTS= ${BUILDDIR}/status-pkg.sh
|
||||
|
||||
#SCRIPTSDIR_status-pkg.sh= /etc/periodic/weekly
|
||||
#SCRIPTSNAME_status-pkg.sh= 400.status-pkg.sh
|
@ -1,7 +1,5 @@
|
||||
etc/rc.d/000.pkgtools.sh
|
||||
@exec /bin/mkdir -p %D/lib/compat/pkg
|
||||
@dirrmtry lib/compat/pkg
|
||||
@dirrmtry lib/compat
|
||||
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
|
||||
sbin/pkg_deinstall
|
||||
sbin/pkg_fetch
|
||||
sbin/pkg_glob
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= portupgrade
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
|
||||
@ -27,12 +27,15 @@ PATCH_DIST_STRIP= -p1
|
||||
|
||||
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
|
||||
|
||||
USE_RC_SUBR= yes
|
||||
USE_BZIP2= yes
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_FEATURES= optparse ruby18
|
||||
USE_PERL5_RUN= yes
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
|
||||
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
|
||||
|
||||
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
|
||||
|
||||
MAN1= pkg_deinstall.1 \
|
||||
@ -57,6 +60,7 @@ INSTALL_TARGET+= install-doc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
|
||||
|
||||
.if defined(WITH_BDB4)
|
||||
# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
|
||||
@ -72,7 +76,7 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
|
||||
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
post-install: install-ldconfig-file
|
||||
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
|
||||
fi
|
||||
|
19
sysutils/portupgrade-devel/files/patch-etc_Makefile
Normal file
19
sysutils/portupgrade-devel/files/patch-etc_Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
--- etc/Makefile.orig Sat Feb 11 16:39:34 2006
|
||||
+++ etc/Makefile Sat Feb 11 16:39:49 2006
|
||||
@@ -2,15 +2,9 @@
|
||||
|
||||
ETCDIR?= ${PREFIX}/etc
|
||||
|
||||
-SCRIPTSDIR?= ${ETCDIR}/rc.d
|
||||
-
|
||||
BUILDDIR= .build
|
||||
|
||||
-SCRIPTS= ${BUILDDIR}/pkgtools.sh \
|
||||
- ${BUILDDIR}/status-pkg.sh
|
||||
-
|
||||
-SCRIPTSDIR_pkgtools.sh= ${ETCDIR}/rc.d
|
||||
-SCRIPTSNAME_pkgtools.sh= 000.pkgtools.sh
|
||||
+SCRIPTS= ${BUILDDIR}/status-pkg.sh
|
||||
|
||||
#SCRIPTSDIR_status-pkg.sh= /etc/periodic/weekly
|
||||
#SCRIPTSNAME_status-pkg.sh= 400.status-pkg.sh
|
@ -1,7 +1,5 @@
|
||||
etc/rc.d/000.pkgtools.sh
|
||||
@exec /bin/mkdir -p %D/lib/compat/pkg
|
||||
@dirrmtry lib/compat/pkg
|
||||
@dirrmtry lib/compat
|
||||
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
|
||||
sbin/pkg_deinstall
|
||||
sbin/pkg_fetch
|
||||
sbin/pkg_glob
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= portupgrade
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
|
||||
@ -27,12 +27,15 @@ PATCH_DIST_STRIP= -p1
|
||||
|
||||
OPTIONS= BDB4 "Use Berkeley DB >=2 as backend. (Use BDB 1.85 if off)" off
|
||||
|
||||
USE_RC_SUBR= yes
|
||||
USE_BZIP2= yes
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_FEATURES= optparse ruby18
|
||||
USE_PERL5_RUN= yes
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
|
||||
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
|
||||
|
||||
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
|
||||
|
||||
MAN1= pkg_deinstall.1 \
|
||||
@ -57,6 +60,7 @@ INSTALL_TARGET+= install-doc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
|
||||
|
||||
.if defined(WITH_BDB4)
|
||||
# For PKG_DBDRIVER={bdb_btree,bdb_hash,bdb}
|
||||
@ -72,7 +76,7 @@ PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
|
||||
IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
post-install: install-ldconfig-file
|
||||
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
|
||||
fi
|
||||
|
19
sysutils/portupgrade/files/patch-etc_Makefile
Normal file
19
sysutils/portupgrade/files/patch-etc_Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
--- etc/Makefile.orig Sat Feb 11 16:39:34 2006
|
||||
+++ etc/Makefile Sat Feb 11 16:39:49 2006
|
||||
@@ -2,15 +2,9 @@
|
||||
|
||||
ETCDIR?= ${PREFIX}/etc
|
||||
|
||||
-SCRIPTSDIR?= ${ETCDIR}/rc.d
|
||||
-
|
||||
BUILDDIR= .build
|
||||
|
||||
-SCRIPTS= ${BUILDDIR}/pkgtools.sh \
|
||||
- ${BUILDDIR}/status-pkg.sh
|
||||
-
|
||||
-SCRIPTSDIR_pkgtools.sh= ${ETCDIR}/rc.d
|
||||
-SCRIPTSNAME_pkgtools.sh= 000.pkgtools.sh
|
||||
+SCRIPTS= ${BUILDDIR}/status-pkg.sh
|
||||
|
||||
#SCRIPTSDIR_status-pkg.sh= /etc/periodic/weekly
|
||||
#SCRIPTSNAME_status-pkg.sh= 400.status-pkg.sh
|
@ -1,7 +1,5 @@
|
||||
etc/rc.d/000.pkgtools.sh
|
||||
@exec /bin/mkdir -p %D/lib/compat/pkg
|
||||
@dirrmtry lib/compat/pkg
|
||||
@dirrmtry lib/compat
|
||||
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
|
||||
sbin/pkg_deinstall
|
||||
sbin/pkg_fetch
|
||||
sbin/pkg_glob
|
||||
|
Loading…
Reference in New Issue
Block a user