- Add new port: www/py-tornado6
- In www/py-tornado: Add conflict with py-tornado6 - In www/py-tornado4: Add conflict with py-tornado6
This commit is contained in:
parent
ee95c7713e
commit
123241acff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=496103
@ -12,7 +12,7 @@ COMMENT= Python Web Server from FriendFeed
|
||||
|
||||
LICENSE= APACHE20
|
||||
|
||||
CONFLICTS= py[0-9]*-tornado4-*
|
||||
CONFLICTS= py[0-9]*-tornado[46]-*
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
@ -13,7 +13,7 @@ COMMENT= Python Web Server from FriendFeed
|
||||
|
||||
LICENSE= APACHE20
|
||||
|
||||
CONFLICTS= py[0-9]*-tornado-*
|
||||
CONFLICTS= py[0-9]*-tornado-* py[0-9]*-tornado6-*
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
26
www/py-tornado6/Makefile
Normal file
26
www/py-tornado6/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# Created by: Guixing Bai <khsing.cn@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tornado
|
||||
PORTVERSION= 6.0.1
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= gblach@FreeBSD.org
|
||||
COMMENT= Python Web Server from FriendFeed
|
||||
|
||||
LICENSE= APACHE20
|
||||
|
||||
CONFLICTS= py[0-9]*-tornado-* py[0-9]*-tornado4-*
|
||||
|
||||
USES= python:3.5+
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
post-build:
|
||||
@${FIND} ${WRKSRC}/build -name speedups.so -exec ${STRIP_CMD} {} \;
|
||||
|
||||
regression-test: build
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} -m tornado.test.runtests
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/py-tornado6/distinfo
Normal file
3
www/py-tornado6/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1552850221
|
||||
SHA256 (tornado-6.0.1.tar.gz) = de274c65f45f6656c375cdf1759dbf0bc52902a1e999d12a35eb13020a641a53
|
||||
SIZE (tornado-6.0.1.tar.gz) = 481563
|
12
www/py-tornado6/files/patch-setup.py
Normal file
12
www/py-tornado6/files/patch-setup.py
Normal file
@ -0,0 +1,12 @@
|
||||
--- setup.py.orig 2015-11-06 20:08:26 UTC
|
||||
+++ setup.py
|
||||
@@ -147,9 +147,6 @@ setup(
|
||||
# in the sdist tarball)
|
||||
"tornado.test": [
|
||||
"README",
|
||||
- "csv_translations/fr_FR.csv",
|
||||
- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.mo",
|
||||
- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.po",
|
||||
"options_test.cfg",
|
||||
"static/robots.txt",
|
||||
"static/sample.xml",
|
15
www/py-tornado6/pkg-descr
Normal file
15
www/py-tornado6/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
Tornado is an open source version of the scalable, non-blocking web server and
|
||||
tools that power FriendFeed. The FriendFeed application is written using a web
|
||||
framework that looks a bit like web.py or Google's webapp, but with additional
|
||||
tools and optimizations to take advantage of the underlying non-blocking
|
||||
infrastructure.
|
||||
|
||||
The framework is distinct from most mainstream web server frameworks (and
|
||||
certainly most Python frameworks) because it is non-blocking and reasonably
|
||||
fast. Because it is non-blocking and uses epoll or kqueue, it can handle
|
||||
thousands of simultaneous standing connections, which means it is ideal for
|
||||
real-time web services. We built the web server specifically to handle
|
||||
FriendFeed's real-time features - every active user of FriendFeed maintains an
|
||||
open connection to the FriendFeed servers.
|
||||
|
||||
WWW: http://www.tornadoweb.org/
|
Loading…
Reference in New Issue
Block a user