- Fix build on -current after gcc 3.3 import

PR:	71875, 71886
Submitted by:	Ports Fury
Approved by:	portmgr (marcus)
This commit is contained in:
Ying-Chieh Liao 2004-09-24 01:04:01 +00:00
parent 2a7f35e54e
commit 1221f6cfad
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118364
8 changed files with 196 additions and 9 deletions

View File

@ -15,15 +15,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A player for many different Amiga and PC module formats
USE_REINPLACE= yes
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" CFLAGS="-I${LOCALBASE}/include -fPIC"
USE_AUTOCONF_VER= 213
WANT_GNOME= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-alsa
CFLAGS+= -fPIC
.include <bsd.port.pre.mk>

View File

@ -0,0 +1,10 @@
--- src/loaders/ac1d_load.c.orig Sat Dec 30 03:08:12 2000
+++ src/loaders/ac1d_load.c Sat Sep 18 23:41:47 2004
@@ -150,6 +150,7 @@
case 0x0a:
event->fxt = 0x00;
case 0x0f:
+ ;
}
}
}

View File

@ -0,0 +1,10 @@
--- src/loaders/pp10_load.c.orig Sat Dec 30 03:08:46 2000
+++ src/loaders/pp10_load.c Sat Sep 18 23:44:27 2004
@@ -226,6 +226,7 @@
case 0x0a:
event->fxt = 0x00;
case 0x0f:
+ ;
}
}

View File

@ -9,7 +9,7 @@ PORTNAME= vdk
PORTVERSION= 2.4.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= vdkbuilder
MASTER_SITE_SUBDIR= vdklib
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ wrapper for GTK+ toolkit
@ -20,7 +20,7 @@ USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no
CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no --enable-testvdk=no
INSTALLS_SHLIB= yes
MAN1= vdk-config-2.1

View File

@ -0,0 +1,45 @@
--- vdk/chart.cc.orig Wed May 22 17:26:12 2002
+++ vdk/chart.cc Thu Aug 5 19:16:35 2004
@@ -45,7 +45,10 @@
size = Usize;
printf("\nsize:%d,%d",size.x,size.y);
fflush(stdout);
- axis = ChartAxis(this,size.X(),size.Y());
+ // patch Bug#262091
+ // axis = ChartAxis(this,size.X(),size.Y());
+ ChartAxis axis_tmp( this, size.X(), size.Y() );
+ axis = axis_tmp;
axis.Draw();
DrawTitle();
DrawChart();
@@ -115,7 +118,10 @@
void VDKChart::SetChartBorder(int b)
{
size = Usize;
-axis = ChartAxis(this,size.X(),size.Y());
+// patch Bug#262091
+// axis = ChartAxis(this,size.X(),size.Y());
+ChartAxis axis_tmp(this,size.X(),size.Y());
+axis = axis_tmp;
DrawChart();
}
/*
@@ -415,10 +421,18 @@
ChartAxis::ChartAxis(VDKChart* owner,int w, int h):
owner(owner)
{
+// patch Bug#262091
+/*
domain = VDKRect(owner->ChartBorder,
h-owner->ChartBorder,
w-owner->ChartBorder*2,
h-owner->ChartBorder*2);
+*/
+VDKRect r(owner->ChartBorder,
+ h-owner->ChartBorder,
+ w-owner->ChartBorder*2,
+ h-owner->ChartBorder*2);
+domain = r;
}
/*
copy-initializer

View File

@ -0,0 +1,62 @@
--- vdk/vdkbtrees.h.orig Wed Nov 22 14:10:33 2000
+++ vdk/vdkbtrees.h Thu Aug 5 19:16:36 2004
@@ -717,7 +717,7 @@
class AbstractRedBlackTree : public AbstractBinaryTree<T, Node> {
protected:
virtual Node *FindNode(T q)
- { return (root) ? (Node *) root->find(q) : NULL; }
+ { return (this->root) ? (Node *) this->root->find(q) : NULL; }
};
/*!
@@ -985,14 +985,14 @@
BlackHeight = -1;
// Check binary tree properties.
- if (parent != _parent)
+ if (this->parent != _parent)
return NULL;
- if (left) {
- if (object < left->object)
+ if (this->left) {
+ if (this->object < this->left->object)
return NULL;
}
- if (right) {
- if (right->object < object)
+ if (this->right) {
+ if (this->right->object < this->object)
return NULL;
}
@@ -1001,15 +1001,15 @@
// If a node is red, then both its children are black
// (NULL nodes are black).
if (clr == Red) {
- if ((left && left->clr != Black) ||
- (right && right->clr != Black))
+ if ((this->left && this->left->clr != Black) ||
+ (this->right && this->right->clr != Black))
return NULL;
}
// The black-heights of all leaf nodes are equal.
int bh = NULL;
- if ((! left) && (! right)) {
+ if ((! this->left) && (! this->right)) {
// Compute black-height of node
for (Node *sc = (Node *) this; sc; sc = sc->parent)
if (sc->clr == Black)
@@ -1023,9 +1023,9 @@
return NULL;
}
}
- if (left && (! left->CheckTreeProperties((Node *) this)))
+ if (this->left && (! this->left->CheckTreeProperties((Node *) this)))
return NULL;
- if (right && (! right->CheckTreeProperties((Node *) this)))
+ if (this->right && (! this->right->CheckTreeProperties((Node *) this)))
return NULL;
return 1;
}

View File

@ -0,0 +1,58 @@
--- vdk/vdkheap.h.orig Wed Nov 22 14:10:52 2000
+++ vdk/vdkheap.h Thu Aug 5 19:16:36 2004
@@ -85,7 +85,7 @@
VDKHeap<T>::VDKHeap(T* source, int size): VDKContainer<T>(size)
{
for(int i = 0; i < size; i++)
- data[i] = source[i];
+ this->data[i] = source[i];
BuildHeap();
}
@@ -94,13 +94,13 @@
void VDKHeap<T>::Heapify(int i, int heapsize)
{
int l = left(i), r = right(i), largest = i;
- if( (l < heapsize) && (data[l] > data[i])) largest = l;
- if( (r < heapsize) && (data[r] > data[largest])) largest = r;
+ if( (l < heapsize) && (this->data[l] > this->data[i])) largest = l;
+ if( (r < heapsize) && (this->data[r] > this->data[largest])) largest = r;
if(largest != i)
{
- T temp = data[i];
- data[i] = data[largest];
- data[largest] = temp;
+ T temp = this->data[i];
+ this->data[i] = this->data[largest];
+ this->data[largest] = temp;
Heapify(largest,heapsize);
}
}
@@ -109,21 +109,21 @@
template <class T>
void VDKHeap<T>::BuildHeap(void)
{
- for (int i = (size()-1)/2 ; i >= 0; i--)
- Heapify(i,size());
+ for (int i = (this->size()-1)/2 ; i >= 0; i--)
+ Heapify(i,this->size());
}
// HEAPSORT
template <class T>
void VDKHeap<T>::Sort(void)
{
- int heapsize = size();
+ int heapsize = this->size();
int i = heapsize-1;
for(; i > 0; i--)
{
- T temp = data[0];
- data[0] = data[i];
- data[i] = temp;
+ T temp = this->data[0];
+ this->data[0] = this->data[i];
+ this->data[i] = temp;
heapsize--;
Heapify(0,heapsize);
}

View File

@ -1,3 +1,3 @@
C++ wrapper for GTK+ toolkit
WWW: http://vdkbuilder.sourceforge.net/
WWW: http://vdklib.sourceforge.net/