fix for 4-STABLE

Submitted by:  vs
This commit is contained in:
Trevor Johnson 2004-04-14 16:06:04 +00:00
parent 1917c86eb9
commit 11de210aa4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107024
2 changed files with 18 additions and 7 deletions

View File

@ -21,12 +21,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on 4.x"
.endif
do-configure:
cd ${WRKSRC} && \
bash ./0 --prefix=${PREFIX} --datadir=${PREFIX}/share/pawm
@ -60,4 +54,4 @@ do-install:
.endfor
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,17 @@
$FreeBSD$
Make ANSI C89/C90-compliant to compile with GCC 2.X.
author: Volker Stolz
--- src/wm.c.orig Wed Apr 14 16:32:24 2004
+++ src/wm.c Wed Apr 14 16:32:44 2004
@@ -311,8 +311,8 @@
char *tmpvalue;
- SAY ("Initializing window manager...");
int (*olderrorhandler) (Display *, XErrorEvent *);
+ SAY ("Initializing window manager...");
if (reference_count++) return !0;