- add a patch fixing .doc/.docx loading [1]

- workaround a pointyhat/tinderbox box, preventing it to figureout clang is
  needed as a dependency on 7 and 8 when host is 9+

Submitted by:	Meowthink <meowthink@gmail.com> (via office@ mailing list)
Obtained from:	libreoffice git master [1]
This commit is contained in:
Baptiste Daroussin 2012-04-26 14:55:09 +00:00
parent 63000530e3
commit 11cee2e8c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=295566
2 changed files with 19 additions and 2 deletions

View File

@ -7,7 +7,7 @@
.include "${.CURDIR}/Makefile.common"
PORTREVISION= 1
PORTREVISION= 2
MASTER_SITE_SUBDIR= src/${PORTVERSION}/
MASTER_SITES+= http://dev-www.libreoffice.org/src/:ext \
@ -217,7 +217,13 @@ CC= clang
CXX= clang++
CXXCPP= clang-cpp
CPP= clang-cpp
.if !exists(${DESTDIR}/usr/bin/clang)
# Work around a bug in pointyhat and tinderbox, prevent it to determine than
# clang from ports is needed when host is a freebsd 9+
.if defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
USE_BINUTILS= yes
.endif
.if !exists(/usr/bin/clang)
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang
USE_BINUTILS= yes
CXXCPP= clang++ -E

View File

@ -0,0 +1,11 @@
--- vbahelper/inc/vbahelper/vbaaccesshelper.hxx.orig 2012-04-26 10:20:44.869218717 +0200
+++ vbahelper/inc/vbahelper/vbaaccesshelper.hxx 2012-04-26 14:53:44.559610302 +0200
@@ -51,7 +51,7 @@
return xVBAFactory;
}
- VBAHELPER_DLLPRIVATE inline css::uno::Reference< css::uno::XInterface > createVBAUnoAPIServiceWithArgs( SfxObjectShell* pShell, const sal_Char* _pAsciiName, const css::uno::Sequence< css::uno::Any >& aArgs ) throw (css::uno::RuntimeException)
+ VBAHELPER_DLLPRIVATE inline css::uno::Reference< css::uno::XInterface > createVBAUnoAPIServiceWithArgs( SfxObjectShell* pShell, const sal_Char* _pAsciiName, const css::uno::Sequence< css::uno::Any >& aArgs ) throw (css::uno::Exception)
{
OSL_PRECOND( pShell, "createVBAUnoAPIService: no shell!" );
::rtl::OUString sVarName( ::rtl::OUString::createFromAscii( _pAsciiName ) );