- Fix the build with GCC 4.2 and unbreak [1]
- Patch things silently as we normally do - Usual cleanups of Makefile and pkg-descr Reported by: pointyhat (logs) [1]
This commit is contained in:
parent
f387edc8e9
commit
11a0f387a8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194909
@ -1,6 +1,6 @@
|
||||
# New ports collection makefile for: stegdetect
|
||||
# Date created: Jul 19, 2001
|
||||
# Whom: Mark Pulford <mark@kyne.com.au>
|
||||
# Date created: Jul 19, 2001
|
||||
# Whom: Mark Pulford <mark@kyne.com.au>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
@ -33,17 +33,11 @@ CONFIGURE_ENV+= PATH_GTKCONFIG="${GTK_CONFIG}"
|
||||
PLIST_SUB+= X11=""
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's;/usr/include/event;${LOCALBASE}/include;g' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} 's;/usr/include/event;${LOCALBASE}/include;g' \
|
||||
${WRKSRC}/configure
|
||||
.if defined(WITHOUT_X11)
|
||||
${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,13 @@
|
||||
--- stegdetect.c.orig Sat Apr 15 00:14:05 2006
|
||||
+++ stegdetect.c Sat Apr 15 00:14:40 2006
|
||||
@@ -78,7 +78,6 @@
|
||||
float DCThist[257];
|
||||
float scale = 1; /* Sensitivity scaling */
|
||||
|
||||
-static int debug = 0;
|
||||
static int quiet = 0;
|
||||
static int ispositive = 0; /* Current images contain stego */
|
||||
static char *transformname; /* Current transform name */
|
||||
@@ -1227,7 +1227,7 @@
|
||||
strlcat(outbuf, quality(tmp, stars), sizeof(outbuf));
|
||||
flag = 1;
|
||||
|
@ -3,11 +3,11 @@ in images. It is capable of detecting several different
|
||||
steganographic methods to embed hidden information in JPEG images.
|
||||
Currently, the detectable schemes are:
|
||||
|
||||
* jsteg
|
||||
* jphide (unix and windows)
|
||||
* invisible secrets
|
||||
* outguess 01.3b
|
||||
* F5
|
||||
# appendX and camouflage
|
||||
* jsteg
|
||||
* jphide (unix and windows)
|
||||
* invisible secrets
|
||||
* outguess 01.3b
|
||||
* F5
|
||||
* appendX and camouflage
|
||||
|
||||
WWW: http://www.outguess.org/detection.php
|
||||
|
Loading…
Reference in New Issue
Block a user