Import of tcb v1.4a

Tcb is a file viewer that works on a terminal. It allows
view file in ASCII or HEX format.

PR:		ports/8911
Submitted by:	andy@icc.surw.chel.su
This commit is contained in:
Justin M. Seger 1998-12-24 13:49:52 +00:00
parent 3c349dc55e
commit 1172e97bde
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15587
6 changed files with 88 additions and 0 deletions

35
misc/tcb/Makefile Normal file
View File

@ -0,0 +1,35 @@
# New ports collection makefile for: tcb
# Version required: 1.4a
# Date created: 1 December 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= tcb-1.4a
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.osk.3web.ne.jp/~moody/tcbj/
MASTER_SITE_SUBDIR= utils/file
MAINTAINER= andy@icc.surw.chel.su
USE_GMAKE= yes
MAN1= tcb.1
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/tcb ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/tcb
@ ${INSTALL_DATA} ${WRKSRC}/tcbrc ${PREFIX}/share/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/HELP ${PREFIX}/share/tcb
@ ${INSTALL_MAN} ${WRKSRC}/doc/tcb.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/CHANGES ${PREFIX}/share/doc/tcb
@ ${INSTALL_DATA} ${WRKSRC}/doc/COPYING ${PREFIX}/share/doc/tcb
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/tcb
.endif
.include <bsd.port.mk>

1
misc/tcb/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (tcb-1.4a.tar.gz) = 6f4888ed656aacaf718d2a72d17e0b91

39
misc/tcb/files/patch-aa Normal file
View File

@ -0,0 +1,39 @@
--- config.sh.orig Mon Nov 23 09:51:15 1998
+++ config.sh Thu Dec 24 08:41:14 1998
@@ -56,20 +56,24 @@
fi
fi
+if [ `uname` = FreeBSD ]; then # FreeBSD
+LIB=$USR_DIR/share/$TCB
+else
LIB=$USR_DIR/lib/$TCB
+fi
BIN=$USR_DIR/bin
MAN=$USR_DIR/man/man1
cat >> .config <<EOF
-CC= gcc
+CC?= gcc
#CFLAGS= -Wall -O2 -g
-CFLAGS= -Wall -O2
+CFLAGS?= -Wall -O2
#LDFLAGS=
LDFLAGS= -s
OBJS= alloc.o child.o code.o disp.o fork.o init.o key.o menu.o \\
mode.o scroll.o shell.o str.o sub.o tc.o tcb.o vt.o
EOF
-if which grep >/dev/null && make -v 2>&1|grep 'GNU Make' >/dev/null 2>&1 && which sed >/dev/null; then
+if which grep >/dev/null && gmake -v 2>&1|grep 'GNU Make' >/dev/null 2>&1 && which sed >/dev/null; then
cat >> .config <<EOF
PROT= mode.P tc.P tcb.P
@@ -113,7 +117,7 @@
cat > install.sh <<EOF
#! /bin/sh
-cd src; make; cd ..
+cd src; gmake; cd ..
echo 'Installing tcb:'
mkdir -p \$1$BIN
mkdir -p \$1$LIB

1
misc/tcb/pkg-comment Normal file
View File

@ -0,0 +1 @@
File viewer for terminal.

4
misc/tcb/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
Tcb is a file viewer that works on a terminal. It allows
view file in ASCII or HEX format.
http://www.osk.3web.ne.jp/~moody/tcbj

8
misc/tcb/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/tcb
share/doc/tcb/CHANGES
share/doc/tcb/COPYING
share/doc/tcb/README
share/tcb/HELP
share/tcb/tcbrc
@dirrm share/doc/tcb
@dirrm share/tcb