x11/kde4-workspace: fix OpenGL test for nvidia-driver.
Restore patch introduced in r408463 and accidentially removed in r417328. MFH: 2016Q3
This commit is contained in:
parent
57882f6d13
commit
116239689b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422903
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= kde-workspace
|
||||
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11 kde
|
||||
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
|
||||
DIST_SUBDIR= KDE/${PORTVERSION}
|
||||
|
@ -0,0 +1,15 @@
|
||||
--- kwin/opengltest/CMakeLists.txt.orig 2014-11-06 22:36:58 UTC
|
||||
+++ kwin/opengltest/CMakeLists.txt
|
||||
@@ -2,9 +2,11 @@
|
||||
|
||||
set(kwin_opengl_test_SRCS opengltest.cpp )
|
||||
|
||||
+find_package(Threads)
|
||||
+
|
||||
kde4_add_executable(kwin_opengl_test ${kwin_opengl_test_SRCS})
|
||||
|
||||
-target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY})
|
||||
+target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
|
||||
|
||||
install(TARGETS kwin_opengl_test DESTINATION ${LIBEXEC_INSTALL_DIR} )
|
||||
|
Loading…
Reference in New Issue
Block a user