net-im/gajim: update to 1.0.1

- convert to using distutils and update dependencies
- comment off GUPNP and AVAHI options, because corresponding dependencies
  are only work with python 2.x
- make NLS option default since gettext is used upon install
- SPELL option now using gspell instead of gtkspell. But, for some reason
  our Gspell.language_get_available() return empty list, so this feature
  doesn't work at the moment
- there are not PORTDOCS anymore, so remove handling of them
- actualize pkg-descr
- remove pkg-message because OTR is not ported to gajim 1.0, and CRYPTO
  option is self-descriptive. User can realize where plugins are stored
  by consulting official docs

Changelog:
https://dev.gajim.org/gajim/gajim/blob/gajim-1.0.1/ChangeLog

The main visible change is that gajim now requires Python 3.5+ and GTK3

PR:		226794
Submitted by:   Greg V <greg@unrelenting.technology> (based on)
This commit is contained in:
Ruslan Makhmatkhanov 2018-04-11 21:06:38 +00:00
parent 7a851d7b29
commit 1143d9c38e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=467113
6 changed files with 36 additions and 1435 deletions

View File

@ -2,56 +2,46 @@
# $FreeBSD$
PORTNAME= gajim
PORTVERSION= 0.16.9
DISTVERSION= 1.0.1
CATEGORIES= net-im
MASTER_SITES= http://gajim.org/downloads/0.16/
MASTER_SITES= http://gajim.org/downloads/1.0/
MAINTAINER= rm@FreeBSD.org
COMMENT= Jabber client based on a plugin system
COMMENT= GTK+ Jabber client
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nbxmpp>=0.6.4:net-im/py-nbxmpp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=0.12:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nbxmpp>0:net-im/py-nbxmpp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-gnupg>0:security/py-python-gnupg@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}cairo>0:graphics/py-cairo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
NO_ARCH= yes
USES= cpe dos2unix gmake localbase pathfix python:2.7 tar:bzip2
USE_GNOME= intltool pygtk2
USES= cpe dos2unix python:3.5+ tar:bzip2
USE_PYTHON= autoplist distutils
USE_GNOME= intltool pygobject3
USE_XORG= x11 xext xscrnsaver
DOS2UNIX_FILES= src/plugins/plugins_i18n.py
GNU_CONFIGURE= yes
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD}
DOS2UNIX_FILES= gajim/plugins/plugins_i18n.py
INSTALLS_ICONS= yes
OPTIONS_DEFINE= AVAHI CRYPTO DBUS DOCS GUPNP NLS SPELL
OPTIONS_DEFAULT=DBUS SPELL
OPTIONS_SUB= yes
OPTIONS_DEFINE= CRYPTO DBUS DOCS NLS SPELL
OPTIONS_DEFAULT=DBUS NLS SPELL
CRYPTO_DESC= End to end encryption support
GUPNP_DESC= UPnP IGD protocol support
SPELL_DESC= Spell checking support
AVAHI_RUN_DEPENDS= avahi-discover:net/py-avahi@${PY_FLAVOR}
# GUPNP_DESC= UPnP IGD protocol support
# net/py-avahi and net/gupnp-idg is python 2.x only right now
# AVAHI_RUN_DEPENDS= avahi-discover:net/py-avahi@${PY_FLAVOR}
# GUPNP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gupnp/__init__.py:net/gupnp-igd@${PY_FLAVOR}
CRYPTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR}
DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.82.2:devel/py-dbus@${PY_FLAVOR}
GUPNP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gupnp/__init__.py:net/gupnp-igd
NLS_USES= gettext
SPELL_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
PORTDOCS= AUTHORS ChangeLog README
SUB_FILES= pkg-message
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
pre-build:
${PYTHON_CMD} -m compileall ${WRKSRC}/src
${PYTHON_CMD} -O -m compileall ${WRKSRC}/src
SPELL_LIB_DEPENDS= libgspell-1.so:textproc/gspell
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1517301219
SHA256 (gajim-0.16.9.tar.bz2) = 21b3973676fb04c8b665c83e65377623f321754634d87e3b072f2a7c77fb086c
SIZE (gajim-0.16.9.tar.bz2) = 4469275
TIMESTAMP = 1523464700
SHA256 (gajim-1.0.1.tar.bz2) = 2cb4bf113d2c4312967ea4c33e044a81c1b17c34fc572925cca6c30d82e6d69b
SIZE (gajim-1.0.1.tar.bz2) = 5959011

View File

@ -1,43 +0,0 @@
--- src/Makefile.in.orig 2014-10-04 21:38:15 UTC
+++ src/Makefile.in
@@ -314,12 +314,26 @@
gajimsrcdir = $(gajim_srcdir)
nobase_dist_gajimsrc_PYTHON = \
$(srcdir)/*.py \
+ $(srcdir)/*.pyc \
+ $(srcdir)/*.pyo \
$(srcdir)/common/*.py \
+ $(srcdir)/common/*.pyc \
+ $(srcdir)/common/*.pyo \
$(srcdir)/common/protocol/*.py \
+ $(srcdir)/common/protocol/*.pyc \
+ $(srcdir)/common/protocol/*.pyo \
$(srcdir)/common/zeroconf/*.py \
+ $(srcdir)/common/zeroconf/*.pyc \
+ $(srcdir)/common/zeroconf/*.pyo \
$(srcdir)/command_system/*.py \
+ $(srcdir)/command_system/*.pyc \
+ $(srcdir)/command_system/*.pyo \
$(srcdir)/command_system/implementation/*.py \
- $(srcdir)/plugins/*.py
+ $(srcdir)/command_system/implementation/*.pyc \
+ $(srcdir)/command_system/implementation/*.pyo \
+ $(srcdir)/plugins/*.py \
+ $(srcdir)/plugins/*.pyc \
+ $(srcdir)/plugins/*.pyo
MAINTAINERCLEANFILES = Makefile.in
all: all-am
@@ -379,11 +393,7 @@
$(MKDIR_P) "$(DESTDIR)$(gajimsrcdir)/$$dir"; }; \
echo " $(INSTALL_DATA) $$xfiles '$(DESTDIR)$(gajimsrcdir)/$$dir'"; \
$(INSTALL_DATA) $$xfiles "$(DESTDIR)$(gajimsrcdir)/$$dir" || exit $$?; }; \
- done; \
- if test -n "$$dlist"; then \
- $(am__py_compile) --destdir "$(DESTDIR)" \
- --basedir "$(gajimsrcdir)" $$dlist; \
- else :; fi; }
+ done; }
uninstall-nobase_dist_gajimsrcPYTHON:
@$(NORMAL_UNINSTALL)

View File

@ -1,42 +0,0 @@
Gajim has been installed.
Gajim supports plugins:
Edit / Plugins
Plugins are installed in:
~/.local/share/gajim/plugins
And configuration for plugins is located in:
~/.config/gajim/pluginsconfig
To use encryption you may use either of the following:
E2EE (End to End message Encryption)
https://www.dlitz.net/software/pycrypto/
https://en.wikipedia.org/wiki/End-to-end_encryption
Enable option CRYPTO in make config
Note that CRYPTO should not be enabled if you intend to use
below explained OTR
OTR (Off-the-Record Messaging) * Recommended
https://otr.cypherpunks.ca/
https://en.wikipedia.org/wiki/Off-the-Record_Messaging
If you wish to use OTR, install it from Plugins:
Edit / Plugins / Off-The-Record Encryption
To use OTR, you need to generate a key from OTR plugin configuration

View File

@ -1,23 +1,24 @@
The goal of Gajim is to provide a full featured and easy to use Jabber
The goal of Gajim is to provide a full featured and easy to use XMPP
client. Gajim works nicely with GNOME, but does not require it to run.
It is released under the GNU General Public License.
FEATURES:
* Tabbed chat window
* Group chat support (with MUC protocol)
* Emoticons, Avatars, File transfer, Room Bookmarks
* Tabbed chat window and single window modes
* Group chat support (with Multi-User Chat protocol)
* Emoticons, avatars, PEP (user activity, mood and tune)
* Audio / video conferences
* Metacontacts Support
* Trayicon, Speller, extented chat history functionalities
* File transfer, room bookmarks
* Metacontacts support
* Trayicon, speller, extended chat history functionalities
* TLS, GPG and End-To-End encryption support (with SSL legacy support)
* Transport Registration support
* Service Discovery including Nodes
* Transport registration support
* Service discovery including nodes, user search
* Wikipedia, dictionary and search engine lookup
* Multiple accounts support
* DBus Capabilities
* XML Console
* DBus capabilities
* XML console
* Link local (bonjour / zeroconf), BOSH
* Other features via plugins
* Gajim is available in 25 languages
* Gajim is available in 29 languages
WWW: http://www.gajim.org/
WWW: https://gajim.org/

File diff suppressed because it is too large Load Diff