Initial import of xtet42 version 2.21.
A one of two player t*tris game. PR: 10096 Submitted by: Gianmarco Giovannelli <gmarco@giovannelli.it>
This commit is contained in:
parent
113be388dc
commit
113c308a1b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17996
32
games/xtet42/Makefile
Normal file
32
games/xtet42/Makefile
Normal file
@ -0,0 +1,32 @@
|
||||
# New ports collection makefile for: xtet42
|
||||
# Version required: 2.21
|
||||
# Date created: 14 Feb 1999
|
||||
# Whom: gmarco@scotty.masternet.it
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xtet42-2.21
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.pvv.ntnu.no/~oyvindmo/xtet42/
|
||||
|
||||
MAINTAINER= freebsd@scotty.masternet.it
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-setgid=games
|
||||
|
||||
MAN6= xtet42.6
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/lib/X11/xtet42
|
||||
@chown games:games ${PREFIX}/lib/X11/xtet42
|
||||
@chmod 775 ${PREFIX}/lib/X11/xtet42
|
||||
${INSTALL} -c -m 2755 -g games ${WRKSRC}/xtet42 ${PREFIX}/bin
|
||||
${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore
|
||||
${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore.single ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore.single
|
||||
${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.unlock
|
||||
${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.log
|
||||
${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${PREFIX}/man/man6
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/xtet42/distinfo
Normal file
1
games/xtet42/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (xtet42-2.21.tar.gz) = 20683a78fb3a18c4493f313ee7ce3cd7
|
20
games/xtet42/files/patch-aa
Normal file
20
games/xtet42/files/patch-aa
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.in.orig Mon Feb 15 00:36:53 1999
|
||||
+++ Makefile.in Mon Feb 15 00:41:28 1999
|
||||
@@ -24,7 +24,7 @@
|
||||
libdir = @libdir@
|
||||
localstatedir = @localstatedir@
|
||||
mandir = @mandir@
|
||||
-hiscoredir = $(localstatedir)/$(PACKAGE)
|
||||
+hiscoredir = $(PREFIX)/lib/X11/$(PACKAGE)
|
||||
|
||||
_Ver = $(VERSION)
|
||||
_Lock = $(hiscoredir)/.xtet42.lock
|
||||
@@ -37,6 +37,8 @@
|
||||
-D_Hiscore=\"$(_Hiscore)\" -D_Hione=\"$(_Hione)\" \
|
||||
-D_Log=\"$(_Log)\" -D_Ver=\"$(_Ver)\"
|
||||
|
||||
+
|
||||
+all: xtet42
|
||||
|
||||
xtet42: $(OBJS)
|
||||
$(CC) $(LDFLAGS) -o xtet42 $(OBJS)
|
31
games/xtet42/files/patch-ab
Normal file
31
games/xtet42/files/patch-ab
Normal file
@ -0,0 +1,31 @@
|
||||
--- xtet42.c.orig Mon Feb 15 00:37:09 1999
|
||||
+++ xtet42.c Mon Feb 15 00:39:51 1999
|
||||
@@ -67,23 +67,23 @@
|
||||
#endif
|
||||
|
||||
#ifndef _Lock
|
||||
-#define _Lock "/local/games/lib/xtet42/.xtet42.lock"
|
||||
+#define _Lock "/usr/X11R6/lib/X11/xtet42/.xtet42.lock"
|
||||
#endif
|
||||
|
||||
#ifndef _Unlock
|
||||
-#define _Unlock "/local/games/lib/xtet42/.xtet42.unlock"
|
||||
+#define _Unlock "/usr/X11R6/lib/X11/xtet42/.xtet42.unlock"
|
||||
#endif
|
||||
|
||||
#ifndef _Log
|
||||
-#define _Log "/local/games/lib/xtet42/.xtet42.log"
|
||||
+#define _Log "/usr/X11R6/lib/X11/xtet42/.xtet42.log"
|
||||
#endif
|
||||
|
||||
#ifndef _Hiscore
|
||||
-#define _Hiscore "/local/games/lib/xtet42/.xtet42.hiscore"
|
||||
+#define _Hiscore "/usr/X11R6/lib/X11/xtet42/.xtet42.hiscore"
|
||||
#endif
|
||||
|
||||
#ifndef _Hione
|
||||
-#define _Hione "/local/games/lib/xtet42/.xtet42.hiscore.single"
|
||||
+#define _Hione "/usr/X11R6/lib/X11/xtet42/.xtet42.hiscore.single"
|
||||
#endif
|
||||
|
||||
static int bricks[7][4][4][4]=
|
1
games/xtet42/pkg-comment
Normal file
1
games/xtet42/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A one or two player t*tris game.
|
18
games/xtet42/pkg-descr
Normal file
18
games/xtet42/pkg-descr
Normal file
@ -0,0 +1,18 @@
|
||||
Xtet42 is a one or two player version of T*tris. The game was written
|
||||
by Hugo Eide Gunnarsen in 1991. The game is very fun and very
|
||||
addictive. It is also astonishingly pretty to be an old X11-game.
|
||||
|
||||
In january 1999 I picked up the code to get rid of a few bugs and
|
||||
limitations that annoyed me. I also converted the build-mechanism to
|
||||
GNU autoconf.
|
||||
|
||||
The result is xtet42-2.21.
|
||||
|
||||
Please report bugs to : Steinar Hamre <steinarh@pvv.ntnu.no>
|
||||
|
||||
---
|
||||
|
||||
Homepage: http://www.pvv.ntnu.no/~oyvindmo/xtet42
|
||||
Distfile : xtet42-2.21.tar.gz (38kb)
|
||||
|
||||
- ported to FreeBSD by Gianmarco (gmarco@giovannelli.it)
|
6
games/xtet42/pkg-plist
Normal file
6
games/xtet42/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
bin/xtet42
|
||||
lib/X11/xtet42/.xtet42.hiscore.single
|
||||
lib/X11/xtet42/.xtet42.hiscore
|
||||
lib/X11/xtet42/.xtet42.unlock
|
||||
lib/X11/xtet42/.xtet42.log
|
||||
@dirrm lib/X11/xtet42
|
Loading…
Reference in New Issue
Block a user