Add back xgfe, which was prematurely removed by will

This commit is contained in:
Kris Kennaway 2002-05-24 11:50:07 +00:00
parent 4d6de4bdae
commit 11299cca11
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=59887
9 changed files with 148 additions and 0 deletions

View File

@ -149,6 +149,7 @@
SUBDIR += wingz
SUBDIR += wingz3
SUBDIR += wmcalc
SUBDIR += xgfe
SUBDIR += xgobi
SUBDIR += xgraph
SUBDIR += xldlas

31
math/xgfe/Makefile Normal file
View File

@ -0,0 +1,31 @@
# New ports collection makefile for: xgfe
# Date created: 24 March 1998
# Whom: Matthew Hunt <mph@pobox.com>
#
# $FreeBSD$
#
PORTNAME= xgfe
PORTVERSION= 2.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= mph
MAINTAINER= mph@freebsd.org
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_QT_VER= 1
USE_X_PREFIX= yes
MAKE_ENV= X11BASE=$(X11BASE) PREFIX=$(PREFIX)
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS=$(NOPORTDOCS)
.endif
WRKSRC= $(WRKDIR)/$(DISTNAME)/source
post-extract:
cd $(WRKSRC) && ${RM} Makefile && ${LN} -s Makefile.freebsd-gcc Makefile
.include <bsd.port.mk>

1
math/xgfe/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (xgfe-2.0.tar.gz) = 2994ae3e9475b1fcb4eb7791ca3c33ae

44
math/xgfe/files/patch-aa Normal file
View File

@ -0,0 +1,44 @@
--- Makefile.freebsd-gcc.orig Sun Jun 7 13:12:00 1998
+++ Makefile.freebsd-gcc Fri May 24 04:40:34 2002
@@ -7,13 +7,14 @@
####### Compiler, tools and options
-CC = gcc
-CFLAGS = -Wall -W -O2 -fno-strength-reduce
-INCPATH = -I$(QTDIR)/include
-LINK = gcc
+#CC = gcc
+#CFLAGS = -Wall -W -O2 -fno-strength-reduce
+QTDIR = $(X11BASE)
+INCPATH = -I$(X11BASE)/include/X11/qt1
+LINK = $(CXX)
LFLAGS =
-LIBS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -lX11
-MOC = moc
+LIBS = -L$(QTDIR)/lib -lqt1 -L$(X11BASE)/lib -lX11
+MOC = ${X11BASE}/bin/moc1
####### Files
@@ -224,16 +225,16 @@
.SUFFIXES: .cpp .cxx .cc .C .c
.cpp.o:
- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
.cxx.o:
- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
.cc.o:
- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
.C.o:
- $(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<
+ $(CXX) -c $(CFLAGS) $(INCPATH) -o $@ $<
.c.o:
$(CC) -c $(CFLAGS) $(INCPATH) -o $@ $<

28
math/xgfe/files/patch-ab Normal file
View File

@ -0,0 +1,28 @@
--- Makefile.common.orig Tue May 26 22:09:43 1998
+++ Makefile.common Wed Jun 10 15:00:13 1998
@@ -2,8 +2,8 @@
# modify starting here
-INSTALL_BIN = /usr/local/bin
-INSTALL_DOC = /usr/local/doc/xgfe-$(VERSION)
+INSTALL_BIN = $(PREFIX)/bin
+INSTALL_DOC = $(PREFIX)/share/doc/xgfe
STATIC_TARGET = xgfe-static
# end modifications
@@ -15,10 +15,11 @@
strip $(STATIC_TARGET)
install:
- cp $(TARGET) $(INSTALL_BIN)
+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(INSTALL_BIN)
+.if !defined(NOPORTDOCS)
mkdir -p $(INSTALL_DOC)
- cp ../doc/* $(INSTALL_DOC)/
- strip $(INSTALL_BIN)/$(TARGET)
+ $(BSD_INSTALL_DATA) ../doc/* $(INSTALL_DOC)/
+.endif
uninstall:
rm $(INSTALL_BIN)$(TARGET)

12
math/xgfe/files/patch-ac Normal file
View File

@ -0,0 +1,12 @@
--- xgfeMainData.cpp.orig Sun Jun 7 14:39:29 1998
+++ xgfeMainData.cpp Sat Feb 12 05:00:10 2000
@@ -34,6 +34,9 @@
#include <qpushbt.h>
#include <qlayout.h>
+#define QColor(i) (QColor)(i)
+#define QRgb(i) (QRgb)(i)
+
xgfeMainData::xgfeMainData
(
QWidget* parent = 0,

1
math/xgfe/pkg-comment Normal file
View File

@ -0,0 +1 @@
An X11 front-end for Gnuplot

2
math/xgfe/pkg-descr Normal file
View File

@ -0,0 +1,2 @@
An X11-based front-end for Gnuplot, written in C++ with the
Qt library.

28
math/xgfe/pkg-plist Normal file
View File

@ -0,0 +1,28 @@
bin/xgfe
share/doc/xgfe/CHANGES
share/doc/xgfe/curve-fitting.gif
share/doc/xgfe/features.html
share/doc/xgfe/file-options.gif
share/doc/xgfe/filelegendtitle.gif
share/doc/xgfe/filemenu.gif
share/doc/xgfe/fileplottypes.gif
share/doc/xgfe/filestyles.gif
share/doc/xgfe/latexterm.gif
share/doc/xgfe/legend-options.gif
share/doc/xgfe/mainwindow.gif
share/doc/xgfe/multi-files.gif
share/doc/xgfe/multi-funcs.gif
share/doc/xgfe/open.gif
share/doc/xgfe/optionsmenu.gif
share/doc/xgfe/pbmterm.gif
share/doc/xgfe/plot-size.gif
share/doc/xgfe/psterm.gif
share/doc/xgfe/rawgnu.gif
share/doc/xgfe/screenshots.html
share/doc/xgfe/terminals.gif
share/doc/xgfe/ticsoptions.gif
share/doc/xgfe/xgfe-abb.jpg
share/doc/xgfe/xgfe-docs.html
share/doc/xgfe/xgfe-main.jpg
share/doc/xgfe/xgfe.html
@dirrm share/doc/xgfe