- Fix build under clang 11

- add missing dependancies
This commit is contained in:
Diane Bruce 2020-08-24 16:24:07 +00:00
parent bf81900f60
commit 111ecda414
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546096
4 changed files with 45 additions and 6 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= xdx
PORTVERSION= 2.4
PORTREVISION= 6
PORTREVISION= 7
CATEGORIES= comms hamradio
MASTER_SITES= http://www.chronos.org.uk/download/ \
LOCAL/db
@ -13,13 +13,16 @@ COMMENT= Amateur Radio DX cluster monitor
LICENSE= GPLv2
USES= gmake gnome pkgconfig
USE_GNOME= gtk20
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
USES= gettext gmake gnome pkgconfig
USE_GNOME= cairo gtk20 gdkpixbuf2
GNU_CONFIGURE= yes
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g'
#post-patch:
# @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
# 's|-D.*_DISABLE_DEPRECATED||g'
.include <bsd.port.mk>

View File

@ -0,0 +1,15 @@
--- src/Makefile.in.orig 2007-11-21 17:46:24 UTC
+++ src/Makefile.in
@@ -181,11 +181,7 @@ INCLUDES = \
@GTK_CFLAGS@ -I.. \
-DPACKAGE_DATA_DIR=\"$(datadir)/xdx\" \
-DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\" \
- -DPACKAGE_SOURCE_DIR=\"$(srcdir)\" \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED
+ -DPACKAGE_SOURCE_DIR=\"$(srcdir)\"
xdx_SOURCES = \
gui.h \

View File

@ -0,0 +1,10 @@
--- src/gui.c.orig 2020-08-23 16:44:09 UTC
+++ src/gui.c
@@ -41,6 +41,7 @@
#include "text.h"
extern preferencestype preferences;
+guitype *gui;
static void on_highcheck_toggled (GtkToggleButton *togglebutton, gpointer user_data);
static void on_soundcheck_toggled (GtkToggleButton *togglebutton, gpointer user_data);

View File

@ -0,0 +1,11 @@
--- src/gui.h.orig 2006-02-26 19:41:12 UTC
+++ src/gui.h
@@ -49,7 +49,7 @@ typedef struct guitype {
gchar *high8tagname;
} guitype;
-guitype *gui;
+extern guitype *gui;
guitype *new_gui(void);
void create_mainwindow (void);