upgrade to 1.6.1

PR:		58335
Submitted by:	AMAKAWA Shuhei <sa264@cam.ac.uk>
This commit is contained in:
Ying-Chieh Liao 2003-11-13 05:33:55 +00:00
parent 7affea4639
commit 1115ae8703
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93863
15 changed files with 276 additions and 30 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= hdf5
PORTVERSION= 1.4.5
PORTVERSION= 1.6.1
CATEGORIES= graphics
MASTER_SITES= http://fresh.t-systems-sfr.com/unix/src/misc/
@ -33,11 +33,11 @@ post-patch:
s|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g ; \
s|-lcipher||g' \
${WRKSRC}/config/freebsd
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/config/gnu-flags
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
post-install:
.for file in gif2h5 h52gif h5debug h5dump h5import h5ls h5perf h5repart
@${STRIP_CMD} ${PREFIX}/bin/${file}
.for i in gif2h5 h52gif h5createU8 h5debug h5diff h5dump h5import h5ls h5repart
@${STRIP_CMD} ${PREFIX}/bin/${i}
.endfor
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (hdf5-1.4.5.tar.gz) = 573b9001b00c3ba78f681babd4fe7520
MD5 (hdf5-1.6.1.tar.gz) = db1ea5374572412b6e75f7916effe064

View File

@ -0,0 +1,31 @@
--- c++/config/commence.in.orig Mon Jun 30 16:19:35 2003
+++ c++/config/commence.in Mon Oct 20 23:44:08 2003
@@ -27,7 +27,7 @@
RM=rm -f
CP=cp
INSTALL=@INSTALL@
-INSTALL_PROGRAM=@INSTALL_PROGRAM@
+INSTALL_PROGRAM=@INSTALL_SCRIPT@
INSTALL_DATA=@INSTALL_DATA@
TRACE=:
@@ -37,7 +37,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Obtain default library; the current version of libtool does not fully
@@ -60,8 +60,8 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
-EXAMPLEDIR=$(docdir)/hdf5/examples/c++
+DOCDIR=$(docdir)/doc/hdf5
+EXAMPLEDIR=$(docdir)/examples/hdf5/c++
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,5 +1,5 @@
--- config/commence.in.orig Sun Jul 7 20:15:36 2002
+++ config/commence.in Sun Jul 7 20:15:58 2002
--- config/commence.in.orig Tue Jul 22 23:39:43 2003
+++ config/commence.in Mon Oct 20 23:45:00 2003
@@ -26,7 +26,7 @@
RM=rm -f
CP=cp
@ -9,3 +9,24 @@
INSTALL_DATA=@INSTALL_DATA@
RUNSERIAL=@RUNSERIAL@
RUNPARALLEL=@RUNPARALLEL@
@@ -39,7 +39,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Shared libraries
@@ -57,9 +57,9 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
+DOCDIR=$(docdir)/doc/hdf5
SUBDOCDIR=
-EXAMPLEDIR=$(docdir)/hdf5/examples/c
+EXAMPLEDIR=$(docdir)/examples/hdf5/c
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,16 +1,17 @@
bin/gif2h5
bin/h52gif
bin/h5c++
bin/h5cc
bin/h5createU8
bin/h5debug
bin/h5diff
bin/h5dump
bin/h5import
bin/h5ls
bin/h5perf
bin/h5redeploy
bin/h5repart
include/H5ACpublic.h
include/H5AbstractDs.h
include/H5Alltypes.h
include/H5Apublic.h
include/H5AtomType.h
include/H5Attribute.h
@ -30,6 +31,7 @@ include/H5Epublic.h
include/H5Exception.h
include/H5FDcore.h
include/H5FDfamily.h
include/H5FDfphdf5.h
include/H5FDgass.h
include/H5FDlog.h
include/H5FDmpio.h
@ -40,6 +42,7 @@ include/H5FDsec2.h
include/H5FDsrb.h
include/H5FDstdio.h
include/H5FDstream.h
include/H5FPpublic.h
include/H5FaccProp.h
include/H5FcreatProp.h
include/H5File.h
@ -50,7 +53,6 @@ include/H5Group.h
include/H5HGpublic.h
include/H5HLpublic.h
include/H5IdComponent.h
include/H5Idtemplates.h
include/H5Include.h
include/H5IntType.h
include/H5Ipublic.h
@ -76,3 +78,31 @@ lib/libhdf5.settings
lib/libhdf5.so
lib/libhdf5.so.0
lib/libhdf5_cpp.a
share/examples/hdf5/c/h5_attribute.c
share/examples/hdf5/c/h5_chunk_read.c
share/examples/hdf5/c/h5_compound.c
share/examples/hdf5/c/h5_drivers.c
share/examples/hdf5/c/h5_extend_write.c
share/examples/hdf5/c/h5_group.c
share/examples/hdf5/c/h5_mount.c
share/examples/hdf5/c/h5_read.c
share/examples/hdf5/c/h5_reference.c
share/examples/hdf5/c/h5_select.c
share/examples/hdf5/c/h5_write.c
share/examples/hdf5/c/ph5example.c
share/examples/hdf5/c++/Attributes.h5
share/examples/hdf5/c++/Group.h5
share/examples/hdf5/c++/SDS.h5
share/examples/hdf5/c++/SDScompound.h5
share/examples/hdf5/c++/SDSextendible.h5
share/examples/hdf5/c++/Select.h5
share/examples/hdf5/c++/chunks.cpp
share/examples/hdf5/c++/compound.cpp
share/examples/hdf5/c++/create.cpp
share/examples/hdf5/c++/extend_ds.cpp
share/examples/hdf5/c++/h5group.cpp
share/examples/hdf5/c++/readdata.cpp
share/examples/hdf5/c++/writedata.cpp
@dirrm share/examples/hdf5/c
@dirrm share/examples/hdf5/c++
@dirrm share/examples/hdf5

View File

@ -7,7 +7,7 @@
#
PORTNAME= hdf5
PORTVERSION= 1.4.5
PORTVERSION= 1.6.1
CATEGORIES= graphics
MASTER_SITES= http://fresh.t-systems-sfr.com/unix/src/misc/
@ -33,11 +33,11 @@ post-patch:
s|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g ; \
s|-lcipher||g' \
${WRKSRC}/config/freebsd
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/config/gnu-flags
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
post-install:
.for file in gif2h5 h52gif h5debug h5dump h5import h5ls h5perf h5repart
@${STRIP_CMD} ${PREFIX}/bin/${file}
.for i in gif2h5 h52gif h5createU8 h5debug h5diff h5dump h5import h5ls h5repart
@${STRIP_CMD} ${PREFIX}/bin/${i}
.endfor
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (hdf5-1.4.5.tar.gz) = 573b9001b00c3ba78f681babd4fe7520
MD5 (hdf5-1.6.1.tar.gz) = db1ea5374572412b6e75f7916effe064

View File

@ -0,0 +1,31 @@
--- c++/config/commence.in.orig Mon Jun 30 16:19:35 2003
+++ c++/config/commence.in Mon Oct 20 23:44:08 2003
@@ -27,7 +27,7 @@
RM=rm -f
CP=cp
INSTALL=@INSTALL@
-INSTALL_PROGRAM=@INSTALL_PROGRAM@
+INSTALL_PROGRAM=@INSTALL_SCRIPT@
INSTALL_DATA=@INSTALL_DATA@
TRACE=:
@@ -37,7 +37,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Obtain default library; the current version of libtool does not fully
@@ -60,8 +60,8 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
-EXAMPLEDIR=$(docdir)/hdf5/examples/c++
+DOCDIR=$(docdir)/doc/hdf5
+EXAMPLEDIR=$(docdir)/examples/hdf5/c++
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,5 +1,5 @@
--- config/commence.in.orig Sun Jul 7 20:15:36 2002
+++ config/commence.in Sun Jul 7 20:15:58 2002
--- config/commence.in.orig Tue Jul 22 23:39:43 2003
+++ config/commence.in Mon Oct 20 23:45:00 2003
@@ -26,7 +26,7 @@
RM=rm -f
CP=cp
@ -9,3 +9,24 @@
INSTALL_DATA=@INSTALL_DATA@
RUNSERIAL=@RUNSERIAL@
RUNPARALLEL=@RUNPARALLEL@
@@ -39,7 +39,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Shared libraries
@@ -57,9 +57,9 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
+DOCDIR=$(docdir)/doc/hdf5
SUBDOCDIR=
-EXAMPLEDIR=$(docdir)/hdf5/examples/c
+EXAMPLEDIR=$(docdir)/examples/hdf5/c
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,16 +1,17 @@
bin/gif2h5
bin/h52gif
bin/h5c++
bin/h5cc
bin/h5createU8
bin/h5debug
bin/h5diff
bin/h5dump
bin/h5import
bin/h5ls
bin/h5perf
bin/h5redeploy
bin/h5repart
include/H5ACpublic.h
include/H5AbstractDs.h
include/H5Alltypes.h
include/H5Apublic.h
include/H5AtomType.h
include/H5Attribute.h
@ -30,6 +31,7 @@ include/H5Epublic.h
include/H5Exception.h
include/H5FDcore.h
include/H5FDfamily.h
include/H5FDfphdf5.h
include/H5FDgass.h
include/H5FDlog.h
include/H5FDmpio.h
@ -40,6 +42,7 @@ include/H5FDsec2.h
include/H5FDsrb.h
include/H5FDstdio.h
include/H5FDstream.h
include/H5FPpublic.h
include/H5FaccProp.h
include/H5FcreatProp.h
include/H5File.h
@ -50,7 +53,6 @@ include/H5Group.h
include/H5HGpublic.h
include/H5HLpublic.h
include/H5IdComponent.h
include/H5Idtemplates.h
include/H5Include.h
include/H5IntType.h
include/H5Ipublic.h
@ -76,3 +78,31 @@ lib/libhdf5.settings
lib/libhdf5.so
lib/libhdf5.so.0
lib/libhdf5_cpp.a
share/examples/hdf5/c/h5_attribute.c
share/examples/hdf5/c/h5_chunk_read.c
share/examples/hdf5/c/h5_compound.c
share/examples/hdf5/c/h5_drivers.c
share/examples/hdf5/c/h5_extend_write.c
share/examples/hdf5/c/h5_group.c
share/examples/hdf5/c/h5_mount.c
share/examples/hdf5/c/h5_read.c
share/examples/hdf5/c/h5_reference.c
share/examples/hdf5/c/h5_select.c
share/examples/hdf5/c/h5_write.c
share/examples/hdf5/c/ph5example.c
share/examples/hdf5/c++/Attributes.h5
share/examples/hdf5/c++/Group.h5
share/examples/hdf5/c++/SDS.h5
share/examples/hdf5/c++/SDScompound.h5
share/examples/hdf5/c++/SDSextendible.h5
share/examples/hdf5/c++/Select.h5
share/examples/hdf5/c++/chunks.cpp
share/examples/hdf5/c++/compound.cpp
share/examples/hdf5/c++/create.cpp
share/examples/hdf5/c++/extend_ds.cpp
share/examples/hdf5/c++/h5group.cpp
share/examples/hdf5/c++/readdata.cpp
share/examples/hdf5/c++/writedata.cpp
@dirrm share/examples/hdf5/c
@dirrm share/examples/hdf5/c++
@dirrm share/examples/hdf5

View File

@ -7,7 +7,7 @@
#
PORTNAME= hdf5
PORTVERSION= 1.4.5
PORTVERSION= 1.6.1
CATEGORIES= graphics
MASTER_SITES= http://fresh.t-systems-sfr.com/unix/src/misc/
@ -33,11 +33,11 @@ post-patch:
s|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g ; \
s|-lcipher||g' \
${WRKSRC}/config/freebsd
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/config/gnu-flags
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
post-install:
.for file in gif2h5 h52gif h5debug h5dump h5import h5ls h5perf h5repart
@${STRIP_CMD} ${PREFIX}/bin/${file}
.for i in gif2h5 h52gif h5createU8 h5debug h5diff h5dump h5import h5ls h5repart
@${STRIP_CMD} ${PREFIX}/bin/${i}
.endfor
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (hdf5-1.4.5.tar.gz) = 573b9001b00c3ba78f681babd4fe7520
MD5 (hdf5-1.6.1.tar.gz) = db1ea5374572412b6e75f7916effe064

View File

@ -0,0 +1,31 @@
--- c++/config/commence.in.orig Mon Jun 30 16:19:35 2003
+++ c++/config/commence.in Mon Oct 20 23:44:08 2003
@@ -27,7 +27,7 @@
RM=rm -f
CP=cp
INSTALL=@INSTALL@
-INSTALL_PROGRAM=@INSTALL_PROGRAM@
+INSTALL_PROGRAM=@INSTALL_SCRIPT@
INSTALL_DATA=@INSTALL_DATA@
TRACE=:
@@ -37,7 +37,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Obtain default library; the current version of libtool does not fully
@@ -60,8 +60,8 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
-EXAMPLEDIR=$(docdir)/hdf5/examples/c++
+DOCDIR=$(docdir)/doc/hdf5
+EXAMPLEDIR=$(docdir)/examples/hdf5/c++
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,5 +1,5 @@
--- config/commence.in.orig Sun Jul 7 20:15:36 2002
+++ config/commence.in Sun Jul 7 20:15:58 2002
--- config/commence.in.orig Tue Jul 22 23:39:43 2003
+++ config/commence.in Mon Oct 20 23:45:00 2003
@@ -26,7 +26,7 @@
RM=rm -f
CP=cp
@ -9,3 +9,24 @@
INSTALL_DATA=@INSTALL_DATA@
RUNSERIAL=@RUNSERIAL@
RUNPARALLEL=@RUNPARALLEL@
@@ -39,7 +39,7 @@
bindir=@bindir@
libdir=@libdir@
includedir=@includedir@
-docdir=@exec_prefix@/doc
+docdir=@exec_prefix@/share
PUB_LIB=$(LIB)
## Shared libraries
@@ -57,9 +57,9 @@
## Optional variables. We must declare them here because Irix pmake
## complains if it sees a reference to a variable which has never been
## defined. The main makefile is free to redefine these to something else.
-DOCDIR=$(docdir)
+DOCDIR=$(docdir)/doc/hdf5
SUBDOCDIR=
-EXAMPLEDIR=$(docdir)/hdf5/examples/c
+EXAMPLEDIR=$(docdir)/examples/hdf5/c
LIB=
LIB_SRC=
LIB_OBJ=

View File

@ -1,16 +1,17 @@
bin/gif2h5
bin/h52gif
bin/h5c++
bin/h5cc
bin/h5createU8
bin/h5debug
bin/h5diff
bin/h5dump
bin/h5import
bin/h5ls
bin/h5perf
bin/h5redeploy
bin/h5repart
include/H5ACpublic.h
include/H5AbstractDs.h
include/H5Alltypes.h
include/H5Apublic.h
include/H5AtomType.h
include/H5Attribute.h
@ -30,6 +31,7 @@ include/H5Epublic.h
include/H5Exception.h
include/H5FDcore.h
include/H5FDfamily.h
include/H5FDfphdf5.h
include/H5FDgass.h
include/H5FDlog.h
include/H5FDmpio.h
@ -40,6 +42,7 @@ include/H5FDsec2.h
include/H5FDsrb.h
include/H5FDstdio.h
include/H5FDstream.h
include/H5FPpublic.h
include/H5FaccProp.h
include/H5FcreatProp.h
include/H5File.h
@ -50,7 +53,6 @@ include/H5Group.h
include/H5HGpublic.h
include/H5HLpublic.h
include/H5IdComponent.h
include/H5Idtemplates.h
include/H5Include.h
include/H5IntType.h
include/H5Ipublic.h
@ -76,3 +78,31 @@ lib/libhdf5.settings
lib/libhdf5.so
lib/libhdf5.so.0
lib/libhdf5_cpp.a
share/examples/hdf5/c/h5_attribute.c
share/examples/hdf5/c/h5_chunk_read.c
share/examples/hdf5/c/h5_compound.c
share/examples/hdf5/c/h5_drivers.c
share/examples/hdf5/c/h5_extend_write.c
share/examples/hdf5/c/h5_group.c
share/examples/hdf5/c/h5_mount.c
share/examples/hdf5/c/h5_read.c
share/examples/hdf5/c/h5_reference.c
share/examples/hdf5/c/h5_select.c
share/examples/hdf5/c/h5_write.c
share/examples/hdf5/c/ph5example.c
share/examples/hdf5/c++/Attributes.h5
share/examples/hdf5/c++/Group.h5
share/examples/hdf5/c++/SDS.h5
share/examples/hdf5/c++/SDScompound.h5
share/examples/hdf5/c++/SDSextendible.h5
share/examples/hdf5/c++/Select.h5
share/examples/hdf5/c++/chunks.cpp
share/examples/hdf5/c++/compound.cpp
share/examples/hdf5/c++/create.cpp
share/examples/hdf5/c++/extend_ds.cpp
share/examples/hdf5/c++/h5group.cpp
share/examples/hdf5/c++/readdata.cpp
share/examples/hdf5/c++/writedata.cpp
@dirrm share/examples/hdf5/c
@dirrm share/examples/hdf5/c++
@dirrm share/examples/hdf5