GNU editing macros with dynamic loading module function (binary only).

PR:		ports/8776
Submitted by:	Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
This commit is contained in:
Jun Kuriyama 1998-12-13 14:27:06 +00:00
parent 1d6f29e1d5
commit 10a16f1335
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15332
10 changed files with 140 additions and 0 deletions

View File

@ -0,0 +1,41 @@
# New ports collection makefile for: GNU emacs with dl
# Version required: 20.3
# Date created: 10 October 1998
# Whom: shige
#
# $Id$
#
DISTNAME= emacs-20.3
PKGNAME= emacs-dl-20.3
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_GNU}
PATCH_SITES= ftp://ftp.jaist.ac.jp/pub/GNU/elisp/emacs-20-dl/
PATCHFILES= emacs-20.3-dl.diff
PATCH_DIST_STRIP= -p1
MAINTAINER= shige@kuis.kyoto-u.ac.jp
RUN_DEPENDS= emacs-20.3:${.CURDIR}/../../editors/emacs20
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= i386--freebsd --with-x-toolkit --with-pop
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
EMACS_VER= 20.3
PLIST_SUB= EMACS_VER=${EMACS_VER}
.if defined(USE_XPGLIB)
.if (${USE_XPGLIB} == "YES")
CONFIGURE_ARGS+= --with-xpg4
.endif
.endif
pre-build:
@${RM} -rf ${WRKSRC}/info/*
do-install:
@${INSTALL} -c -s -m 555 -o root -g wheel ${WRKSRC}/src/emacs ${PREFIX}/bin/emacs-dl-${EMACS_VER}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (emacs-20.3.tar.gz) = 5aee43bb7c7267cc24b78011d280ecdc
MD5 (emacs-20.3-dl.diff) = 45e06de63c8bd8b272a7a3c517ad387f

View File

@ -0,0 +1,34 @@
--- src/Makefile.in.orig Thu Nov 19 00:28:38 1998
+++ src/Makefile.in Thu Nov 19 00:30:14 1998
@@ -126,6 +126,10 @@
#define LIBS_MACHINE
#endif
+#ifndef LIBS_XPG
+#define LIBS_XPG
+#endif
+
#ifndef LIB_MATH
# ifdef LISP_FLOAT_TYPE
# define LIB_MATH -lm
@@ -418,7 +422,11 @@
libexecdir=${exec_prefix}/libexec
archlibdir=${libexecdir}/emacs/${version}/${configuration}
#ifdef __FreeBSD__
+#ifdef __ELF__
+#define LINKER $(CC) -nostdlib -Wl,-export-dynamic -Wl,-R${archlibdir}
+#else /* not __ELF__ */
#define LINKER $(CC) -nostdlib -Wl,-R${archlibdir}
+#endif /* __ELF__ */
#else
#define LINKER $(CC) -nostdlib -rdynamic -Wl,-rpath,${archlibdir}
#endif
@@ -814,7 +822,7 @@
duplicated symbols. If the standard libraries were compiled
with GCC, we might need gnulib again after them. */
LIBES = $(LOADLIBES) $(LDLIBS) $(LIBX) $(LIBDL) LIBS_SYSTEM LIBS_MACHINE LIBS_TERMCAP \
- LIBS_DEBUG $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR)
+ LIBS_XPG LIBS_DEBUG $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR)
/* Enable recompilation of certain other files depending on system type. */

View File

@ -0,0 +1,16 @@
--- src/s/freebsd.h.orig Wed Nov 11 21:22:03 1998
+++ src/s/freebsd.h Wed Nov 11 21:52:19 1998
@@ -45,6 +45,13 @@
#define LIBS_SYSTEM -lutil
#define LIBS_TERMCAP -ltermcap
+/* Use XPG4 Library for FreeBSD */
+#if __FreeBSD_version >= 220000
+#ifdef USE_XPG
+#define LIBS_XPG -lxpg4
+#endif
+#endif
+
#define SYSV_SYSTEM_DIR
/* freebsd has POSIX-style pgrp behavior. */

View File

@ -0,0 +1,12 @@
--- configure.in.orig Sat Nov 21 08:59:52 1998
+++ configure.in Sat Nov 21 08:58:16 1998
@@ -57,6 +57,9 @@
AC_ARG_WITH(gssapi,
[ --with-gssapi support GSSAPI-authenticated POP],
[AC_DEFINE(GSSAPI)])
+AC_ARG_WITH(xpg4,
+[ --with-xpg4 support XPG4 library on FreeBSD system],
+[AC_DEFINE(USE_XPG)])
dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
dnl keep them together visually.

View File

@ -0,0 +1,12 @@
--- src/config.in.orig Sat Nov 21 09:00:30 1998
+++ src/config.in Sat Nov 21 09:00:58 1998
@@ -118,6 +118,9 @@
/* Define to support using a Hesiod database to find the POP server. */
#undef HESIOD
+/* Define to support using a XPG4 library on FreeBSD system. */
+#undef USE_XPG
+
/* Some things figured out by the configure script, grouped as they are in
configure.in. */
#ifndef _ALL_SOURCE /* suppress warning if this is pre-defined */

View File

@ -0,0 +1 @@
GNU editing macros with dynamic loading module function (binary only).

View File

@ -0,0 +1,12 @@
GNU Emacs is a self-documenting, customizable, extensible real-time
display editor (emacs binary only).
This package's emacs has a dynamic loading function.
Emacs binary is:
${PREFIX}/bin/emacs-dl-${EMACS_VER}
Dynamic loading patch:
ftp://ftp.jaist.ac.jp/pub/GNU/elisp/emacs-20-dl/emacs-${EMACS_VER}-dl.diff
--- Port by shige@kuis.kyoto-u.ac.jp

View File

@ -0,0 +1 @@
bin/emacs-dl-%%EMACS_VER%%

9
editors/emacs20-dl/scripts/configure vendored Normal file
View File

@ -0,0 +1,9 @@
#! /bin/sh
cd ${WRKSRC}
if [ -f /usr/lib/aout/crt0.o -a ! -f /usr/lib/crt0.o ]; then
sed -e "s|/usr/lib/crt0\.o|/usr/lib/aout/crt0.o|g" \
src/s/freebsd.h > src/s/freebsd.h.new || exit
mv -f src/s/freebsd.h.new src/s/freebsd.h
fi